Middle number
There is a sequence of integers, we have two operations now
1 add a: means add an integer a to the end of the sequence, forms a N+1 long sequence.
2 mid : Output the current sequence's middle numbera sequence's middle number is the middle position of the sequence when it's sorted by in creasing order.(if the sequence's length is even, then the middle position is the litter number's position of the two middle numbers)
example 1, sequence 1 2 13 14 15 16 and it's middle number is 13
example 2, sequence 1 3 5 7 10 11 17 and it's middle number is 7
example 3, 1 1 1 2 3 and it's middle number is 1
Input
The first line of the input gives the number of test cases T, for each test case the first line is the sequence's inital length N, the second line has N number represent the integer sequence. then third line is the operation number M then follows M lines, each line has the format either add a or mid (1<=N<=100000, 0<=M<=10000)
Output
each test case for each mid operation output the middle number
Sample Input
1
6
1 2 13 14 15 16
5
add 5
add 3
mid
add 20
mid
Sample Output
5
13
题目分析:数据结构题,使用一个大顶堆与一个小顶堆,时刻维护着大顶堆的元素小于小顶堆元素,并且大顶堆内元素的个与小顶内元素的个数相等或者比后者多一个,故每次查寻的结果都是大顶堆顶元素
n用STL实现堆操作
#include<iostream>
#include<set>
using namespace std;
multiset <int> small;
multiset <int, greater<int> > big;
int main()
{
int cas;
scanf("%d",&cas);
while(cas--){
int n,num;
scanf("%d",&n);
small.clear();
big.clear();
int nt = n;
while(nt--){
scanf("%d",&num);
small.insert(num);
}
for(int i = 0; i < (n+1)/2; i++){
big.insert(*(small.begin()));
small.erase(small.begin());
}
int m;
scanf("%d",&m);//getchar();
char op[100];
while(m--){
scanf("%s",&op);
if(!strcmp(op, "add"))
{
scanf("%d",&num);
if(num > *big.begin()){
small.insert(num);
}
else
big.insert(num);
if(small.size() > big.size()){
big.insert(*small.begin());
small.erase(small.begin());
}
else if(big.size() > small.size() + 1){
small.insert(*big.begin());
big.erase(big.begin());
}
}
else
printf("%d\n",*(big.begin()));
}
}
return 0;
}
分享到:
相关推荐
通过实例介绍了 cast(multiset() as) 的使用方法,以处理嵌套表的操作
在这个话题中,我们将深入探讨STL容器中的`multiset`,并结合VC6.0环境下的代码示例进行讲解。 **一、STL multiset简介** `multiset`是STL中的一种关联容器,它类似于`set`,但允许插入重复元素。`multiset`内部...
Almeza MultiSet是一款强大的软件全自动安装器,它专为那些希望简化软件部署和管理的“懒人”设计。这款工具能够帮助用户自动化地安装、配置和管理多种应用程序,极大地节省了手动安装软件的时间和精力。Pro6.2.0....
《Almeza MultiSet 6+ 修复更新详解:打造全自动软件安装体验》 在现代计算机使用中,软件安装往往是一项耗时且繁琐的工作。尤其是当需要安装大量软件时,手动逐一操作无疑会浪费大量的时间和精力。为此,专门用于...
MultiSet是一款界面简洁的自动程序安装工具。不需要编写程序,用这个程序可以是你从大量的程序安装过程中解放出来。并且可以在安装过程中实现注册信息的输入 Almeza MultiSet Pro 7.8.1绿色版 自动程序安装
在Python的世界里,`multiset_multicover`是一个不太常见的库,但它的存在是为了解决特定的问题。这个库名为`multiset_multicover-0.4-cp37-cp37m-win_amd64.whl`,它是一个专门为Python 3.7编译的二进制包,适用于...
安装说明:安装后先不要立即运行Almeza MultiSet,将内附的“activate_multiset.amltkey”文件复制到C:\Program Files\Almeza\MultiSet目录下面即是正式版。点击菜单View-->Language-->在General中选择...
《Almeza MultiSet——Windows自动安装软件利器详解》 在Windows操作系统中,软件的安装过程通常需要用户手动执行一系列步骤,这对于批量部署或者需要快速安装多款软件的场景而言,无疑增加了工作负担。为此,专业...
Almeza MultiSet可通过软件安装管理器将常用程序集成到一起,它先录制软件的安装过程,下次安装同一软件时就会采用“回放”的方式... 小提示:如果需要将MultiSet中的所有程序安装到位,那么直接选择“安装所有”即可
### C++ `multiset` 介绍及详细使用示例 #### 概述 在C++标准模板库(STL)中,`std::multiset`是一个关联容器,它能够存储可重复的元素,并且这些元素按照指定的排序规则进行排序。`std::multiset`中的元素默认...
### C++中的multiset容器详解 #### 引言 `multiset`是C++标准模板库(STL)中的一种关联容器,它主要用于存储数据,并能够从数据集合中取出数据。`multiset`的一个显著特点是它允许存储重复的键值,并且会自动根据...
让你从软件安装中解放,让你从此一键安装千万软件 让你从软件安装中解放,让你从此一键安装千万软件
标题中的"multiset_multicover-0.2-cp310-cp310-win32.whl"就是一个这样的库,它针对Python 3.10版本进行了优化,并且适用于Windows 32位系统。 首先,我们来理解一下`multiset_multicover`库。在数学和计算机科学...
Almeza MultiSet Pro 是一个自动安装程序用一个简单和方便的接口。很多时候,它需要花费大量的时间,用户在安装操作系统后,安装必要的程序。并在同一时间,用户需要更换光盘的CD-ROM和DVD-ROM驱动器,输入注册数据...
STL_multiset 方法:multisetst; 定义了一个multiset变量st,st里面可以存放T类型数据,并且能自动排序。开始st为空 排序规则:表达式”a<b为true,则a排在b前面 可用的方法 目的 格式 添加元素 st.insert ...
C++ STL入门教程(7) multimap、multiset的使用 本文主要介绍了C++ STL中multimap和multiset的使用方法,multimap是一对多索引,multiset是多元集合,都是STL容器中非常重要的组件。 一、multimap(一对多索引) ...
在C++标准库中,模板被广泛应用于STL(Standard Template Library,标准模板库),其中包括了各种容器如vector、map、multimap、set和multiset。这些容器都是模板类,它们提供了高效的数据组织和操作方式。 1. **...
在本例中,我们关注的是名为"multiset_multicover"的一个Python库,版本为0.3,它以whl(Wheel)格式提供,这是一种预编译的Python软件包格式,方便用户直接安装。 `multiset_multicover`库主要用于处理多重集...
Java中的多集您只需要一个文件: : 因为我使用的是SpotBugs,所以有spotbugs-annotations-3.1.0.jar。 但是您也可以删除这些注释。 我的博客: :
Multiset ( 1 , 2 , 3 ) + Multiset ( 3 , 4 , 5 ) // == Multiset(1, 2, 3, 3, 4, 5) // Difference Multiset ( 1 , 2 , 3 ) - Multiset ( 2 , 3 ) // == Multiset(1) // Intersection Multiset ( 1 , 2 , 3 ) & ...