`
Simone_chou
  • 浏览: 198031 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

The Unique MST(次小生成树)

    博客分类:
  • POJ
 
阅读更多
The Unique MST
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 20786   Accepted: 7314

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

 

      题意:

      给出 T 组数组,每组数据给出 N, M,代表有有 N 个节点, M 条无向边,问是否有唯一的一颗最小生成树,有则输出这个值,没有则输出 Not Unique!

 

      思路:

      次小生成树。先用 Prim 算法算出最小生成树,记录最小生成树的边是什么,然后枚举生成树的边,一条条删去,删去后再求一遍生成树,如果所构成的图连通且这个值与原来最小生成树的值相等则输出 Not Unique,如果没有则说明唯一。注意每次都要判断是否连通。

 

      AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef struct {
    int a, b, num;
} node;

node no[200005];
int root[505], path[505];
int n, m, cnt, sum;

void init() {
    for (int i = 1; i <= n; ++i)
        root[i] = i;
}

int Find (int x) {
    return x == root[x] ? x : root[x] = Find(root[x]);
}

bool cmp (node a, node b) { return a.num < b.num; }

bool test() {
    int num = 0;
    for (int i = 1; i <= n; ++i) {
        if (root[i] == i) ++num;
        if (num > 1) return false;
    }

    return true;
}

bool solve () {
    if (!test()) return false;

    for (int i = 0; i < cnt; ++i) {
        init();

        int ans = 0;
        for (int j = 0; j < m; ++j) {
            if (j == path[i]) continue;

            int A = Find(no[j].a);
            int B = Find(no[j].b);
            if (A != B) {
                ans += no[j].num;
                root[A] = B;
            }
        }
        if (!test()) continue;

        if (ans == sum) return false;
    }

    return true;
}

int main() {

    int t;
    scanf("%d", &t);

    while (t--) {
        scanf("%d%d", &n, &m);


        for (int i = 0; i < m; ++i) {
            scanf("%d%d%d", &no[i].a, &no[i].b, &no[i].num);
        }

        sort(no, no + m, cmp);

        init();
        cnt = sum = 0;
        for (int i = 0; i < m; ++i) {
            int A = Find(no[i].a);
            int B = Find(no[i].b);
            if (A != B) {
                root[A] = B;
                path[cnt++] = i;
                sum += no[i].num;
            }
        }

        if (solve()) printf("%d\n", sum);
        else printf("Not Unique!\n");

    }

    return 0;
}

 

 

 

分享到:
评论

相关推荐

    次小生成树(POJ 1679 The Unique MST)

    先利用prim算法求出最小生成树,然后通过往MST里加边来判断新生成的最小生成树是否具有最小的权值,POJ上The Unique MST(1679)题是要求判断最小生成树是否唯一,此题其实根本不用这样做,但是为了练习球次小生成树...

    Poj中的一些题目源代码

    3. **P1679(Unique_MST_prim).cpp 和 P1679(Unique_MST_kruskal).cpp** - 这两个文件都涉及了“唯一最小生成树”问题。Prim和Kruskal是两种常见的求解最小生成树的算法。在某些情况下,图可能有唯一的最小生成树...

    ACM题目大汇总

    2. **POJ1679 TheUniqueMST** - **题意**:判断最小生成树是否唯一。 - **解法**:Prim算法即可解决,虽然实现起来容易出错。 3. **POJ2728 DesertKing** - **题意**:要求找到具有最优比率的生成树。 - **...

    poj pku图论、网络流入门题总结、汇总

    ### POJ1679 TheUniqueMST **题目链接:** **核心知识点:** - **问题描述:** 验证给定图的最小生成树是否唯一。 - **解题思路:** 可以先通过Prim或Kruskal算法找到最小生成树,然后通过改变权重值的方法来判断...

    poj 图论 集合

    - **解法概述**:该题目涉及到了最小生成树(Minimum Spanning Tree, MST)的概念,可以通过 Prim 或 Kruskal 算法求解。 - **Prim 算法**:从任意顶点开始构建 MST,每次添加离当前 MST 最近的顶点。 - **Kruskal...

    图算法项目1

    5. **最小生成树(MST):** Kruskal算法和Prim算法是解决加权无环图的最小生成树问题的经典算法,它们都能找到连接所有顶点的边的集合,且总权重最小。 6. **二分图匹配:** 包括匈牙利算法(Kuhn-Munkres算法)等,...

Global site tag (gtag.js) - Google Analytics