`
贝壳水母
  • 浏览: 148113 次
  • 性别: Icon_minigender_1
  • 来自: 广州中低收入人群
社区版块
存档分类
最新评论

Problem1004

    博客分类:
  • POJ
阅读更多
/**
 * Description
 * Larry graduated this year and finally has a job. 
 * He's making a lot of money, but somehow never seems to have enough. 
 * Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. 
 * The first step is to figure out what's been going on with his money. 
 * Larry has his bank account statements and wants to see how much money he has. 
 * Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
 * 
 * Input
 * The input will be twelve lines. 
 * Each line will contain the closing balance of his bank account for a particular month. 
 * Each number will be positive and displayed to the penny. No dollar sign will be included.
 * 
 * Output
 * The output will be a single number,
 *  the average (mean) of the closing balances for the twelve months.
 *   It will be rounded to the nearest penny, preceded immediately by a dollar sign, 
 *   and followed by the end-of-line. There will be no other spaces or characters in the output.
 *   
 * Sample Input
 * 100.00
 * 489.12
 * 12454.12
 * 1234.10
 * 823.05
 * 109.20
 * 5.27
 * 1542.25
 * 839.18
 * 83.99
 * 1295.01
 * 1.75
 * 
 * Sample Output
 * $1581.42
 */
package acm;

import java.io.BufferedReader;
import java.io.InputStreamReader;

public class Problem1004 {
	public static void main(String[] args) {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		double sum = 0.00;
		//计算总额
		for (int i = 0; i < 12; i++) {
			try {
				sum += Double.parseDouble(br.readLine());
			} catch (Exception e) {
				e.printStackTrace();
			}
		}
		//计算平均数
		double avg = sum/12;
		//四舍五入到两位小数
		if(avg%0.01>0.0045){
			avg+=0.01;
		}
		//乘以100将头两位小数纳入,再除以100将结果精确到两位小数
		avg*=100;
		avg-=(avg%1);
		avg/=100;
		System.out.println("$"+avg);
	}
}


题目:有个小子想算算自己银行账户一年每个月平均能剩多少钱
里面的精确到小数后两位可把我的懒脑累惨了,后来才发现原来*100再/100就能完成这个工作
分享到:
评论

相关推荐

    acm比赛试题

    Problem 1004 本题的标题是“-2 进制”,它是一道数字系统题目,要求将十进制数转换为-2 进制。该题目考察了数字系统和算法设计的知识点,需要使用数字系统转换算法来解决问题。 知识点: 1. 数字系统 2. 算法...

    POJ1004-Financial Management

    【标题】"POJ1004 - Financial Management" 是一个来自北京大学在线判题系统POJ(Problem Set of Peking University)的编程题目。这个题目主要涉及到计算机科学中的算法设计和实现,特别是与财务管理和计算相关的...

    leetcode1004-leetcode-solutions:leetcode-解决方案

    1004 这个是我自己整理的leetcode Java版本的题解(或许以后会有更多版本的解法) 我将题目按照知识点进行分类,只要是属于该知识点,或者和该知识点相关的,我都会放在该知识点下。如果有链接问题,或者解答提交...

    Tejaskumar.Patel.BDAT1004PS2

    "PS2"通常代表“Problem Set 2”或“Programming Assignment 2”,意味着这是一系列练习中的第二个部分,旨在深化对数据处理和分析的理解。 描述中同样提到 "Tejaskumar.Patel.BDAT1004PS2",这表明内容可能围绕一...

    Shaochen.Du.BDAT1004PS2:这是习题集2的作业

    BDAT1004可能是数据科学或大数据分析相关的课程代码,而“PS2”可能代表“Problem Set 2”,即第二个问题集或作业。这个作业很可能包含了若干数据处理、分析或建模的题目。 【描述】"Shaochen.Du.BDAT1004PS2:这是...

    Atilla.Acar.BDAT1004PS-2

    结合【描述】中的同样信息,我们可以推测这可能是一个由Atilla Acar教授或指导的数据科学相关的课程内容,具体可能是BDAT1004这门课程的一个实践部分,编号为PS-2,可能代表Project或Problem Set。 【标签】...

    Brunilda.Xhaferllari.BDAT1004PS1:问题集1

    "PS1"代表"Problem Set 1",意味着这是系列练习中的第一部分,旨在帮助学生建立对课程核心概念的理解。 【描述】"布鲁尼尔达(Brunilda)Xhaferllari(BDAT1004PS1) 问题集1" 重申了这个资料的主题,即由Brunilda ...

    leetcode中国-ACM-Learning:ACM竞赛中关于算法的代码

    1004 1006 1007 专题分类 (一)简单搜索 ID Problem C++ Source 1 HDU 2553 (精简版) 2 HDU 1312 3 POJ 3984 4 POJ 2251 5 POJ 3278 6 POJ 3279 7 ZOJ 1002 8 POJ 1321 9 HDU 1241 (二)树 ID Problem C++ Source 1 ...

    leetcode中国-Homo-sapiens-ACM-Learning:智人-ACM-学习

    1004 1006 1007 专题分类 (一)简单搜索 ID Problem C++ Source 1 HDU 2553 (精简版) 2 HDU 1312 3 POJ 3984 4 POJ 2251 5 POJ 3278 6 POJ 3279 7 ZOJ 1002 8 POJ 1321 9 HDU 1241 (二)树 ID Problem C++ Source 1 ...

    ECNU 1-100 部分AC程序

    ECNU 1-100 部分AC程序 problem list : 1000 1001 1002 1003 1004 1005 1006 1007 1008 1009 1011 1012 1013 1014 1015 1017 1018 1019 1020 1023 1026 1027 1029 1030 1031 1036 1037 1038 1040 ...

    信息学奥赛一本通(C++版)在线评测系统-答案-1000-1009.docx

    1004:字符三角形 该题目主要测试了循环操作和字符处理,使用`for`循环和字符输出将一个字符三角形输出到屏幕上。该题目考察了基本的C++语法和循环操作。 1005:地球人口承载力估计 该题目主要测试了基本的数学运算...

    hdoj杭电入门训练题

    Let the Balloon Rise (HDOJ1004) **知识点:** - 字符串处理。 - 字符串匹配算法。 **解题思路:** - 读入字符串。 - 使用循环或字符串函数检查字符串是否包含特定字符序列。 - 如果包含,则输出“YES”,否则...

    美世国际和海氏的岗位评估方法

    例如,如果一个岗位的知能得分为941分,解决问题得分为71%(转换为绝对分),应负责任得分为1004分,假设解决问题能力和责任的权重分别为40%和60%,则该岗位的最终评估得分为1269分。 海氏评估法的应用不仅限于确定...

    BURNINTEST--硬件检测工具

    - Changes to correct a BurnInTest crash problem on some systems. When the disk and standard RAM tests are run for many hours, BurnInTest may have disappeared with no error message. Release 5.3 ...

    poj 前5题的C 和java代码

    Poj(Problem Online Judge)是一个在线编程竞赛平台,它提供了大量的算法题目供程序员进行训练和挑战。这里的“前5题”指的是poj题库中的最初五道题目,而提供的代码则是针对这些题目的解决方案。 1. **C语言基础*...

    Algorithm_Study:2021상반기알고리즘스터디

    git commit -m“ [UPD] BOJ1004_진행중(막힘)” ()것같습니것같습니것같습니다。 예)(막힘),(수정),(런타임에러),(문제이해중)... 상황 git commit -m“ [DEL] BOJ1004_삭제” 问题 주차 링크...

    基于遗传算法的计算机网络安全路由.pdf

    9. 文章编号(Article Number)是学术期刊中每篇文章的唯一标识,通常由期刊的ISSN(国际标准连续出版物编号)、出版年份、卷号、期号、页码等信息构成,如本例中的“1004-373X202007-0078-04”,它能够帮助人们快速...

Global site tag (gtag.js) - Google Analytics