`
Simone_chou
  • 浏览: 197200 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Just a Hook(线段树 + 延迟标记)

    博客分类:
  • HDOJ
 
阅读更多

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16232    Accepted Submission(s): 8075


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

 

Sample Input
1
10
2
1 5 2
5 9 3
 

 

Sample Output

 

Case 1: The total value of the hook is 24.

 

       题意:

       给出 T 组 case,后给出 N(1 ~ 100000) ,代表有 N 个为 1 的数,后给出 M,代表有 M 个操作,每个操作有 l,r,ans,代表将 l 到 r 区间的数变为 ans,在处理完所有操作之后,输出整个序列和的结果。

 

       思路:

       线段树 + 区间更新。延迟标记记录每段变为 ans 时候的值,理解了新的写法。

 

       AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAX = 100000 * 5;

int tree[MAX], mark[MAX];

void pushup (int node) {
        tree[node] = tree[node << 1] +  tree[node << 1 | 1];
}

void pushdown (int node, int l, int r) {
        if (mark[node]) {
                int mid = (r + l) >> 1;

                mark[node << 1] = mark[node];
                mark[node << 1 | 1] =  mark[node];

                tree[node << 1] = (mid - l + 1) * mark[node];
                tree[node << 1 | 1] = (r - mid) * mark[node];

                mark[node] = 0;
        }
}

void build (int node, int l, int r) {
        int mid = (l + r) >> 1;

        if (l == r) {
                tree[node] = 1;
                mark[node] = 0;
        } else {
                build(node << 1, l, mid);
                build(node << 1 | 1, mid + 1, r);

                pushup(node);
                mark[node] = 0;
        }

}

void update (int node, int l, int r, int cl, int cr, int num) {

        if (cl > r || cr < l) return;
        if (cl <= l && cr >= r) {
                mark[node] = num;
                tree[node] = (r - l + 1) * num;
                return;
        }

        pushdown(node, l, r);
        
        int mid = (r + l) >> 1;
        update(node << 1, l, mid, cl, cr, num);
        update(node << 1 | 1, mid + 1, r, cl, cr, num);

        pushup(node);
}

int main() {
        int t;
        scanf("%d", &t);

        for (int tt = 1; tt <= t; ++tt) {

                int n;
                scanf("%d", &n);
                build(1, 1, n);

                int m;
                scanf("%d", &m);
                while (m--) {
                        int al, ar, ans;
                        scanf("%d%d%d", &al, &ar, &ans);
                        update(1, 1, n, al, ar, ans);
                }

                printf("Case %d: The total value of the hook is %d.\n",
                        tt, tree[1]);

        }

        return 0;
}

 

 

分享到:
评论

相关推荐

    ACM hdu 线段树题目+源代码

    Hdu 1698 Just a Hook 是另一个典型的线段树题目,题目要求我们实现一个数据结构来维护一个数组的区间信息。 Hdu 3584 Cube Hdu 3584 Cube 是一个三维线段树题目,题目要求我们实现一个三维线段树来维护一个三维...

    基于MFC恶意文件检测系统 框架 vs2022 + c/c++ + hook + PE + inject + 动态调试工具Imm

    框架 vs2022 + c/c++ + hook + PE + inject + 动态调试工具Immunity Debugger或者 odbg110, x64debug(手动找hook合适的地址把它改我们想要的如"jmp xxxxxxx" ,写入weHook) 用户类型 管理员 admin 123456 模块...

    基于MFC恶意文件检测系统框架 vs2022 + c/c++ + hook + PE + inject + 动态调试工具Imm

    框架 vs2022 + c/c++ + hook + PE + inject + 动态调试工具Immunity Debugger或者 odbg110, x64debug(手动找hook合适的地址把它改我们想要的如"jmp xxxxxxx" ,写入weHook) 用户类型 管理员 admin 123456 模块...

    Hook+-+进程防杀

    "Hook+进程防杀"是指通过Hook技术来防止反病毒软件或者其他恶意程序对目标进程的检测和清除。这篇文章将深入探讨Hook的原理,以及如何应用于进程防杀。 一、Hook的基本概念 Hook技术源于Windows操作系统,它允许...

    易语言x64-hook模块源码+实列

    常见的Hook类型包括API Hook、内联Hook(Inline Hook)、异常处理Hook(VEH Drx Hook)等。 3. **wow64_hook_2.91模块源码**:这是易语言的x64 Hook模块的源代码,版本号为2.91。通过阅读源码,开发者可以了解模块...

    Hook API 工具 + 源代码

    Hook API 是一种技术,它允许开发者拦截和修改特定API(应用程序接口)调用的行为。这种技术在软件开发、调试、安全分析以及系统监控等领域有着广泛的应用。本资源包含了一个Hook API工具及其源代码,用于将自定义...

    DELPHI HOOK 钩子 DLL+调用

    DELPHI HOOK 钩子DLL+调用是一种在Delphi编程环境下实现系统级监控和功能拦截的技术。钩子是Windows操作系统提供的一种机制,允许开发者注册一个回调函数,以便在特定事件发生时被调用,例如键盘输入、鼠标点击或者...

    C# 优雅的 APIHOOK 支持X86+X64源码

    using (var hook = new MessageBoxHook()) { //绕过Hook直接调用源函数 hook.Origin(IntPtr.Zero, "111", "222", 0); //调用Api 被Hook MessageBox.Show("Hello world", "666", MessageBoxButtons.YesNoCancel...

    WPF使用Hook监听LWin+F20、F19、F18

    本案例中的标题和描述提到了使用Hook技术来监听`LWin+F20`、`LWin+F19`和`LWin+F18`这三个快捷键,目的是覆盖Ink Workspace的设置。Ink Workspace是Windows系统中一个用于手写和绘图的组件,但这里显然是为了实现...

    Hook经典分析 关于QQ Hook的应用 钩子

    QQ Hook是一种技术手段,主要涉及计算机程序中的钩子(Hook)机制。钩子在编程领域中,是指一种允许开发者在特定事件发生时插入自定义处理代码的机制。它允许程序拦截并处理系统或应用程序级别的事件,例如键盘输入...

    WeChat-微信Hook,DaenWxHook+千寻VX框架,DaenWxHook源代码+千寻VX框架源代码,绝好学习资料!

    而随着技术的不断进步,人们对于微信的探索和开发也逐渐深入,微信的Hook技术便是一个典型的例子。Hook技术的出现,让开发者有机会在微信运行时改变其行为,或者是提供新的功能,这就涉及到所谓的微信框架开发。 ...

    拼西西商城后台管理系统源码(react(hook) + antd + ts).zip

    拼西西商城后台管理系统源码(react(hook) + antd + ts) 拼西西商城后台管理系统源码(react(hook) + antd + ts) 拼西西商城后台管理系统源码(react(hook) + antd + ts) 拼西西...

    API Hook 源代码 vc ++

    API Hook是一种技术,用于在应用程序调用特定API(应用程序编程接口)时进行拦截,以便在调用前后执行自定义操作。这种技术常用于系统监控、调试、插件开发以及安全领域。在VC++环境中实现API Hook,需要对Windows ...

    用mfc实现hook,屏蔽了键盘和鼠标消息,留有默认后门

    在IT安全领域,"Hook"技术是一种常见的系统监控和调试手段。MFC(Microsoft Foundation Classes)是微软提供的一套C++库,用于构建Windows应用程序。本文将深入探讨如何使用MFC实现Hook,以及如何处理键盘和鼠标消息...

    hook例子源码-拦截API

    在编程领域,"hook"(钩子)是一种技术,它允许程序员在系统或应用程序的关键点插入自定义代码,以便在特定事件发生时进行监控、修改或控制行为。本示例"HookTest"提供了VC++(Visual C++)实现的API(应用程序接口...

    hook+端口转发+防火墙过滤.rar

    用于过滤d2gs在没有源码的情况把本身的4000端口hook到其他端口,然后通过hpsocket转发数据并过滤其中不好的东西。 主要用于针对暗黑2私服中用封包攻击端口用,类似于端口防火墙的原理.

    PDD工作台 Hook消息回调+发送消息SDK

    源码采用inlinehook来监听实时消息,并且回调到易语言,可监听的消息为:收到的聊天内容/发送出去的聊天内容/入店路径/改地址信息/退款信息/小卡片信息/订单信息等等自动监视目标进程创建,自动hook/自动还原hook。...

    hook+WSASend源码

    【标题】"hook+WSASend源码"指的是一个针对WSASend函数的钩子(hook)技术实现的源代码包。在计算机编程中,钩子是一种机制,允许程序员拦截和处理系统调用,例如网络通信中的WSASend函数。WSASend是Windows Socket ...

    easyhook库的使用例子

    EasyHook库是一个强大的.NET钩子库,它允许开发者在运行时拦截和修改其他应用程序的调用,无需重新编译或修改目标代码。这个库在Windows平台上特别有用,因为Windows API提供了大量的函数调用来实现各种系统操作,而...

    VEH+硬件断点实现无痕HOOK

    【标题】"VEH+硬件断点实现无痕HOOK"涉及的是Windows系统中的一种高级调试技术,主要用于在不改变目标程序原始行为的情况下,插入自定义代码以监控或修改其执行流程。这种技术常用于软件调试、逆向工程、安全检测等...

Global site tag (gtag.js) - Google Analytics