`

Uva 10054 - The Necklace 欧拉回路

 
阅读更多

连接:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&category=543&problem=995&mosmsg=Submission+received+with+ID+11655838

 

 

My little sister had a beautiful necklace made of colorful beads. Two successive beads in the necklace shared a common color at their meeting point. The figure below shows a segment of the necklace:

 

But, alas! One day, the necklace was torn and the beads were all scattered over the floor. My sister did her best to recollect all the beads from the floor, but she is not sure whether she was able to collect all of them. Now, she has come to me for help. She wants to know whether it is possible to make a necklace using all the beads she has in the same way her original necklace was made and if so in which order the bids must be put.

Please help me write a program to solve the problem.

Input 

The input contains T test cases. The first line of the input contains the integer T.

The first line of each test case contains an integer N ( $5 \le
N \le 1000$) giving the number of beads my sister was able to collect. Each of the next N lines contains two integers describing the colors of a bead. Colors are represented by integers ranging from 1 to 50.

 

Output 

For each test case in the input first output the test case number as shown in the sample output. Then if you apprehend that some beads may be lost just print the sentence ``some beads may be lost" on a line by itself. Otherwise, print N lines with a single bead description on each line. Each bead description consists of two integers giving the colors of its two ends. For $1 \le i \le N ­ 1$, the second integer on line i must be the same as the first integer on line i + 1. Additionally, the second integer on line N must be equal to the first integer on line 1. Since there are many solutions, any one of them is acceptable.

Print a blank line between two successive test cases.

 

Sample Input 

2
5
1 2
2 3
3 4
4 5
5 6
5
2 1
2 2
3 4
3 1
2 4

Sample Output 

Case #1
some beads may be lost
 
Case #2
2 1
1 3
3 4
4 2
2 2

 

 

#include<cstdio>
#include<cstring>
using namespace std;
#define M 50
int map[M+1][M+1],n;
void euler(int u)
{
       for(int v = 1;v <= 50;v++)if(map[u][v])
       {
              map[u][v]--;
              map[v][u]--;
              euler(v);
              printf("%d %d\n",v,u);
       }
}
int main()
{
      // freopen("in.txt","r",stdin);
	int T,step,i,a,b,flag;
	scanf("%d",&T);
	for(step = 1;step <= T;step++)
	{
	       memset(map,0,sizeof(map));
	       scanf("%d",&n);
	       for(i =  0;i < n;i++)
	       {
	              scanf("%d%d",&a,&b);
	              map[a][b]++;map[b][a]++;
	              map[a][0]++;map[b][0]++;
	       }
	       for(i=1,flag=0;i<=50;i++)
                     if(map[i][0]%2)
                     {
                            flag=1;
                            break;
                     }
              printf("Case #%d\n",step);
	       if(flag)printf("some beads may be lost\n");
	       else euler(a);
	       if(step<T)printf("\n");
	}
	return 0;
}

 

 

 

 

 

分享到:
评论

相关推荐

    欧拉回路的构建及输出欧拉回路的路径

    这里以构建一个度全部相同的欧拉回路,并输出欧拉回路的路径 1.构建欧拉回路 连通主要是靠树来保证,首先建立一个度为k的完全图,其中会有很多需要主要的地方 (1)首先构造树 =&gt;保证顶点连通 (2)将度的点...

    欧拉回路C++程序(随机给图求欧拉回路)

    欧拉回路C++程序 随机输入任意点数,给出图中存在的欧拉回路

    欧拉回路程序java

    根据提供的文件信息,本文将对“欧拉回路程序java”进行详细解析,涉及的知识点主要包括:欧拉路径与欧拉回路的概念、Java程序设计基础、数据结构(如图和节点)、算法实现(欧拉回路算法)等。 ### 欧拉路径与欧拉...

    欧拉回路的Fleury算法

    欧拉回路的Fleury算法 欧拉回路的Fleury算法是图论中用来判断图是否存在欧拉回路的一种有效算法。欧拉回路是指经过图中所有边一次且仅一次行遍所有顶点的回路。具有欧拉回路的图称为欧拉图。 Fleury算法的思想是从...

    图论- 图的遍历- 欧拉通路与欧拉回路问题.rar

    欧拉通路与欧拉回路是图论中的经典概念,尤其在算法设计和网络分析中有着广泛的应用。 欧拉通路是指一个图中从某一个顶点出发,沿着边顺序经过每一个顶点恰好一次,最后回到起点的路径。这样的路径不一定要包含所有...

    欧拉回路的实验报告

    ### 欧拉回路的实验报告知识点解析 #### 一、基本概念 **1.1 定义** - **欧拉通路(欧拉迹)**:在一张图中,若存在一条路径能恰好经过每条边一次,并且经过每一个顶点,则这条路径被称为欧拉通路。 - **欧拉回路...

    算法-欧拉回路(HDU-1878)(包含源程序).rar

    标题中的“欧拉回路”是指在图论中的一种特殊路径。欧拉回路是图中从一个顶点出发,经过图中每条边恰好一次,并最终返回到起点的闭合路径。这个问题在计算机科学中有着重要的应用,尤其是在解决网络问题、数据结构...

    有向图的欧拉回路

    在图论中,欧拉路径和欧拉回路是两个重要的概念。欧拉路径是从图的一个顶点出发,经过图中的每一条边恰好一次,最后到达另一个顶点的路径。而欧拉回路则是在图中从一个顶点出发,经过每条边恰好一次,并最终返回到...

    实验_38_如何构建欧拉回路.pdf

    实验三十八:如何构建欧拉回路 在本文中,我们将了解如何构建欧拉回路,掌握用构造证明法证明定理2的充分条件,并采用定理2的方法编程给出三个图的欧拉回路。 欧拉回路的定义 欧拉回路(Eulerian Circuit)是一种...

    COMSOL-欧拉-欧拉双流体模型案例(PDF+COMSOL程序).rar

    在处理涉及两种或多种相互作用流体的问题时,欧拉-欧拉双流体模型是一种常用的方法。本资料包包含了一个关于如何在COMSOL中实现欧拉-欧拉双流体模型的案例分析,以及相关的COMSOL模型程序。 欧拉-欧拉模型是解决...

    欧拉回路输出路径

    从给定的代码片段来看,这是一个典型的解决欧拉回路问题的程序,主要应用于图论领域,特别是寻找图中是否存在一个路径,该路径恰好通过每条边一次,并且回到起点。这种路径被称为欧拉回路。下面将详细介绍这段代码中...

    20151910042-刘鹏-AG实验05-欧拉图判断与寻找欧拉回路1

    《欧拉图判断与寻找欧拉回路》的实验报告主要关注的是图论中的一个重要概念——欧拉图。欧拉图是指一个图中每条边恰好被包含在一条闭合路径中,即存在一个经过图中所有边的路径,而没有重复的顶点。这个路径称为欧拉...

    3.仇荣琦《欧拉回路性质与应用探究》1

    【欧拉回路性质与应用探究】 欧拉回路,源于18世纪的哥尼斯堡七桥问题,是图论中的基本概念,它涉及到在一张图中能否找到一条路径,使得这条路径恰好经过每条边一次且仅一次,并且回到起点。这种路径被称为欧拉回路...

    欧拉回路题集

    ### 欧拉回路题集解析 #### 欧拉回路概念 欧拉回路(Eulerian Circuit)是指在一个无向图或有向图中,如果存在一条闭合路径,该路径通过每条边恰好一次,则这条路径称为欧拉回路。一个能够包含欧拉回路的图称为...

    实验4-图的生成及欧拉回路的确定1

    【实验名称】图的生成及欧拉回路的确定 实验目标是学习和掌握图的表示方法、欧拉图的概念以及如何寻找欧拉回路。在这个实验中,学生将使用离散数学的知识来处理无向图,并通过编程实现欧拉路径的搜索。 1. **图的...

    欧拉回路计算

    欧拉回路是图论中的一个重要概念,它指的是在无向图或有向图中,一个从某点出发,经过图中每条边恰好一次,最后又回到起点的路径。在学习数据结构的过程中,理解并实现欧拉回路的算法是一项基础而关键的任务。这个...

    第八讲-机器人动力学--牛顿-欧拉方程.ppt

    "机器人动力学--牛顿-欧拉方程" 本资源是机器人动力学的第八讲,主要介绍机器人的杆件速度和牛顿-欧拉方程。下面是对标题、描述、标签和部分内容的详细解释: 机器人的杆件速度 机器人的杆件速度是机器人动力学的...

    2022级图论-欧拉回路和最短路-题解

    一个图可能存在欧拉回路的条件是:如果图中所有顶点的度数(出度加入度)都是偶数,那么这个图就有可能存在欧拉回路。若图中存在某个顶点的度数为奇数,则图中无法形成欧拉回路。著名的“七桥问题”就是欧拉回路的...

Global site tag (gtag.js) - Google Analytics