`

POJ1611解题报告

 
阅读更多
The Suspects
Time Limit: 1000MS  Memory Limit: 20000K
Total Submissions: 14274  Accepted: 6780

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1
题意:有多个测试用例。第一行n表示学生数目,m表示组数。n=0且m=0时测试结束。每一行第一个值表示后面有多少个学生,后面就跟着学生的序号。默认第0个学生感染了SARS,每个与他同组的,或间接同组的都会感染。求最大感染人数。

分析:这是一道经典的并查集的题目,直接套用模板,几乎不用修改。只需将同一组的人union,最后求和0号同学同一组的有多少个人,那么就有多少人被感染。
#include<stdio.h>
#define NNUM 30000
int p[NNUM],rank[NNUM];
int suspect,n,m,u,x,y;
void makeSet()
{
   int i;
   for(i=0;i<NNUM;i++)
   {
       p[i]=i;
       rank[i]=0; 
   } 
}
int findSet(int i)
{
   if(i!=p[i])
   {
       p[i]=findSet(p[i]); 
   } 
   return p[i];
} 
void link(int i,int j)
{
   if(rank[i]>rank[j])
   {
       p[j]=p[i]; 
   } 
   else
   {
       p[i]=p[j];
       if(i==j)
       {
           rank[j]+=1; 
       } 
   }
}
void union1(int i,int j)
{
    link(findSet(i),findSet(j));
}
int main()
{
  while(scanf("%d%d",&n,&m)&&n+m)
  {
        int i,j;
        makeSet();
        for(i=0;i<m;i++)
        {
             scanf("%d",&u);
             scanf("%d",&x);
             
             for(j=1;j<u;j++)
             {
                 scanf("%d",&y);
                 union1(x,y); 
             }
        }
        
        int num=1;
        for(i=1;i<n;i++)
        {
            if(findSet(i)==findSet(0))
            {
                num++;
            } 
        }
        printf("%d\n",num);
  }
  
  system("pause");
  return 0; 
}
分享到:
评论

相关推荐

    poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告

    poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题报告poj 解题...

    poj 3414解题报告

    poj 3414解题报告poj 3414解题报告poj 3414解题报告poj 3414解题报告

    poj 1012解题报告

    poj 1012解题报告poj 1012解题报告poj 1012解题报告poj 1012解题报告

    poj 2329解题报告

    poj 2329解题报告poj 2329解题报告poj 2329解题报告poj 2329解题报告

    poj 1440解题报告

    poj 1440解题报告 poj 1440解题报告 poj 1440解题报告 poj 1440解题报告

    poj 3083解题报告

    poj 3083解题报告poj 3083解题报告poj 3083解题报告poj 3083解题报告

    poj 1659解题报告

    poj 1659解题报告poj 1659解题报告poj 1659解题报告poj 1659解题报告

    poj 3720解题报告

    poj 3720解题报告poj 3720解题报告poj 3720解题报告poj 3720解题报告

    北大poj解题报告

    这个“北大poj解题报告”包含了作者在使用POJ平台解题过程中的学习总结和经验分享,旨在帮助软件工程专业的学生提升编程能力和算法理解。 解题报告通常会涵盖以下几个方面: 1. **基础算法讲解**:解题报告中可能...

    poj1691解题报告

    ### poj1691解题报告 #### 题目信息 - **题目名称**:Painting A Board - **时间限制**:1S - **内存限制**:1000K - **提交总数**:62 - **通过总数**:35 - **来源**:...

    acm竞赛----北大poj详细解题报告

    【ACM竞赛与北大POJ解题报告】 在编程竞赛领域,ACM(国际大学生程序设计竞赛,简称ACM/ICPC)是一项极具影响力的比赛,它挑战参赛者的算法设计、问题理解和快速编码能力。北京大学(Peking University)的在线判题...

    80道POJ解题报告

    【标题】"80道POJ解题报告"所涉及的知识点主要集中在ACM(国际大学生程序设计竞赛)和POJ(编程Online Judge系统)上。POJ是北京大学主办的一个在线编程竞赛平台,广泛用于训练和提升程序员的算法设计与实现能力。80...

    北大ACM_POJ_解题报告

    【北大ACM_POJ_解题报告】是北京大学ACM在线评测系统POJ的解题资源集合,这个压缩包包含了对POJ平台上的各种类型ACM竞赛题目的详细解答。ACM,全称国际大学生程序设计竞赛(International Collegiate Programming ...

    POJ 1316解题报告

    【POJ 1316 解题报告】 本题源自北京大学举办的ACM竞赛,题号为POJ 1316,主要涉及算法设计和数组的应用。题目要求找到10000以内的所有self-number,并输出它们。Self-number是一个特殊的整数序列,它的定义是该数...

    poj 2392 解题报告

    《POJ 2392解题报告:高效计算最高堆积高度》 本文将深入解析POJ 2392这个编程题目,该题目要求利用给定的不同高度、耐压性和数量的block,来确定能够堆叠出的最大高度。解决这个问题的关键在于运用排序和动态规划...

    poj2828解题报告

    这篇解题报告主要介绍了如何解决POJ2828这个编程题目。该题目涉及的数据结构是区间树(Interval Tree),这是一种用于高效处理区间查询和修改的树形数据结构。在这个问题中,我们需要根据输入的元素位置和值,构建一...

    ACM Poj Pku 解题报告答案 打包 下载 600多题 史上最全

    ACM Poj Pku 解题报告答案 打包 下载 600多题 史上最全 不是网上乱传的200多题,更不是100多题就挂着10分才能下的题 下了这个 大家也不要浪费分数去下载其它版本的了,基本上都有 共享 一起进步 中国加油 ACMer...

    本人整理的POJ解题报告大全

    【POJ解题报告大全】是我精心整理的一份编程题解集合,主要涵盖了在Programming Online Judge(POJ)平台上遇到的250道经典题目。POJ是一个著名的在线编程竞赛平台,它为程序员提供了大量的算法练习题目,是提高编程...

    北大POJ 大量解题代码

    【标签】"ACM POJ解题报告"是关键词,表明这些代码和报告是围绕ACM竞赛中的POJ平台进行的,ACM是全球知名的学生编程竞赛,旨在测试参赛者的算法知识、编程技能和团队合作能力。POJ(Problem Set Archive)是北京大学...

    poj 2376 解题报告

    题目“Poj 2376”是一道关于贪心算法的编程竞赛题目,目标是找到最少数量的牛来清洁一段长度为`len`的地板。每头牛有自己的清洁范围,给出每头牛能清洁的地板区间。题目要求确保整个地板都能被清洁到,如果无法实现...

Global site tag (gtag.js) - Google Analytics