Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input
2
10
20
Sample Output
7
19
Source
Asia 2002, Dhaka (Bengal)
这一题运用了一个数学公式,叫做斯格拉公式,可以自己查询了解一下这个公式,我当时做这个题时,当阶乘后数字大于9时,显示的结果总是少1,自己调了好久,感觉那都没有错,结果就是不对,最后一次就把数字分数形式换成了小数形式,因为1/2==0,在编程语言中。。。。。。
代码如下
#include<stdio.h>
#include<math.h>
#define pi 3.1415926
int main()
{
int n,i,m,b;
double a;
scanf("%d",&n);
for(i=0; i<n; i++)
{
a=0;
scanf("%d",&m);
a=(m*log(m)-m+0.5*log(2*pi*m))/log(10.0);//注意 这条语句 b=(int)a+1;
printf("%d\n",b);
}
return 0;
}
分享到:
相关推荐
4. 数学题:杭电OJ题目分类中有多道数学题,例如1005、1006、1012、1014、1018、1019等。这些题目需要学习和掌握数学的基本概念和方法,例如数论、代数、几何等。 5. 字符串处理:杭电OJ题目分类中有多道字符串处理...
首先,我们来看一个典型的例子,例如杭州电子科技大学OJ1207题或杭电1018题,这两道题目都要求计算给定整数n的阶乘n!的位数。这里,阶乘表示的是1到n的所有正整数的乘积,即n! = 1 × 2 × 3 × ... × n。 计算...
包含杭电1000-1005,1009,1013,1018,1021,1040,1048,1049,1062,1071,1215,1219,1251,1863,2005,2007,2010-2012,2018,2021,2027,2029,2047,2054,2066,2203,2846
- **例题**:1005、1006、1012、1014、1018、1019、1021、1023、1027、1030、1032、1038、1041、1046、1059、1060、1061、1065、1066、1071(微积分)、1097、1098、1099、1100、1108、1110、1112、1124、1130、1131...
【杭电ACM试题分类】涉及的是编程竞赛中的算法与数据结构题目,主要围绕ACM(国际大学生程序设计竞赛)的训练题目进行整理。这些题目涵盖了多种算法和问题解决技巧,是提高编程能力和算法理解的重要资源。以下是这些...
- **1018**:利用递推公式求解数学问题。 ##### 17. 数论问题 - **1164**:介绍数论的基本概念。 - **1211**:探讨数论中的典型问题。 ##### 18. 计算几何 - **1086**:引入计算几何的基本概念。 - **1115**:探讨...
ACM 题型分类是杭电题型的详细分类,涵盖了多种算法和数据结构。以下是对每种题型的详细说明: 搜索与回溯 搜索与回溯是 ACM 题型分类中的一种,常用的算法有深度优先搜索(DFS)和广度优先搜索(BFS)。这类题目...
- **1017**、**1018**、**1019**:这些题目的共同特点是简单数学题,通常涉及基础数学概念的应用,如代数运算、数列等。 - **1021**:找规律的数学题,可能需要通过观察样例来找出背后的数学规律。 - **1039**:字符...