`
Simone_chou
  • 浏览: 196997 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Stamps(DP)

 
阅读更多
Stamps

Given a set of N stamp values (e.g., {1 cent, 3 cents}) and an upper limit K to the number of stamps that can fit on an envelope, calculate the largest unbroken list of postages from 1 cent to M cents that can be created.

For example, consider stamps whose values are limited to 1 cent and 3 cents; you can use at most 5 stamps. It's easy to see how to assemble postage of 1 through 5 cents (just use that many 1 cent stamps), and successive values aren't much harder:

  • 6 = 3 + 3
  • 7 = 3 + 3 + 1
  • 8 = 3 + 3 + 1 + 1
  • 9 = 3 + 3 + 3
  • 10 = 3 + 3 + 3 + 1
  • 11 = 3 + 3 + 3 + 1 + 1
  • 12 = 3 + 3 + 3 + 3
  • 13 = 3 + 3 + 3 + 3 + 1.

However, there is no way to make 14 cents of postage with 5 or fewer stamps of value 1 and 3 cents. Thus, for this set of two stamp values and a limit of K=5, the answer is M=13.

The most difficult test case for this problem has a time limit of 3 seconds.

PROGRAM NAME: stamps

INPUT FORMAT

Line 1: Two integers K and N. K (1 <= K <= 200) is the total number of stamps that can be used. N (1 <= N <= 50) is the number of stamp values.
Lines 2..end: N integers, 15 per line, listing all of the N stamp values, each of which will be at most 10000.

SAMPLE INPUT (file stamps.in)

5 2
1 3

OUTPUT FORMAT

Line 1: One integer, the number of contiguous postage values starting at 1 cent that can be formed using no more than K stamps from the set.

SAMPLE OUTPUT (file stamps.out)

13

 

      题意:

      给出 K(1 ~ 200) 和 N(1 ~ 50),代表只能使用任意的 K 个数,有 N 种数选择,后给出 N 个数,输出一个最大的上限,使凑到 1 ~ M 中的任意一个数,只能用 K 个数且必须是 N 种数里面。

 

      思路:

      DP。dp [ i ] 代表能凑到 i 钱币的最少使用张数,当一遇到凑不到的情况就退出循环。

      递推式子 dp [ i ] = min { dp [ i ] , dp [  i - mon [ j ] ] + 1 }。

 

      AC:

/*
TASK:stamps
LANG:C++
ID:sum-g1
*/

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAX = 3000005;
const int INF = 9999999;

int dp[MAX], mon[55];

void init() {
    for (int i = 0; i < MAX; ++i)
        dp[i] = INF;
    dp[0] = 0;
}

int main() {
    freopen("stamps.in", "r", stdin);
    freopen("stamps.out", "w", stdout);

    init();
    int k, n;
    scanf("%d%d", &k, &n);

    for (int i = 0; i < n; ++i)
        scanf("%d", &mon[i]);

    for (int i = 1; i < MAX; ++i) {
        for (int j = 0; j < n; ++j) {
            if (i - mon[j] >= 0 && (dp[i - mon[j]] + 1) <= k) {
                dp[i] = min(dp[i], dp[i - mon[j]] + 1);
            }
        }

        if(dp[i] == INF) {
            printf("%d\n", i - 1);
            break;
        }
    }

    return 0;
}

 

 

 

分享到:
评论

相关推荐

    1010_stamps.rar_1010 STAMPS

    2. **状态转移方程**:对于每个面值j的邮票,我们需要更新dp[i]的状态,如果i &gt;= j,则dp[i]可以从dp[i - j] + 1或者dp[i]中取较小值,这样就确保了在使用或不使用面值j的邮票时,我们都能得到最小的邮票数量。...

    1010_stamps.zip_1010_POJ 1010_poj_poj stamps_poj10

    《POJ 1010 Stamps:解题思路与陷阱分析》 POJ 1010,也被称为“邮票问题”,是编程竞赛中的一道经典题目,旨在考察参赛者的动态规划和数学思维能力。这个题目在编程爱好者中具有较高的知名度,因为它涉及到有趣的...

    ACM编程比赛入门题库

    ### ACM编程比赛入门题库知识点解析 #### 一、最少钱币数 ... if sum([1 for s in stamps if i &gt;= s and dp[i-s]]) &gt; m: dp[i] = False return dp ``` 以上是对题库中部分题目进行的知识点解析和技术要点总结。

    pku题目分类.doc

    5. **搜索**:包括深度优先搜索(DFS)和广度优先搜索(BFS),如"STAMPS"和"Anniversary Cake",可能需要设计递归或队列数据结构来解决问题。 6. **动态规划(DP)**:"Dividing"、"Jury Compromise"和"Sticks"等题目...

    POJ题目分类-题库分类

    5. **动态规划(DP)**:动态规划是一种优化技术,用于求解最优化问题,例如STAMPS、Jury Compromise、Cable master等。DP常用于处理具有重叠子问题和最优子结构的问题,需要构造状态转移方程并存储中间结果。 6. *...

    usaco心得及总结

    其中,动态规划(Dynamic Programming, DP)作为一种重要的算法思想,在USACO竞赛中占据了极其重要的地位。以下是对USACO中一些典型动态规划题目的心得与总结。 ### 一、典型题目分类与解法 #### 1. 背包问题及其...

    hdu题目分类

    14. **1016 Shoot-out 博弈+状态压缩DP** - **知识点**: 博弈论、状态压缩动态规划。 - **描述**: 分析射击游戏中的最优策略。 - **难度级别**: 高级。 - **解题思路**: 结合博弈论和状态压缩动态规划来解决问题...

Global site tag (gtag.js) - Google Analytics