`
Simone_chou
  • 浏览: 192871 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Super Jumping! Jumping! Jumping!(动态规划)

    博客分类:
  • HDOJ
 
阅读更多

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17610    Accepted Submission(s): 7541


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the maximum according to rules, and one line one case.
 

 

Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0
 

 

Sample Output
4
10
3

    题意:

    跳棋每次都跳到大于该位置值的地方,对这些位置的值进行全部加和,输出最大和。

   

    思路:

    说白了就是求所有递增子序列和的最大值,首先必须要清楚,不是说子序列越长就是和越大,跟之前的最长递增子序列是不一样的。

    对比最长递增子序列与最大和递增子序列:

    最长递增子序列:     1.长度最长  2.递增

    最大和递增子序列:  1.加和最大  2.递增

    可以看出,同样的要求是递增序列。

    设number[1.....N],与sum[1.....N],number表示该位置的值,sum代表每个位置最大和,设i与j两个位置,每次遍历都从 j =1开始到 i 位置结束,故 i 的范围是2到N,j 的范围是1到 i 。

    那么sum[ i ]=number[ i ]+max { sum[1]......sum[i-1] },当然在max { sum[1]......sum[i-1] }这里面的所有项中,要满足条件number[ i ]>number[ j ],因为要求是递增序列。

    与最长递增子序列对比:

    length[ i ]=1+max { length[1]......length[i-1] },同样的,也许要number [ i ]>number [ j ]。

    两者间的区别就是,最大和与本身的值有关,而最长序列与本身值无关,只需要长度+1,这一点在循环体中的写法有点不同。

AC:

 

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
	int n,i,j;
	int number[1005];
	int sum[1005],max,max1;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0) break;
		memset(number,0,sizeof(number));
		for(i=1;i<=n;i++)
		{
		  scanf("%d",&number[i]);
	          sum[i]=number[i];
		}
//		printf("\n");
//		for(i=1;i<=n;i++)
//		 printf("%d ",number[i]);
//		printf("\n");
//记得初始化
                max=1;
          
		for(i=2;i<=n;i++)
	       {
			max1=0;
                 //这个循环是为了找i前面的最大加和值用的
                        for(j=1;j<i;j++)
			{
			 if(number[i]>number[j])
			   {
			   	 if(sum[j]>max1) max1=sum[j];
			   }
		        }
                 //找到后就加上这个值成为符合条件下的自身最大加和值 
		    sum[i]+=max1;
//对比查找最大用的,直接写在同一个循环内,就不用再另外写一个来找里面的最大值输出了
                       if(sum[i]>max) max=sum[i];
//			printf("\nmax1=%d\n",max1);
//		    printf("sum[%d]=%d\n",i,sum[i]);
//		    printf("max=%d\n",max);
//		    system("pause");
//测试用
		}
		printf("%d\n",max);
	}
	return 0;
}

 Compare:

    最长递增子序列:

for(i=1;i<length;i++)  
    {  
        for(j=0;j<i;j++)  
         if(s[i]>s[j])  
          max[i]=max[i]>max[j]+1?max[i]:max[j]+1;  
//直接对比更新值
        if(max[i]>m) m=max[i];     
    }

   最大和递增子序列:

for(i=2;i<=n;i++)
 {
   max1=0;
   for(j=1;j<i;j++)
   {
    if(number[i]>number[j])
      {
	if(sum[j]>max1) max1=sum[j];
      }
   }
//这里不可以直接对比更新值,必须j循环完才可以
    sum[i]+=max1;
    if(sum[i]>max) max=sum[i];
 }

   总结:

   还是需要提高一下实现能力,不能急,得慢慢来……

 

分享到:
评论

相关推荐

    JSU_动态规划_dp1

    动态规划(DP1) http://acm.hdu.edu.cn/diy/contest_show.php?cid=20151 解题报告: 1001 计算直线的交点数 1002 FatMouse's Speed1003 Common Subsequence1004 Max Sum 1005 Super Jumping! Jumping! Jumping! ...

    super-jumping-game:一个游戏! 大概

    "Super-Jumping-Game",正如其名,是一款游戏,可能属于休闲娱乐类,旨在带给玩家轻松愉快的游戏体验。这款游戏的开发语言选择了JavaScript,这是一种广泛应用于Web前端开发的脚本语言,具有动态、轻量级和解释执行...

    使用Unity开发的Jumping Frog 2D横板平台跳跃类小游戏

    游戏内美术资源来自于Assert Store上免费资源Pixel Adventure 1,音乐资源来自Super Mario Bros. Wonder。 游戏内AD键左右移动,空格键跳跃,ESC键返回主菜单。 一共做了三个关卡,每个关卡不同风格,陷阱的内容也...

    SGU推荐题目分类

    116 Index of Super-prime 动态规划:Index of Super-prime 是 SGU 中的一道动态规划题目,要求使用动态规划来解决。 117 Counting 快速幂:Counting 是 SGU 中的一道数学题目,要求使用快速幂算法来解决。 118 ...

    Supermario-Bros-3

    例如,`MarioState`类可以包含`Running`、`Jumping`、`Dead`等状态。 6. **音频管理**:游戏音效和背景音乐是提升游戏体验的重要部分。C#提供了对音频文件的处理和支持,允许开发者在适当的时候播放音效或音乐。 7...

    五年级英语下册 Unit 5(10)教案 人教PEP.doc

    在"Preparation"环节,通过"Superstar"和"Let’s sing"的活动,学生在轻松愉快的氛围中预热,锻炼了语言组织和听说技能,同时也为新知识的学习做好准备。教师会通过故事的形式引入相关场景,例如在公园里的活动,...

    Shōnen Jump New Tab Theme-crx插件

    包括来自Shonen Jumping漫画格斗游戏的高清图像 对于Jump Force Dragon Ball Z Naruto Super Smash Bros的粉丝。 在每个新选项卡页面上均包含Jump Force的高清图像。 对于七龙珠Z,超级粉碎兄弟和漫画的粉丝。 请给...

    DP46题.doc

    动态规划(DP)是一种在计算机科学中广泛应用的算法设计技术,尤其在解决最优化问题时极为有效。DP算法的核心思想是将复杂问题分解为多个相互关联的子问题,并通过存储和重用已解决子问题的解来避免重复计算,从而...

    安卓java读取网页源码-Andorid-learning:Andorid-学习

    super.onCreate(savedInstanceState); getSupportActionBar().hide(); //&lt;&lt; this setContentView(R.layout.activity_main); } 跳转不同activity并传值 不传值 public void sendMessage(View view) { start...

    小学六年级英语第二次月考试题.doc

    1. My mum is _____ the supermarket. 答案:C.at(在超市里) 2. _____ I going to have an American birthday? 答案:B.Am(我要过一个美国式的生日吗?) 3. Make the wings, and _____ . 答案:B.stick them on...

    六年级英语下册 Unit 8 What's your dream(第3课时)教案 陕旅版-陕旅版小学六年级下册英语教案.doc

    3. 句型“The chicken was jumping up and down a short wall.”:这是一个描绘动作的句子,描述小鸡在矮墙上跳上跳下的情景,可以用于练习动词短语“up and down”。 【短语学习】: 1. “up and down”:表示上上...

    小学英语人教版PEP(三年级起点)六年级上册一课一练课堂练习.doc

    例如,可能的单词或短语包括:library(图书馆),supermarket(超市),post office(邮局),science museum(科学博物馆)等。 2. 对话排序:这部分练习旨在训练学生的语境理解能力和对话结构。给出的对话示例...

    朗文新派少儿英语词汇汇总PPT课件.pptx

    动物词汇有bug、cat、dog、frog,还有动作词汇如climbing、hiding、jumping rope、sliding和swinging。此外,还引入了基数词,如ten、twenty、thirty等,以及方位介词behind、in、in front of、on和under。 **Unit ...

    Get Smart 2 词汇表.doc

    - 活动:riding a bike, reading, eating, drinking, jumping rope, playing soccer, catching, chasing, sitting, making, watching TV, listening to music, playing a game 最后一个模块关注娱乐活动,包括运动...

    小升初必背1000个英语单词(分类).doc

    "supermarket"是超市,一站式购物的选择。 在服装和穿着方面,我们有:"coat"是外套,用于保暖;"blouse"是女式衬衣;"shirt"是衬衫,男女皆宜;"pyjamas"是睡衣,睡觉时穿的;"T-shirt"是T恤衫,休闲装;"sweater...

Global site tag (gtag.js) - Google Analytics