`
richard_ma
  • 浏览: 16675 次
最近访客 更多访客>>
社区版块
存档分类
最新评论

hdu1019 gcd和lcm

阅读更多
Least Common Multiple

http://acm.hdu.edu.cn/showproblem.php?pid=1019

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output
105
10296

解题思路
经典的最大公约数(gcd)和最小公倍数(lcm)题目。
这两个算法是代码模块。

注意:
先除后乘防止数据溢出!!

#include <stdio.h>
#include <stdlib.h>

int gcd(int a, int b)
{
    if (b == 0) {
        return a;
    } else {
        return gcd(b, a % b);
    }
}

int lcm(int a, int b)
{
    int g;

    g = gcd(a, b);
    return a / g * b;
}

int main (int argc, char const* argv[])
{
    int c, n, i, ans, t;

    scanf("%d", &c);

    while (c--) {
        scanf("%d", &n);

        scanf("%d", &ans);
        for (i = 1; i < n; i++) {
            scanf("%d", &t);
            ans = lcm(ans, t);
        }

        printf("%d\n", ans);
    }

    return 0;
}
分享到:
评论

相关推荐

    HDU1019(2028)解题报告

    Least Common Multiple ...先利用gcd算法求两个数的最大公约数,再考虑最小公倍数=两数乘积/最大公约数,即可求得最小公倍数。 注意:要考虑到输入的输入的n个数中的0,有0的要去掉0求其他数的最小公倍数。 代码:

    HDU+2000-2099+解题报告

    5. **数论**:包括最大公约数(GCD)、最小公倍数(LCM)、模逆、线性同余方程、素数判断等。 6. **数据结构**:堆(大顶堆、小顶堆)、平衡二叉搜索树(AVL、红黑树)、树状数组、 Fenwick Tree(二分索引树)等。 7....

    算术(HDU-6715).rar

    13. **数论概念**:如最大公约数(GCD)、最小公倍数(LCM)、质因数分解等。 14. **数学模型**:将实际问题转化为数学模型,如线性方程、二次方程等。 在提供的PDF文件中,可能包含了这个问题的详细描述、输入...

    人工智能基础-线性同余方程.pdf

    此外,对于一定范围内解的个数,如 HDU 1573 题目,可以先求出方程组的一个解,然后通过求解通解 `x = x0 + k * lcm` 来找到所有解,其中 `x0` 是最小非负解,`lcm` 是所有方程分母的最小公倍数。 在人工智能领域,...

    ACM程序设计 简单数学题

    1. 算术:ACM中的简单数学题可能涉及基本的加减乘除运算,以及整数的性质,例如最大公约数(GCD)、最小公倍数(LCM)的计算。有时候,快速幂算法、模逆运算等也会被用于优化计算效率。 2. 代数:线性方程、二次...

    ACM之特殊的数

    ACM中常用于计算最大公约数(GCD)和最小公倍数(LCM),或者解决与数的因子相关的题目。 6. **模运算下的特殊性质数**:在模运算中,有些数具有特殊性质,比如模逆元、欧拉函数φ(n)的值等。这些问题常常与数论中...

    ACM培训讲义

    1. **数论**:模运算、最大公约数(GCD)、最小公倍数(LCM)、质因数分解等在密码学和计算复杂性分析中常见。 2. **组合数学**:排列组合、鸽巢原理、容斥原理等在处理计数问题时不可或缺。 3. **线性代数**:...

    杭电ACM的11页部分题Java源代码

    例如,求最大公约数(GCD)、最小公倍数(LCM)、质数判断等。 8. **字符串处理**:题目中提到的2030题,可能是关于字符串处理的,正则表达式是处理字符串的一种强大工具,但也可以用C语言的字符串函数解决。 9. *...

Global site tag (gtag.js) - Google Analytics