`
qingdaoguy
  • 浏览: 24315 次
  • 性别: Icon_minigender_1
  • 来自: 南京
社区版块
存档分类
最新评论

杭电1004

    博客分类:
  • acm
UP 
阅读更多

题目来源:杭电acm1004

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

 

Sample Output
red pink

 

这里使用hashMap,ArrayList集合。源程序如下:

import java.util.*;

public class P1004 {
    public static void main(String args[]){
        int count;
        String color;
       
        Map map = new HashMap<String,Integer>();
        Scanner sin = new Scanner(System.in);
        ArrayList<String> name = new ArrayList<String>();
        count = sin.nextInt();
       
        while(count!=0){
            for(int i=0;i<count;i++){
                color = sin.next();
                if(map.containsKey(color)){
                    Integer tempNum = (Integer)map.get(color);
                    tempNum = tempNum + 1;
                    map.remove(color);
                    map.put(color, tempNum);                               
                }
                else{
                    map.put(color, new Integer(1));
                    name.add(color);
                }           
            }
           
            String maxColor = name.get(0);
            int max = (Integer)map.get(maxColor);
            name.remove(0);
            while(!name.isEmpty()){
                if(max<(Integer)map.get(name.get(0))){
                    maxColor = name.get(0);
                    max = (Integer)map.get(maxColor);
                }
                name.remove(0);
            }
            System.out.println(maxColor);
            name.clear();
            map.clear();
               count = Integer.parseInt(sin.next());
        }
    }
}

分享到:
评论

相关推荐

    杭电acm1004源码

    根据给定的杭电ACM 1004题目及提供的C语言源代码,我们可以从中提炼出以下几个重要的知识点: ### 1. 文件包含与头文件的使用 在C语言程序中,通过`#include`指令可以引入外部的头文件。在本例中,程序包含了两个...

    杭电acm1004

    杭州电子科技大学acm第1004题 let the balloon rise

    杭电OJ使用说明书 HDOJ使用说明书

    **杭电OJ使用说明书** **一、OJ系统简介** OJ,全称为Online Judge,是一种在线编程评测系统,用于自动评估用户提交的代码是否能正确解决特定问题。杭电OJ(HDOJ)是杭州电子科技大学开发并维护的在线编程竞赛平台...

    hdoj杭电入门训练题

    Let the Balloon Rise (HDOJ1004) **知识点:** - 字符串处理。 - 字符串匹配算法。 **解题思路:** - 读入字符串。 - 使用循环或字符串函数检查字符串是否包含特定字符序列。 - 如果包含,则输出“YES”,否则...

    杭电OJ题目分类

    - **1004**:可能涉及简单的数学计算或格式化输出。 - **1012**:可能会引入循环结构,例如求解斐波那契数列的前几项。 - **1014**:可以涉及到数组的基本操作,如遍历数组、查找最大值或最小值等。 - **1021**:...

    杭电ACM试题分类.do

    【杭电ACM试题分类】涉及的是编程竞赛中的算法与数据结构题目,主要围绕ACM(国际大学生程序设计竞赛)的训练题目进行整理。这些题目涵盖了多种算法和问题解决技巧,是提高编程能力和算法理解的重要资源。以下是这些...

    杭电题目分类

    【杭电题目分类】是杭州电子科技大学在线编程竞赛(杭电OJ)中对题目进行的一种整理和划分,便于参赛者根据自身水平和兴趣选择适合的题目进行练习。这些题目涵盖了计算机科学和技术的多个领域,包括算法设计、数据...

    ACM入门十题(杭电oj)

    从给定的文件信息来看,我们正在探讨的是ACM竞赛中的入门题目,这些题目选自杭州电子科技大学在线裁判系统(杭电OJ),是初学者熟悉编程和算法竞赛的良好起点。下面,我们将深入分析每一道题目的核心知识点,以便更...

    杭州电子科技大学OJ解题报告

    2. **最大气球颜色问题**(PID: 1004): 这个问题是关于统计不同颜色气球的数量,其中可能存在两种或多种颜色的气球数量最多。代码使用一个结构体数组`s`来存储每种颜色的气球数量和颜色名称。主函数中,程序读取...

    ACM 程序设计竞赛入门:第2讲 数学问题.ppt

    首先,我们来看一个典型的例子,例如杭州电子科技大学OJ1207题或杭电1018题,这两道题目都要求计算给定整数n的阶乘n!的位数。这里,阶乘表示的是1到n的所有正整数的乘积,即n! = 1 × 2 × 3 × ... × n。 计算...

Global site tag (gtag.js) - Google Analytics