Hangover
Description
How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.
Input
The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
Output
For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
Sample Input
1.00
3.71
0.04
5.19
0.00
Sample Output
3 card(s)
61 card(s)
1 card(s)
273 card(s)
#include <stdio.h>
#include <stdlib.h>
int sticknumber(float length);
int main(int argc, char *argv[])
{
float length;
scanf("%4f", &length);
while (length != 0) {
printf("%d card(s)\n", sticknumber(length));
scanf("%4f", &length);
}
}
int sticknumber(float length)
{
int i = 1;
float sum = 1.0/(i + 1);
while (sum < length) {
sum += 1.0/((++i)+1);
}
return i;
}
分享到:
相关推荐
在“Hangover1.GIF”这个文件中,我们可能看到了“Hangover”字体的动态展示,它可以是一张GIF动图,展示了字体在不同应用场景下的动态效果。这样的动态展示有助于用户更好地理解和感受字体的动态美感,尤其是在网页...
【标题】"POJ1003-Hangover"是一个编程竞赛题目,源自北京大学的在线判题系统POJ(Problem Online Judge)。这类题目通常要求参赛者编写程序来解决特定的算法问题,以此锻炼和测试编程技能及算法理解能力。 【描述...
Hangover Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 44187 Accepted: 20574 Description How far can you make a stack of cards overhang a table? If you have one card, you can create a...
1045 HangOver 简单题 1049 I Think I Need a Houseboat 简单题 1028 Flip and Shift 简单题,可以DP/BFS/……,但是实际上有数学方法可直接判断出来 1026 Modular multiplication of polynomials 简单题,有...
1045 HangOver 简单题 1049 I Think I Need a Houseboat 简单题 1028 Flip and Shift 简单题,可以DP/BFS/……,但是实际上有数学方法可直接判断出来 1026 Modular multiplication of polynomials 简单题,有...
这是Hangover,这是由StefanDösinger和AndréHentschel发起的一个项目,用于在aarch64 / ppc64le / x86_64 Wine上运行x86_64 / x86_32 Windows应用程序。 1)运作方式 在主机上,只有64位模式下有一个Wine,而对于...
在本例中,这个压缩包与北京大学ACM(算法竞赛)练习网站上的第1003题有关,该题目可能是关于图像处理或计算机视觉的一道编程挑战。 【描述】提到的"北京大学ACM练习网站1003题代码"意味着这个压缩包中包含的是为了...
Hangover是Google的即时通讯服务Hangouts的第一个本机Mac客户端。 目前,它实质上是 ( 的本机Swift... 目前,Hangover是用Swift 2.0编写的,这意味着您将需要才能编译应用程序。 同样,您会注意到Podfile明显为空。 所
* 1003 Hangover:本题目要求使用编程语言来模拟酒吧的营业情况。 * 1701 Dissatisfying Lift:本题目要求使用编程语言来模拟电梯的运行情况。 * 2301 Beat the Spread!:本题目要求使用编程语言来模拟股票交易的...
3. 1003Hangover:这个题目可能与数学计算有关,但具体内容需要查询原题。 4. 1004ManagementFinancial:这可能涉及到基本的财务计算。 5. 1013CounterfeitDollar:这个题目可能是一个与现金识别相关的逻辑题。 6...
7. **文件结构**:压缩包中的`the_hangover-main`很可能包含了项目的源代码和配置文件。典型的项目结构可能包括`src`目录(存放源代码)、`public`目录(存放静态资源)、`node_modules`目录(存放npm安装的依赖)、...
该题目主要考察了字符串处理能力,要求解决 HangOver 问题。该问题的解决需要对字符串处理有深入的理解。 知识点:字符串处理、字符串操作、字符操作。 4. ZOJ Problem Set – 1048 Financial Management 该题目...
* 1003 Hangover:这是一个简单的字符串处理题目,要求学习者编写一个程序来处理字符串。 搜索题 搜索题是POJ题目中的一种重要题型,通常涉及搜索算法和图论的应用,如深度优先搜索、广度优先搜索、迪杰斯特拉算法...
这篇资料是关于2014年高考英语完形填空的一道练习题,主题围绕着友谊的本质和朋友间相处的方式。文章中强调了友谊的无条件性和无批评性,指出真正的友谊建立在相互尊重和享受彼此陪伴的基础上,而不是基于讨论高深的...
保持固化 一个借助[TheCocktailDB]( )查看来自世界各地的饮料和鸡尾酒食谱的React应用程序。 特征 搜索和查看来自世界各地的饮料和鸡尾酒的食谱。 在彩色模式和深色模式之间切换。 开发人员说明 ...
依赖关系 节点 Ruby 入门 bundle install npm install bower install cd client bundle install npm install bower install 见 部署 ./script/deploy
3. 1003 Hangover:简单的模拟醉酒状态,注意条件分支。 4. 2301 Beat the Spread!: 模拟体育比赛的赌注,理解概率和比较。 5. 2304 Combination Lock:解锁密码组合,理解排列组合。 6. 2339 Rock, Scissors, Paper...
此外,POJ题目还包括一些数学题目,例如,1001 Exponentiation、1002 487-3279、1003 Hangover 等。这类题目需要程序员使用数学知识和算法来解决问题。 POJ题目是一个非常有价值的资源,对于程序员来说,通过解决...
5. "Hangover.doc":这道题可能涉及到图像的模糊处理或者图像效果的模拟,比如“宿醉”效果的实现。 6. "w4Biorhythms.doc":可能与生物节奏相关,但在这个上下文中可能是指图像的周期性变化或者某种滤波器的应用。...