Description
A single-player game is played on a rectangular board divided in R rows and C columns. There is a single uppercase letter (A-Z) written in every position in the board.
Before the begging of the game there is a figure in the upper-left corner of the board (first row, first column). In every move, a player can move the figure to the one of the adjacent positions (up, down,left or right). Only constraint is that a figure cannot
visit a position marked with the same letter twice.
The goal of the game is to play as many moves as possible.
Write a program that will calculate the maximal number of positions in the board the figure can visit in a single game.
Input
The first line of the input contains two integers R and C, separated by a single blank character, 1 <= R, S <= 20.
The following R lines contain S characters each. Each line represents one row in the board.
Output
The first and only line of the output should contain the maximal number of position in the board the figure can visit.
Sample Input
3 6
HFDFFB
AJHGDH
DGAGEH
Sample Output
6
Water DFS
LANGUEGE:C++
CODE:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define maxn 30
const int dir[8][2]={{1,0},{0,1},{-1,0},{0,-1}};
bool used[maxn];
int n,m;
char matrix[maxn][maxn],cnt,max;
void dfs(int x,int y)
{
for(int i=0;i<4;i++)
{
int x1=x+dir[i][0];
int y1=y+dir[i][1];
if(x1>0&&x1<=n&&y1>0&&y1<=m&&!used[matrix[x1][y1]])
{
used[matrix[x1][y1]]=true;
cnt++;
dfs(x1,y1);
if(cnt>max)max=cnt;
used[matrix[x1][y1]]=false;
cnt--;
}
}
}
int main()
{
char s[maxn];
while(scanf("%d%d",&n,&m)!=EOF)
{
getchar();
cnt=1,max=1;
for(int i=1;i<=n;i++)
{
gets(s);
for(int j=0;j<m;j++)
{
matrix[i][j+1]=s[j]-'A'+1;
}
}
used[matrix[1][1]]=true;
dfs(1,1);
used[matrix[1][1]]=false;
printf("%d\n",max);
}
return 0;
}
分享到:
相关推荐
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in ...
poj1002 source code input: The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on ...
Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. ...
2. **LETTERS (POJ 1154)** - **题目描述**:给定一个大写字母矩阵,从左上角出发,每步可以向上下左右四个方向移动一格,不能重复经过同一个字母。求最多能经过多少个不同的字母。 这道题目考察了深度优先搜索...
BFS可以用来求解最短路径问题,如“PKU1154: LETTERS”,其中需要从图的某个节点出发,找到另一指定节点的最短路径。 报告中提到的每一道题目都有其对应的解题报告与代码,详细阐述了解决算法题目的思路和实现。...