`
hellojyj
  • 浏览: 61771 次
  • 性别: Icon_minigender_1
  • 来自: 长沙
社区版块
存档分类
最新评论

ZOJ 2165 Red and Black

    博客分类:
  • ACM
阅读更多

原题传送门:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2165

 

Red and Black

 


 

Time Limit: 2 Seconds      Memory Limit: 65536 KB

 


 

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

 

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 


Input

 

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

 

  • '.' - a black tile
  • '#' - a red tile
  • '@' - a man on a black tile(appears exactly once in a data set)

 


Output

 

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 


Sample Input

 

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

 


Sample Output

 

45
59
6
13

 


Source: Asia 2004, Ehime (Japan), Japan Domestic

 

这道题主要是考察BFS(广度优先搜索),每次去搜索与某个点相邻的(上下左右)四个点,如果这四个点中有符合条件---1.x>0,y>0,x<row,y<cloumn,并且没有被访问过,以及不是红色砖块。那么将这个个点入队。那么用什么条件来控制这个循环呢?答案当然是队列为空!

 

首先将起始点Pos,进队,然后while(队列不为空){  count++; 检查四周有木有符合上述条件的点,有则入队} printf count is ok!

 

//图的BFS ZOJ 2165
#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
struct Pos{
    int x;
    int y;
};
const int MAXN = 21;
char list[MAXN][MAXN];
bool isVisited[MAXN][MAXN];
int row,cl,count;
Pos staPos;
int main(){
  queue<Pos> bfs;
  while(scanf("%d %d",&cl,&row)!= EOF){
        if(cl == 0&&row==0)break;
        count = 0;
        for(int i=1;i<MAXN;i++){
            for(int j=1;j<MAXN;j++){
                isVisited[i][j] = false;
            }
        }
        for(int i=1;i<=row;i++){
            scanf("%s",list[i]+1);
        }
        for(int i=1;i<=row;i++){
            for(int j=1;j<=cl;j++){
                if(list[i][j] == '@'){
                    staPos.x = i;
                    staPos.y = j;
                }
            }
        }
        bfs.push(staPos);
        isVisited[staPos.x][staPos.y] = true;
        while(!bfs.empty()){

            count++;
            Pos tempPos = bfs.front();
            bfs.pop();
            if((list[tempPos.x+1][tempPos.y] == '.')&& (tempPos.x+1<=row) && (!isVisited[tempPos.x+1][tempPos.y])){
                Pos newPos1;
                newPos1.x = tempPos.x+1;
                newPos1.y = tempPos.y;
                bfs.push(newPos1);
                isVisited[newPos1.x][newPos1.y] = true;
            }

            if((list[tempPos.x-1][tempPos.y] == '.')&& (tempPos.x-1>0) && (!isVisited[tempPos.x-1][tempPos.y])){
                Pos newPos2;
                newPos2.x = tempPos.x-1;
                newPos2.y = tempPos.y;
                bfs.push(newPos2);
                isVisited[newPos2.x][newPos2.y] = true;
            }
            if((list[tempPos.x][tempPos.y+1] == '.')&& (tempPos.y+1<=cl) && (!isVisited[tempPos.x][tempPos.y+1])){
                Pos newPos3;
                newPos3.x = tempPos.x;
                newPos3.y = tempPos.y+1;
                bfs.push(newPos3);
                isVisited[newPos3.x][newPos3.y] = true;
            }
            if((list[tempPos.x][tempPos.y-1] == '.')&& (tempPos.y-1>0) && (!isVisited[tempPos.x][tempPos.y-1])){
                Pos newPos4;
                newPos4.x = tempPos.x;
                newPos4.y = tempPos.y-1;
                bfs.push(newPos4);
                isVisited[newPos4.x][newPos4.y] = true;
            }

        }

        printf("%d\n",count);
  }
  return 0;

}

 

0
0
分享到:
评论

相关推荐

    zoj 1237 Fans and Gems.md

    zoj 1237 Fans and Gems.md

    zoj 2886 Look and Say.md

    zoj 2886 Look and Say.md

    zoj 1002_zoj1002_

    【标题】"ZOJ 1002" 是一个在线编程竞赛题目,源自ZOJ(Zhejiang Online Judge),这是一个面向ACM/ICPC(国际大学生程序设计竞赛)的在线评测系统。题目编号1002,通常表示该题是ZOJ平台上的一个问题,可能涉及算法...

    zoj 源码700题

    【标题】"zoj 源码700题"是指一个包含700多道ZOJ(在线判题系统Zhejiang Online Judge)编程竞赛题目的源代码集合。这个资源对于学习算法、提高编程技能以及准备编程竞赛的学员来说极具价值。 【描述】"包含了zoj...

    ZOJ:浙江大学程序在线评测系统.docx

    ZOJ,全称“浙江大学程序在线评测系统”(Zhejiang University Online Judge),是一个提供信息学(算法竞赛)题库及程序评测的网站。以下是关于ZOJ的详细介绍: 一、基本信息 名称:浙江大学程序在线评测系统(ZOJ)...

    Problem Arrangement zoj 3777

    Problem Arrangement zoj 3777

    zoj 题库 详细解答 解题代码

    7. ZOJ Problem Set – 1073 Round and Round We Go 该题目主要考察了循环和递归算法能力,要求解决 Round and Round We Go 问题。该问题的解决需要对循环和递归算法有深入的理解。 知识点:循环算法、递归算法、...

    浙江大学ZOJ题目分类

    浙江大学ZOJ(Zhejiang University Online Judge)是一个在线编程练习平台,主要服务于计算机科学和技术的学习者,特别是对算法和编程有浓厚兴趣的学生。这个平台提供了大量的编程题目,涵盖了各种难度和主题,帮助...

    zoj1027解题指南

    【标题】"ZOJ1027解题指南"是一个针对特定编程竞赛题目——ZOJ1027的解决方案集合。ZOJ,全称为“Zhejiang Online Judge”,是浙江大学主办的一个在线编程竞赛平台,提供了丰富的算法题目供参赛者练习和挑战。本解题...

    ZOJ题目答案源码

    ZOJ(Zhejiang Online Judge)是一个著名的在线编程竞赛平台,主要面向计算机科学与信息技术的学生和爱好者,提供了大量的算法题目供参赛者练习和提交代码。"ZOJ题目答案源码"是一个压缩包文件,其中包含了700多道...

    zoj 700源代码

    ZOJ,全称为Zhejiang Online Judge,是一个知名的在线编程竞赛平台,主要服务于浙江大学和国内其他高校的学生,提供丰富的算法题目供参赛者练习和比赛。这个压缩包文件名为"ZOJ 700多题源代码",意味着它包含了解决...

    zoj.gz_ ZOJ_ZOJ 1016_max flow_zoj 1045_zoj.rar

    标题中的"ZOJ.gz_ ZOJ_ZOJ 1016_max flow_zoj 1045_zoj.rar" 提到了两个ZOJ(Zhejiang Online Judge)的题目,分别是1016和1045,这两个数字通常代表在线编程竞赛中的题目编号。这些题目通常涉及到算法和数据结构的...

    zoj题目简单归类zoj题目简单归类

    ### ZOJ 题目简单归类解析 在IT竞赛和编程练习中,ZOJ(Zhejiang University Online Judge)平台提供了丰富的算法题目供学习者挑战和提升技能。本次解析将聚焦于部分被标记为“简单”的ZOJ题目,通过细致分析其描述...

    ZOJ.zip_Jugs A_ZOJ NTA_zoj acm_zoj acm 1216_zoj code

    【ZOJ.zip】是一个压缩包,里面包含了与ZOJ(Zhejiang Online Judge)相关的ACM(International Collegiate Programming Contest)题解。ZOJ是一个在线编程竞赛平台,它为参赛者提供了一系列算法题目进行练习,以...

    ACM训练必备POJ ZOJ题目分类及解题思路

    学习ACM程序设计的朋友一定要看,这是训练必备的POJ ZOJ题目分类及解题思路

    zoj.rar_zoj_zoj4041

    《ZOJ 4041问题的正确解法与程序分析》 ZOJ(Zhejiang Online Judge)是一个知名的在线编程竞赛平台,其中的题目编号为4041的题目吸引了众多程序员的关注。本篇文章将深入探讨ZOJ 4041的正确解法,并对提供的源代码...

    ZOJ1805代码

    ZOJ1805代码

    zoj 1003c 语言的

    zoj 1003 c语言的,要写这么多描述吗。。

    zoj1951的AC代码

    本代码是zoj上AC的1951的代码,把双重循环简化为O(n),不过素数判断的改进还不够

    ZOJ1014.zip_zoj code_zoj1004

    标题“ZOJ1014.zip_zoj code_zoj1004”表明这是一个与ZOJ(ZeroJudge)在线判题系统相关的代码压缩包,其中可能包含了解决ZOJ问题1004的源代码。ZOJ是面向编程爱好者和学生的一个在线编程竞赛平台,它提供了各种算法...

Global site tag (gtag.js) - Google Analytics