`
hellobin
  • 浏览: 65474 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 10098 - Generating Fast

    博客分类:
  • UVA
 
阅读更多

Generating permutation has always been an important problem in computer science. In this problem you will have to generate the permutation of a given string in ascending order.  Remember that your algorithm must be efficient.


Input

The first line of the input contains an integer n, which indicates how many strings to follow. The next n lines contain n strings. Strings will only contain alpha numerals and never contain any space. The maximum length of the string is 10.

 
Output

For each input string print all the permutations possible in ascending order. Not that the strings should be treated, as case sensitive strings and no permutation should be repeated. A blank line should follow each output set.

 

Sample Input

3
ab
abc
bca

 

 

 

Sample Output

ab
ba

abc
acb
bac
bca
cab
cba

abc
acb
bac
bca
cab
cba

 

 

直接调用库函数next_permutation,在调用前要用qsort先排序下

 

#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>
#include <ctime>

using namespace std;

#define MAXN 110

char buf[MAXN];

int cmp( const void *a , const void *b )  
{
	return *(char *)a - *(char *)b;  
} 

int main(){

#ifndef ONLINE_JUDGE
	freopen("10098.in", "r", stdin);
	freopen("out.out", "w", stdout);
#endif

	int n;
	scanf("%d", &n);
	while(n--){
		memset(buf, 0, sizeof(buf));
		scanf("%s", buf);
		qsort(buf, strlen(buf), sizeof(buf[0]), cmp);

		do {
			printf("%s\n", buf);
		} while ( next_permutation(buf, buf+strlen(buf)) );
		printf("\n");
	}
}


#endif

 

分享到:
评论

相关推荐

    Self-generating-code.zip

    标题“Self-generating-code.zip”和描述中的信息都指向了一个概念——自动生成代码(Self-generating code)。在IT行业中,自动生成代码是指通过自动化工具、模板或者编程语言特性,根据预定义的规则或模型,自动...

    GROK-FPGA- GENERATING.pdf

    根据提供的文件信息,本文将重点解析"GROK-FPGA- GENERATING REAL ON-CHIP KNOWLEDGE FOR FPGA FINE-GRAIN DELAYS USING TIMING EXTRACTION"所涉及的关键知识点,并结合部分内容进行详细阐述。 ### 标题解析:GROK-...

    Improved PSO Used in the Auto-generating Test Paper Algorithm

    【摘要分析】 本文针对当前自动组卷算法的不足,提出了一种改进的粒子群优化(PSO)方法,并将其应用于自动组卷算法中。作者首先分析了通用的自动组卷算法存在的问题,然后设计了自动组卷算法的数学模型,并对传统...

    关于泊松点过程的生成方法-Generating Homogeneous Poisson Processes - PDF.pdf

    关于泊松点过程的生成方法-Generating Homogeneous Poisson Processes - PDF.pdf 在百度上看很多人问平面内泊松点怎么生成,以前我也迷茫的很久,刚好今天找到一个很有用的方法,分享给大家! Report1_...

    Variance, covariance, correlation, moment-generating functions.pdf

    Introduction to Probability,Variance, covariance, correlation, moment-generating functions。概率论中的方差协方差相关等概念解析。

    eu-16-Wen-Use-After-Use-After-Free-Exploit-UAF-By-Generating

    【 eu-16-Wen-Use-After-Use-After-Free-Exploit-UAF-By-Generating 】这篇内容主要探讨了网络安全中的一个重要问题:Use-After-Free (UAF) 漏洞的利用和防御策略。作者Guanxing Wen是一名在Pangu LAB工作的安全研究...

    Herbert S. Wilf - Generating Functions.pdf

    ### Generating Functions in Discrete Mathematics: An Overview Based on Herbert S. Wilf's Work #### Introduction to Generating Functions Generating functions serve as a bridge between discrete ...

    notes-generating-appp

    【笔记生成应用 "notes-generating-appp" 深度解析】 在当今信息化时代,高效地管理和生成笔记是提升个人及团队工作效率的关键。"notes-generating-appp" 是一款专为此目的设计的应用程序,它利用先进的技术和人性...

    PERFORMANCE PROTOTYPING - GENERATING AND SIMULATING A DISTRIBUTED IT-SYSTEM FROM UML MODELS

    ### 性能原型设计——从UML模型生成与模拟分布式IT系统 #### 概述 在信息技术领域,特别是在软件性能工程(SPE)方面,“性能原型设计”是一种重要的方法论和技术,它允许工程师们在项目的早期阶段就评估系统的...

    intellij-test-generating-plugin

    总的来说,【intellij-test-generating-plugin】是一个实用的开发工具,它通过自动化的方式降低了编写测试代码的负担,鼓励开发者遵循TDD(测试驱动开发)原则,从而提升代码质量和项目稳定性。如果你是Java开发者...

    Episode-Based Prototype Generating Network for Zero-Shot Learnin

    在"Episode-Based Prototype Generating Network for Zero-Shot Learning"这篇论文中,作者提出了一种新的训练框架,用于解决零样本学习(ZSL)中的挑战。这个框架基于episode训练,每个episode模拟一个零样本分类...

    poem-generating

    我是来自尼日利亚的Chukwuemeka Egbuchulam,一位致力于数据的科学家,他喜欢通过数据洞察力构建模型和创建解决方案 数据科学家和机器学习科学家 在提出想法和提出特定问题的解决方案时,我至关重要。...

    diagnosis-generating2

    "diagnosis-generating2"可能是一个工具,它帮助开发者自动检测并修复上述问题。这样的工具可能会分析HTML代码,指出潜在问题,并提供修改建议。此外,它可能还具备自动化生成HTML的功能,根据预设的模板或者用户...

    A Segmentation Method for Lung Parenchyma Image Sequences Based on Superpixels and a Self-Generating Neural Forest

    A Segmentation Method for Lung Parenchyma Image Sequences Based on Superpixels and a Self-Generating Neural Forest

    GAN-for-generating-MNIST-images

    GAN用于生成MNIST图像

    母函数(Generating function)详解

    母函数,又称生成函数,是数学中一种强大的工具,特别是在组合数学和数论领域。它是一种将序列编码为单一的函数表达式,使得序列的性质可以通过处理这个函数来揭示。母函数通过这种方式提供了序列分析的新视角,使得...

    matlab图像膨胀代码-the-Second-Order-Gradients-Based-Method-for-Generating-Adv

    Generating Adversarial Example”的对应代码。 Tensorflow 中三种攻击算法的实现。 它在 Python 3.6 和 matlab 2018b 上正确运行。 model.image_size:图像大小(例如,MNIST 为 28,CIFAR 为 32) model.num_...

    WC Yeh-universal generating MPs

    ### WC Yeh-universal generating MPs #### 概述 该文章由IEEE Transactions on Systems, Man, and Cybernetics—Part A: Systems and Humans在2009年11月发表,作者Wei-Chang Yeh(IEEE高级会员)提出了一种简单...

    视频图matlab代码-Autonomous-2D-Map-Generating-Robot:自主制图机器人

    视频图matlab代码自主2D地图生成机器人 这款自主的2D地图生成机器人是为在Carleton大学进行的ELEC 3907第三年开放式项目课程而创建的。 该项目是由6位热衷于设计和从事项目工作的个人创建的。 该机器人的工作方式是...

    颜色分类leetcode-dsc-generating-data:dsc生成数据

    颜色分类leetcode 生成数据 介绍 数据分析通常需要分析师使用某种类型的数据来测试算法的效率/性能。 在这种情况下,重点不是像我们之前看到的那样回答一些分析问题,而是测试一些机器学习假设,例如,比较两种不同...

Global site tag (gtag.js) - Google Analytics