`
hellobin
  • 浏览: 65455 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 10055 Hashmat the brave warrior

    博客分类:
  • UVA
 
阅读更多

Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before fighting he just calculates one thing, the difference between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Hashmat's soldier number is never greater than his opponent.

 

Input

The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input numbers are not greater than 2^32. Input is terminated by End of File.

 

Output

For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.

 

Sample Input:

10 12
10 14

100 200

 

Sample Output:

2
4

100

 

 

 

//#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>


using namespace std;


#define MAXN 1000


int main(){


#ifndef ONLINE_JUDGE
	freopen("10055.in", "r", stdin);
	freopen("10055.out", "w", stdout); 
#endif

	// 必须用long类型来通过
	unsigned long int a, b;

	while (scanf("%lu%lu", &a, &b) == 2)
	{
		if(a >= b){
			printf("%lu\n", a-b);
		}
		else{
			printf("%lu\n", b-a);
		}
	}


}


#endif




分享到:
评论

相关推荐

    Rethinking the design of the Internet:The end to end arguments vs. the brave new world

    the brave new world 作者:Marjory S. Blumenthal, Computer Science & Telecommunications Bd David D. Clark, M.I.T. Lab for Computer Science 这是Clark后来反思端到端论点的论文,此前他写过关于端到端论点的...

    Clojure for the Brave and True

    Clojure for the Brave and True offers a 'dessert-first' approach: you'll start playing with real programs immediately, as you steadily acclimate to the abstract but powerful features of Lisp and ...

    We_Are_The_Brave.pcm

    播放参数: 1.采样精度:32 bit pcm 2.格式:little endian 3.通道数:1 channel moon 4.采样率:44100

    該注意的點1

    `Hashmat the Brave Warrior`这部分看起来像是一个编程竞赛题目或者故事的名称,它可能涉及字符串处理、数组操作、算法应用等。由于没有具体的内容,我们无法提供详细的解析。通常,这类题目可能要求解决特定问题,...

    在windows下编译brave浏览器

    ### 在Windows下编译Brave浏览器的关键步骤及注意事项 #### 一、概述 本文旨在详细介绍如何在Windows操作系统下成功编译Brave浏览器的过程。Brave是一款开源浏览器,以其隐私保护特性而闻名。对于想要深入了解其...

    brave-jar.zip

    brave-5.12.7.jar,brave-context-slf4j-5.12.7.jar,brave-instrumentation-http-5.12.7.jar,brave-instrumentation-httpasyncclient-5.12.7.jar brave-instrumentation-httpclient-5.12.7.jar brave-instrumentation...

    brave-impl-2.1.1.zip

    《深入理解Brave:Java分布式追踪的开源实现》 在当今的微服务架构中,分布式系统中的服务调用变得越来越复杂。为了有效地监控和调试这些跨服务的交互,分布式追踪技术应运而生。Brave,作为一个开源项目,提供了一...

    Typecho主题情侣博客Brave主题源码

    "Brave主题"是专为Typecho设计的一款独特主题,尤其适合情侣博主使用,为他们的网络空间增添浪漫与温馨的氛围。 该主题的核心亮点在于其丰富的功能设计。首先是"计时器"功能,这个功能可以用来记录情侣间的特殊日子...

    brave-core,勇敢浏览器的核心引擎,适用于MacOS、Windows、Linux以及最终的Android。有关问题日志,请参见.zip

    勇敢浏览器(Brave)是一款基于开源的Chromium项目构建的安全、快速且注重隐私的网络浏览器。它的核心引擎,称为“Brave Core”,是Brave浏览器区别于其他基于Chromium的浏览器的关键所在。这个核心引擎包含了特定的...

    【Typecho主题】情侣博客Brave主题源码.zip

    【Typecho主题】情侣博客Brave主题源码是一款专为情侣设计的个性化博客主题,它提供了丰富的功能,如计时器、留言板、恋爱清单以及记录生活点滴的模块,旨在帮助情侣们在网络上创建一个温馨的共享空间,记录他们的...

    brave-browser,下一代勇敢的MacOS、Windows、Linux浏览器,最终是Android浏览器.zip

    "Brave浏览器"是一款由Brendan Eich(JavaScript的创造者)和Brian Bondy共同创立的创新性网络浏览器,其目标是提供更快、更安全的浏览体验,同时注重用户隐私。这款浏览器不仅适用于MacOS、Windows和Linux操作系统...

    Typecho 情侣主题 「Brave」v1.2 情侣网站源码.rar

    【Typecho 情侣主题「Brave」v1.2 概述】 Typecho是一款轻量级的开源博客系统,以其简洁、高效和易于扩展的特性受到许多个人和情侣博主的喜爱。此次介绍的主题「Brave」是专为情侣网站设计的,版本号v1.2,它为...

    Windows版 Brave Browser

    Brave Browser是一款速度非常快的浏览器,它基于Chromium开发。其特性就是保护隐私且快速。官网宣称:“比 Chrome 快 3 倍。能更好地保护您,让您不受 Google 和其他科技巨头的威胁。” 默认情况下,Brave 浏览器会...

    brave-impl-spring-2.2.0.zip

    【标题】"brave-impl-spring-2.2.0.zip" 提供的是Brave框架的一个Spring实现的版本,具体为2.2.0。Brave是一个分布式追踪系统,它主要用于微服务架构中的性能监控,它实现了Zipkin的客户端接口,Zipkin是一种流行的...

    Typecho主题Brave1.1下载

    Brave主题是一款适合正在搞对象的博主使用,具有计时器、留言板恋爱清单、点点滴滴记录等功能,基本上是保留了Cupid主题的所有功能,UI重新进行了设计。 提醒:使用此主题,需要先安装主程序:最新 Typecho1.1-...

    Brave浏览器官方正版秒杀Google

    浏览器,高速,无痕,私密,安全,纯净,广告拦截,最新版。自行体会~

    brave-browser-master.zip

    Brave浏览器简介 2014年Eich从Mozilla离职,并于2015年和合作伙伴共同创立了Brave公司。2016年,具有反追踪功能的第一个版Brave浏览器发布,后来又增加了捐助功能和付费广告功能。Eich希望Brave可以通过改变传统的...

Global site tag (gtag.js) - Google Analytics