`
hellobin
  • 浏览: 65501 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 458 The Decoder

    博客分类:
  • UVA
 
阅读更多

The Decoder

Write a complete program that will correctly decode a set of characters into a valid message. Your program should read a given file of a simple coded set of characters and print the exact message that the characters contain. The code key for this simple coding is a one for one character substitution based upon asingle arithmetic manipulationof the printable portion of the ASCII character set.

 

Input and Output

For example: with the input file that contains:

 

1JKJ'pz'{ol'{yhklthyr'vm'{ol'Jvu{yvs'Kh{h'Jvywvyh{pvu5
1PIT'pz'h'{yhklthyr'vm'{ol'Pu{lyuh{pvuhs'I|zpulzz'Thjopul'Jvywvyh{pvu5
1KLJ'pz'{ol'{yhklthyr'vm'{ol'Kpnp{hs'Lx|pwtlu{'Jvywvyh{pvu5

your program should print the message:

*CDC is the trademark of the Control Data Corporation.
*IBM is a trademark of the International Business Machine Corporation.
*DEC is the trademark of the Digital Equipment Corporation.

Your program should accept all sets of characters that use the same encoding scheme and should print the actual message of each set of characters.

 

Sample Input

 

1JKJ'pz'{ol'{yhklthyr'vm'{ol'Jvu{yvs'Kh{h'Jvywvyh{pvu5
1PIT'pz'h'{yhklthyr'vm'{ol'Pu{lyuh{pvuhs'I|zpulzz'Thjopul'Jvywvyh{pvu5
1KLJ'pz'{ol'{yhklthyr'vm'{ol'Kpnp{hs'Lx|pwtlu{'Jvywvyh{pvu5

 

Sample Output

 

*CDC is the trademark of the Control Data Corporation.
*IBM is a trademark of the International Business Machine Corporation.
*DEC is the trademark of the Digital Equipment Corporation.

#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 1000


int main(){


#ifndef ONLINE_JUDGE
	freopen("458.in", "r", stdin);
	freopen("458.out", "w", stdout); 
#endif

	
	char c;

	while(scanf("%c", &c) != EOF){
		if(c != '\n'){
			printf("%c", c-7);
		}
		else{
			printf("\n");
		}
	}

	return 0;

}


#endif

分享到:
评论

相关推荐

    EasyToYou - IonCube Decoder [v8.4].zip_IonCube Decoder 8.4_IonCu

    EasyToYou is a decoder of IonCube, as the name indicates, here you can decode the files encrypted with IonCube easily. We have developers working every day to keep the site and the decoder updated. If...

    decoder_decoder5.0_zenddecoder_

    【标题】"decoder_decoder5.0_zenddecoder_" 指的是一个名为 "decoder" 的解码工具,特别针对 "Zend php 5.6.9.0" 版本。这个解码器可能是用于处理由 Zend Optimizer 或 Zend Guard 加密的 PHP 代码,使得开发者能够...

    sun.misc.base64decoder.jar下载

    sun.misc.BASE64Encoder找不到jar包的解决方法?... Access restriction : The constructor BASE64Decoder() is not accessible due to restriction on required library C:\Program files\java\jre6\lib\rt.jar

    BASE64Decoder包

    BASE64Decoder包 加密代码: 加密前字符串:String key="mykey"; byte[] bt = key.getBytes(); 加密后字符串:String newKey=(new BASE64Encoder()).encodeBuffer(bt); 解密代码: 加密后的字符串:String newkey=...

    libmp3decoder-1[1].0

    libmp3decoder, the library is to decoder mp3 audio stream to pcm audio stream. the library is witten by c language, so it is independent-plateform. it can be compiled in any plateform, in the ...

    RS Decoder

    - RSDecoder.v : contains description of top module of the decoder. It combines 5 modules of typical RS Decoder building blocks. - scblock.v : contains description of the SC (Syndrome Computation) ...

    Decoder_V2.03-cardreadertech_decoder_V2_

    标题中的"Decoder_V2.03-cardreadertech_decoder_V2_"表明这是一款名为"Decoder V2.03"的软件,由CardReaderTech公司开发,版本号为V2。这款软件的核心功能很可能是用于解码或编码某些特定的数据,比如音频、视频、...

    PIE_decoder_model.zip_PIE RFID_RFID matlab_The Project_decoder s

    PIE(pulse interval decoder)- Its the PIE decoder that I built for my RFID project. Its an ambedded simulink model.

    sun.misc.BASE64Decoder

    // Now 'decodedBytes' contains the original bytes } } ``` 在这个例子中,`Base64.getDecoder()`创建了一个Base64解码器实例,然后`decode()`方法用于将Base64字符串解码为原始字节数组。 使用`java.util....

    BASE64Decoder jar包

    Base64Decoder是处理这种编码的关键工具,尤其在加密和解密过程中扮演着重要角色。下面将详细阐述Base64编码的基本原理、用途,以及如何使用Base64Decoder进行加密和解密。 Base64编码源于电子邮件系统,目的是将非...

    mjpeg_decoder.rar_The Image

    Loads a new frame, reads its headers, and determines the uncompressed image format.

    iDezender_3.4.zip_IonCube_Decoder_Ioncube__decoder_ionCube_ioncu

    IonCube decoder iDezender 3.4

    sun.misc.BASE64Decoder(Android Base64Jar包以及Java源代码)

    sun.misc.BASE64Decoder 其中包括 Android Base64Jar包 以及Java源代码 sun.misc.BASE64Decoder 其中包括 Android Base64Jar包 以及Java源代码 sun.misc.BASE64Decoder 其中包括 Android Base64Jar包 以及...

    component_decoder.rar_MAAB_The Process_iterative decoding_turbo

    this code maab descrie the decoder componetnt of turbo with iterative decoding process

    Zend-Decoder-master.zip_?ONCUBE DECODE_ionCube decrypt_smooths3t

    Decoder of IonCube, as the name indicates, here you can decode the files encrypted with IonCube easily. We have developers working every day to keep the site and the decoder updated. If you want to ...

    PHP DECoder

    【PHP Decoder】是一种专门用于解码PHP源代码的工具,主要应用于处理被混淆或加密的PHP脚本。在Web开发领域,尤其是开源软件社区,PHP源码的可见性有助于代码的共享和学习,但同时也可能导致代码被盗用或恶意篡改。...

    IonCube v8.3 Decoder

    【描述】提到的"IonCube v8.3 Decoder"意味着它支持IonCube的第8.3版本。每个版本的IonCube可能都有所改进,包括对新版本PHP的兼容性、性能提升和可能的安全增强。解码器的存在是为了帮助开发者或系统管理员在不拥有...

    sun.misc.BASE64Decoder.zip

    《深入解析Java 7中的sun.misc.BASE64Decoder》 在Java编程中,`sun.misc.BASE64Decoder`是Java 7版本中一个用于解码Base64编码的数据的类。Base64是一种广泛使用的编码方式,它将任意二进制数据转换为可打印的...

    therm_decoder_1.rar

    温度计码解码器(thermometer decoder),温度计码由连续的1组成,解码器将温度计码解码成二进制码,并且具有气泡判断功能。压缩包内包含Verilog代码、modelsim仿真文件testbench、quartus II工程文件

Global site tag (gtag.js) - Google Analytics