`
hellobin
  • 浏览: 65461 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 494 Kindergarten Counting Game

    博客分类:
  • UVA
 
阅读更多

Everybody sit down in a circle. Ok. Listen to me carefully.

``Woooooo, you scwewy wabbit!''

Now, could someone tell me how many words I just said?

 

Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).

 

Your program should output a word count for each line of input. Each word count should be printed on a separate line.

 

Sample Input

 

Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...

 

Sample Output

 

2
7
10
9

注意:单词的定义是只含字母,a...a是2个单词



#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 1000


int main(){


#ifndef ONLINE_JUDGE
	freopen("494.in", "r", stdin);
	freopen("494.out", "w", stdout); 
#endif

	char c;
	int cnt = 0;
	bool isword = false;

	while(scanf("%c", &c) != EOF){
		if(c == '\n'){
			if(isword){
				cnt++;
			}
			printf("%d\n", cnt);
			cnt = 0;
			continue;
		}
		
		if(isalpha(c)){
			isword = true;
		}
		if(!isalpha(c) && isword){
			cnt++;
			isword = false;
		}
	}
	


	
	
}


#endif


分享到:
评论

相关推荐

    kindergarten-game:适用于学龄前儿童的安卓应用

    在"kindergarten-game-master"这个压缩包中,我们可以推测包含的是游戏的源代码和资源文件。源代码部分可能包括了游戏逻辑的实现,如游戏规则、得分系统、用户输入处理等。资源文件可能涵盖游戏的图像、音频、布局...

    KinderGarten(备用资料)

    KinderGarten,刘坤的作品,作为以后的资料参考用

    Kindergarten

    《Kindergarten》是一款独特风格的冒险解谜游戏,以其幽默的剧情、丰富的谜题和独特的艺术风格深受玩家喜爱。在这款游戏中,玩家将扮演一名幼儿园的小朋友,通过探索和互动解决一系列有趣的问题,揭示隐藏在幼儿园...

    一个用于将kindergarten整合到VueJS应用程序中的VueJS20插件

    而"kindergarten"在上下文中似乎是指一个特定的库或模块,它被设计为与VueJS 2.0版本集成,以扩展Vue的应用能力。不过,由于没有提供更详细的信息,我们只能基于VueJS 2.0的基础特性来探讨这个插件可能涉及的知识点...

    vue-kindergarten, 为 Vue,Vuex,Vue路由器和Nuxt提供模块化安全.zip

    vue-kindergarten, 为 Vue,Vuex,Vue路由器和Nuxt提供模块化安全 kindergarten幼儿园 简介幼儿园是一个用于 VueJS 2.0的插件,它将幼儿园插件集成到你的VueJS应用程序中。 它可以以帮助你在非常模块化的方式下授权...

    Kindergarten-management-system.zip_kindergarten_sex_年龄排序

    “Kindergarten-management-system.zip”压缩包内含“Kindergarten management system.docx”文档,这是系统的主要使用指南,旨在帮助用户理解如何操作和利用该系统。该系统的核心功能之一是对幼儿园儿童的数据进行...

    KinderGarten game(by Fourty-two aka 42.)-开源

    《KinderGarten游戏——由Fourty-two(42)开源解析》 在信息技术领域,开源软件已经成为一种重要的发展趋势,它允许用户自由地查看、使用、修改和分发软件源代码。今天我们要讨论的是名为“KinderGarten”的游戏,这...

    基于Python语言的manim kindergarten社区设计源码集合

    该项目是一个基于Python语言的幼儿园教育辅助工具源码集合,隶属于manim-kindergarten社区。该集合包含161个文件,主要类型为Python代码,同时包含61个PNG图片、14个SVG图形、8个GIF动画、4个PDF文档、2个Markdown...

    Wordpress Kindergarten模板

    【Wordpress Kindergarten模板】是专为幼儿园或儿童教育机构设计的一款WordPress主题,它结合了色彩鲜艳、卡通化的视觉元素,以及对教育内容展示的友好布局,旨在吸引孩子们的注意力并方便家长和教师的使用。...

    kindergarten:幼儿园

    本文将详细解析一款名为"Kindergarten"的幼儿园管理软件,特别是其针对司机端的功能设计,包括车辆认证、技能认证、提现以及流水和评价列表等核心模块,并探讨其中JavaScript技术的应用。 首先,我们来看“司机端...

    Kindergarten.zip

    在这个名为 "Kindergarten.zip" 的压缩包中,包含了一个完整的幼儿园网站项目,该网站无需数据库支持,但提供了丰富的功能,旨在展示幼儿园的相关信息。 1. **首页**:首页通常是用户访问网站时首先看到的界面,...

    Prediction of kindergarten reading success from preschool report of parents

    Prediction of kindergarten reading success from preschool report of parents 304 Psychology in the Schools, July , 1976, Vol. I S , No. 3. of individual children. However, the hypothesis suggested ...

    The kindergarten auditory screening test as a predictor of reading disability

    The kindergarten auditory screening test as a predictor of reading disability A Comparison of Three Measures 399 REFERENCES ARTHUR, G. The Arthur Adaptation of the Leiter Ii~ternational ...

    The development of kindergarten behavior rating scales for the prediction of learning and behavior disorders

    The development of kindergarten behavior rating scales for the prediction of learning and behavior disorders THE DEVELOPMENT OF KINDERGARTEN BEHAVIOR RATING SCALES FOR THE PREDICTION OF LEARNING ...

    Havaj Kindergarten-开源

    【Havaj Kindergarten 开源项目详解】 Havaj Kindergarten 是一个开源项目,它的名字寓含了其核心目标——像照顾孩子一样管理各种资源,确保它们的安全与有序。这个项目可能是一个模拟游戏或者教育软件,旨在模拟...

    Apress.NET.Game.Programming.with.DirectX.9.0

    根据提供的信息,《Apress .NET Game Programming with DirectX 9.0》是一本详细介绍如何使用.NET框架结合DirectX 9.0进行游戏开发的专业书籍。本书由Alexandre Santos Lobão和Ellen Hatton合著,ISBN号为...

    kindergarten

    【描述】"kindergarten"在IT领域中的含义可能是指一系列针对编程初学者的基础教程或实践项目,旨在帮助他们理解和掌握JavaScript的基础概念和语法。这个项目可能包括了简单的代码示例、交互式练习以及逐步进阶的编程...

    Effects of length of school day on kindergarten school performance and parent satisfaction

    Effects of length of school day on kindergarten school performance and parent satisfaction Psychologv in the Schools 1982, 19, 238-242 EFFECTS O F LENGTH O F SCHOOL DAY ON KINDERGARTEN SCHOOL ...

    Kindergarten_Backend

    Kindergarten_Backend

Global site tag (gtag.js) - Google Analytics