`
hellobin
  • 浏览: 65459 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 537 - Artificial Intelligence?

    博客分类:
  • UVA
 
阅读更多

 

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on theP-U-Itype problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.

 


Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

 

Input

The first line of the input file will contain the number of test cases.

Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the formI=xA,U=xVorP=xW, wherexis a real number.

Directly before the unit (A,VorW) one of the prefixesm(milli),k(kilo) andM(Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

 

DataField ::= Concept '=' RealNumber [Prefix] Unit
Concept   ::= 'P' | 'U' | 'I'
Prefix    ::= 'm' | 'k' | 'M'
Unit      ::= 'W' | 'V' | 'A'

Additional assertions:

 

  • The equal sign (`=') will never occur in an other context than within a data field.
  • There is no whitespace (tabs,blanks) inside a data field.
  • EitherPandU,PandI, orUandIwill be given.

 

Output

For each test case, print three lines:

 

  • a line saying ``Problem #k" wherekis the number of the test case
  • a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
  • a blank line

 

Sample Input

 

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

 

Sample Output

 

Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V

 

 

花了一段时间debug,后来发现是最后要打印出两行的空行!只打印一行就会WA!

 

 

 

#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 105
string buf;


double getValue(int loc){
	int i;
	string val;
	double c = 1;
	for(i=loc+1; i<buf.length(); i++){
		if(isdigit(buf[i]) || buf[i]=='.' || buf[i]=='-' || buf[i]=='e' ){
			val += buf[i];
		}
		else if(buf[i] == 'm'){
			c = 1e-3;
		}
		else if(buf[i] == 'k'){
			c = 1e3;
		}
		else if(buf[i] == 'M'){
			c = 1e6;
		}
		else{
			break;
		}
	}

	//cout << "val.c_str():" << val.c_str() << endl;
	double ret = atof(val.c_str())*c;
	
	if(ret == 0){
		ret = 0;
	}
	return ret;
}


void play(){
	//cout << buf << endl;

	int loc1 = buf.find("=");
	//cout << loc1 << endl;

	int loc2 = buf.find("=", loc1+1);
	//cout << loc2 << endl;

	bool useU = false, useI = false, useP = false;
	double U = 0, I = 0, P = 0;
	switch (buf[loc1-1])
	{
	case 'U':
		U = getValue(loc1);
		useU = true;
		break;
	case 'I':
		I = getValue(loc1);
		useI = true;
		break;
	case 'P':
		P = getValue(loc1);
		useP = true;
		break;
	}

	switch (buf[loc2-1])
	{
	case 'U':
		U = getValue(loc2);
		useU = true;
		break;
	case 'I':
		I = getValue(loc2);
		useI = true;
		break;
	case 'P':
		P = getValue(loc2);
		useP = true;
		break;
	}

	if(!useU){
		printf("U=%.2lfV\n", (P/I));
	}
	else if(!useI){
		printf("I=%.2lfA\n", (P/U));
	}
	else if(!useP){
		printf("P=%.2lfW\n", (U*I));
	}
}


int main(){

#ifndef ONLINE_JUDGE
	freopen("537.in", "r", stdin);
	freopen("537.out", "w", stdout);
#endif

	int n;

	scanf("%d", &n);
	getchar();
	for(int i=0; i<n; i++){

		getline(cin, buf);
		//cout << buf << endl;
		printf("Problem #%d\n", i+1);
		play();
		p = true;
	}

}


#endif



 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics