`
godfrey90
  • 浏览: 56114 次
  • 性别: Icon_minigender_1
  • 来自: 南京
社区版块
存档分类
最新评论

8th_B

阅读更多
                B. 嘉娃的难题
问题描述
  嘉娃的家庭作业里有很多数列填空练习题。填空练习题的要求是:已知数列的前四
项,填出第五项。因为已经知道这些数列只可能是等差或者等比数列,所以他决定写一
个程序来完成这些练习。
输入格式
  第一行是数列的数目 T (0 ≤ T ≤ 40)。接下来 T 行每行均包含四个整数,表示一个
数列的前四项。数列的前五项均为绝对值不大于 109 的自然数,等比数列的比值也是自
然数。
输出格式
  对输入的每个数列,输出它的前五项,每一行的末尾没有多余空格。
样例输入
2
-1 -2 -3 -4
1 2 4 8
样例输出
-1 -2 -3 -4 -5
1 2 4 8 16
#include<cstdio>

int main(){
	int i,j;
	int n;
	double a[5];
	scanf("%d",&n);
	for(i=0;i<n;i++){
		for(j=0;j<5;j++){
			a[j]=0;
		}
		for(j=0;j<4;j++){
			scanf("%lf",&(a[j]));
		}
		if((a[3]+a[1]==2*a[2])&&(a[2]+a[0]==2*a[1])){
			a[4]=a[3]*2-a[2];
		}else if((a[3]*a[1]==a[2]*a[2])&&(a[2]*a[0]==a[1]*a[1])){
			a[4]=a[3]*a[3]/a[2];
		}
		for(j=0;j<4;j++){
			printf("%d ",(int)a[j]);
		}
		printf("%d\n",(int)a[4]);
	}
	return 0;
}

分享到:
评论

相关推荐

    Fundamentals_of_Differential_Equations_8th_ed.pdf

    根据提供的文件信息,我们可以确定这是一本关于常微分方程基础的书籍,书名为《Fundamentals of Differential Equations 8th edition》,作者是R.Kent Nagle,Edward B. Saff 和 Arthur David Snider。这本书是针对...

    Understanding Automotive Electronics 8th - Appendix B

    首先,标题“Understanding Automotive Electronics 8th - Appendix B”和描述“Understanding Automotive Electronics 8th Appendix B - Discrete Time Systems Theory”指出,汽车电子控制系统和仪表系统,以及...

    WBIR 2018 论文集

    ### WBIR 2018论文集:生物医学图像配准国际研讨会 #### 会议概述 WBIR(Workshop on Biomedical Image Registration)是生物医学图像配准领域的一个重要国际研讨会,旨在为研究者们提供一个交流最新研究成果、探讨...

    (8th Edition) Barry B. Brey-The Intel Microprocessors-Prentice Hall (2008)

    标题《The Intel Microprocessors》第八版由Barry B. Brey编写,这本权威性著作涵盖了Intel微处理器的发展历程,包括8086/8088、80186/80188、80286、80386、80486、Pentium系列以及具有64位扩展的Core2等处理器的...

    Integrated Power Brake (IPB)

    With the introduction of vehicle stability systems like ESP®, and passive safety systems like seat belts and airbags, driving safety has been improved and the number of road traffic ...

    C++ Programming: From Problem Analysis to Program Design, 8th Edition

    Appendix B. Operator Precedence. Appendix C. Character Sets. Appendix D. Operators Overloading. Appendix E. Additional C++ Topics. Appendix F. Header Files. Appendix G. Memory Size On A System And ...

    CISSP All-in-One Exam Guide, 8th Edition.zip

    CISSP All-in-One Exam Guide, Eighth Edition By 作者: Shon Harris – Fernando Maymi ISBN-10 书号: 1260142655 ISBN-13 书号: ...Appendix B About the Online Content Glossary Index 英文原版超清

    Elements of Modern Algebra, 8th Edition Gilbert 2014

    - `A⊆B`:表示集合`A`是集合`B`的子集(第2页)。 - `A⊂B`:表示集合`A`是集合`B`的真子集(第3页)。 - `A∪B`:表示集合`A`和集合`B`的并集(第3页)。 - `A∩B`:表示集合`A`和集合`B`的交集(第3页)。 -...

    -introduction to java programming comprehensive version 8th

    - `Math.pow(a, b)`: 计算a的b次幂。 - `System.currentTimeMillis()`: 获取当前时间(毫秒)。 - `System.out.println(anyValue)`: 输出信息到控制台。 - `JOptionPane.showMessageDialog(null, message)`: 显示...

    HMC.for.pSeries.Installation.and.Operations.Guide_8th.Nov.2003.SA380590

    - **阅读附录B“通知”**:这部分包含重要的安全和法律信息,包括产品保修条款。 - **硬件和软件需求**:确保满足HMC的最低系统要求,包括处理器类型、内存大小和操作系统版本。 - **网络配置**:正确配置网络环境,...

    联想ThinkPad E480 OS11.1 OC引导99%完美黑苹果EFI

    主板 联想 20KNA002CD ( 7th/8th Generation Intel Processor Family I/O - 9D4E 笔记本芯片组 ) 显卡 AMD Radeon RX 550 ( 2 GB / 联想 ) 内存 8 GB ( 记忆科技 DDR4 2666MHz ) 主硬盘 HFM128GDHTNG-8310B ( 128...

    英语质量检测模拟试题(卷).doc

    ",答句中的"On August 8th,2008." 使用了介词On,用于具体的日期前。 3. 频率副词:第三题"How often does your school have sports meetings?"询问的是频率,答案是C. How often,表示“多久一次”。 4. 动词...

    2015七年级英语上册Unit8Whenisyourbirthday单元写作&SectionB3a_3b练习新版人教新目标版

    2. 在 2 月 8 日:on February 8th 3. 在 3 月 11 日:on March 11th 4. 在 4 月 24 日:on April 24th 5. 在 5 月 1 日:on May 1st 6. 在 6 月 18 日:on June 18th 7. 在 7 月 31 日:on July 31st 8. 在 8 月 3 ...

    Prentice Hall.Introduction.to.Java.Programming.Comprehensive.8th.Edition

    - **`Math.pow(a, b)`**:计算a的b次幂。 - **`System.currentTimeMillis()`**:返回当前时间的毫秒数。 - **`System.out.println(anyValue)`**:打印输出。 - **`JOptionPane.showMessageDialog(null, message)`**...

    2020年中考英语总复习专题10介词练习题基础版含解析20200409295

    2. We couldn’t connect Malaysia MH370 _______ Mar8th, 2014. 答案:A. on 解析:在具体日期前使用介词"on",所以正确答案是"on March 8th, 2014"。 3. Please call Xiaoxi ______ 0531-88881234 if you have ...

    Psychology as a first course in science for 8th graders

    Psychology as a first course in science for 8th graders 68 Jerry B. Hutton, Timothy G. Roberts, Jane Walker, and Joe Zuniga DOHRENWEND, B. S., & DOHRENWEND, B. P. (1974). Stressful life events: ...

    PET测试试题.pdf

    15. 完成句子:"Many people will come to Beijing when the 29th Olympic Games _______ in Beijing on August 8th, 2008." 知识点:本题考查的是将来时的被动语态的用法,正确选项应为B.will be held(将在......

    大众FORMEL-Q第八版考试题目.docx

    - **供应商分级**:Formel-Q将供应商分为不同的级别(如A、B、C等),其中A级供应商为最高级别。 - **采购订单关联**:供应商的级别直接影响其获得采购订单的可能性。理论上,所有级别的供应商都有可能获得订单,但...

Global site tag (gtag.js) - Google Analytics