`
itspace
  • 浏览: 978413 次
  • 性别: Icon_minigender_1
  • 来自: 杭州
社区版块
存档分类
最新评论

AIX 查看aio状态

阅读更多
Aix平台打开异步io需要fileset支持
引用
# lslpp -l bos.rte.aio
  Fileset                      Level  State      Description        
  ----------------------------------------------------------------------------
Path: /usr/lib/objrepos
  bos.rte.aio               5.3.0.60  COMMITTED  Asynchronous I/O Extension

Path: /etc/objrepos
  bos.rte.aio               5.3.0.60  COMMITTED  Asynchronous I/O Extension


查看异步io是否已经打开,available表示已经开启
引用
# lsattr -El aio0
autoconfig available STATE to be configured at system restart True
fastpath   enable    State of fast path                       True
kprocprio  39        Server PRIORITY                          True
maxreqs    4096      Maximum number of REQUESTS               True
maxservers 10        MAXIMUM number of servers per cpu        True
minservers 1         MINIMUM number of servers                True


引用
# aioo -a
               minservers = 1
               maxservers = 10
                  maxreqs = 4096
               fsfastpath = 0



当然也可以通过以下命令启用aio
引用
# chdev -P -l aio0 -a autoconfig='available'
aio0 changed

修改maxreqs时报如下错误
引用
# chdev -l aio0 -a maxreqs=16384
Method error (/usr/lib/methods/chgaio):
        0514-064 Cannot perform the requested function because the
                 AIO kernel extension is permanent and cannot be unloaded.

解决办法如下
引用
#  chdev -l aio0 -P  -a maxreqs=16384
aio0 changed

可以仔细了解一下-P参数的作用
引用
-P
Changes the device's characteristics permanently in the Customized Devices object class without actually changing the device.This is useful for devices that cannot be made unavailable and cannot be changed while in the available state. The change ismade to the database, and the changes are applied to the device when the system is rebooted. This flag cannot be used withthe -T flag. Not all devices support the -P flag.


查看aio进程数
引用
# pstat -a | grep aio
20 a    1478      1   1478     0     0     1  posix_aioserver 
21 a    1540      1   1540     0     0     1  aioserver 
48 a    30c4      1   30c4     0     0     1  aioserver 
50 a    3250      1   3250     0     0     1  aioserver 
68 a    44be      1   44be     0     0     1  aioserver 
75 a    4baa      1   4baa     0     0     1  aioserver 
76 a    4ca6      1   4ca6     0     0     1  aioserver 
80 a    50b6      1   50b6     0     0     1  aioserver 
89 a    59bc      1   59bc     0     0     1  aioserver 
125 a    7d28      1   7d28     0     0     1  aioserver 
127 a    7f0c      1   7f0c     0     0     1  aioserver 


查看目前系统异步io是否遇到瓶颈
引用
# iostat -A 1 1

System configuration: lcpu=1 drives=3 paths=0 vdisks=0

aio: avgc avfc maxg maif maxr avg-cpu: % user % sys % idle % iowait
        0    0   33    0 4096             0.4   0.8   98.8      0.0

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn
hdisk1           0.0       0.0       0.0          0         0
hdisk0           0.0       0.0       0.0          0         0
cd0              0.0       0.0       0.0          0         0


下面的列表描述了用于监视 AIO 子系统的一些参数。

    * avfc:这个参数用于报告在指定的时间间隔内每秒的平均快速路径请求计数。
    * avgc:这个参数用于报告在指定的时间间隔内每秒的平均全局异步 I/O 请求。
    * maxgc:这个参数用于报告从上一次获取这个值以来最大的全局异步 I/O 请求。
    * maxfc:这个参数用于报告从上一次获取这个值以来快速路径请求计数的最大值。
    * maxreqs:这个参数是允许的、异步 I/O 请求的最大值。

在我们的示例中,AIO 服务器不是系统瓶颈。
需要注意的是在AIX 6L中异步io会自动开启,maxreqsminservers、maxservers也会根据应用而自动调整,无须人工干预,当然也没有smitty aio这条命令了,呵呵

附:metalink的说明
Solution

AIX 5L supports asynchronous I/O (AIO) for database files created both on file system partitions and on raw devices.

AIO on raw devices is implemented fully into the AIX kernel, and does not require database processes to service the AIO requests.

When using AIO on file systems, the kernel database processes (aioserver) control each request from the time a request is taken off the queue to the time it is completed. The number of aioserver servers determines the number of AIO requests that can be processed in the system concurrently. So, it is important to tune the number of aioserver processes when using file systems to store Oracle Database data files.

Use one of the following commands to set the number of servers. This applies only when using
asynchronous I/O on file systems rather than raw devices:

smit aio

chdev -l aio0 -a maxservers=' m ' -a minservers='n'

Set the minimum value to the number of servers to be started when the system is started. Set the maximum value to the number of servers that can be started in response to a large number of concurrent requests. These parameters apply to file systems only. They do not apply to raw devices.

The default value for the minimum number of servers is 1. The default value for the maximum number of servers is 10. These values are usually too low to run Oracle Database on large systems with 4 CPUs or more, if you are not using kernelized AIO. Oracle recommends that you set the parameters to the values listed in the following table.

Parameter Values
=============


minservers

Oracle recommends an initial value equal to the number of CPUs on the system or 10, whichever is lower.


maxservers

Starting with AIX 5L version 5.2, this parameter counts the maximum number of AIO servers per CPU. On previous versions of AIX, it was a systemwide value. If you are using GPFS, then set maxservers to worker1threads divided by the number of CPUs. This is the optimal setting.
Increasing maxservers does not lead to improved I/O performance. If you are using JFS/JFS2, then set the initial value to 10 times the number of logical disks divided by the number of CPUs.


Monitor the actual number of aioservers started during a typical workload using the pstat or ps commands. If the actual number of active aioservers is equal to the maxservers, then increase the maxservers value.


maxreqs

Set the initial value to 4 times the number of logical disks multiplied by the queue depth. You can determine the queue depth by running the following command:
$ lsattr -E -l hdiskxx

Typically, the queue depth is 3.

If the value of the maxservers or maxreqs parameter is set too low, then the following warning messages are repeatedly displayed:

"Warning: lio_listio returned EAGAIN
Performance degradation may be seen."

You can avoid these errors by increasing the value of the maxservers parameter. To display the number of AIO servers running, enter the following commands as the root user:

# pstat -a | grep -c aios
# ps -k | grep aioserver

Check the number of active AIO servers periodically, and change the values of the minservers and maxservers parameters if required. The changes take place when the system is restarted.

0
0
分享到:
评论

相关推荐

    AIX系统操作员手册.pdf

    AIX系统管理员需要了解系统的运行状态,监控系统的性能,记录系统的日志,备份重要数据,恢复系统等。 AIX版本号代表什么意思 AIX版本号是指AIX系统的版本号,它由一个数字串组成,例如AIX 5L、AIX 6.1等。AIX版本...

    AIX系统维护大全

    3. **AIX常用命令**:包括`df`(查看文件系统空间)、`errpt`(检查错误日志)、`last`(检查登录记录)、`find`(搜索文件)、`mail`(检查邮件)、`diag`(诊断硬件状态)等,这些都是日常管理中不可或缺的工具。...

    AIX 系统维护下载

    - AIX的异步I/O(aio)可提高系统处理大量I/O请求时的性能。 15. **Paging Space管理**: - 通过`lsps -a`查看页面空间状态,必要时添加或调整大小。 16. **在线手册安装**: - 在AIX 4.3中,使用`man`命令的...

    克隆AIX操作系统

    - AIO是AIX中的一项功能,它允许自动创建和管理系统映像对象。启用AIO后,可以在安装新系统时自动加载所需的软件包,从而简化安装过程。 - 启用AIO通常需要通过`smit chaio`命令进行配置。需要注意的是,AIO启用后...

    AIX系统操作员手册

    #### 异步I/O(aio)提升性能 AIX的异步I/O功能允许数据读写操作在后台执行,从而显著提升系统响应速度和整体性能。 #### PagingSpace管理 通过`chps`, `lsps`, `mkps`等命令管理分页空间,确保内存和虚拟内存之间...

    AIX主机挂接EMC CLARiiON磁盘阵列

    Page Space是AIX中的虚拟内存管理机制,`lsps -a`用于查看Page Space的大小。通常推荐Page Space大小为物理内存的2倍,但根据实际需求,可以设置为4GB。 9. **OS参数检查**: 使用`smitty aio`来改变异步I/O的...

    IBM AIX系统管理

    除了上述命令,还有诸如**lslpp**(列出已安装的产品)、**lppchk**(检查产品状态)、**lsvg**(显示卷组信息)等,都是AIX系统管理中不可或缺的工具。 #### 三、逻辑卷管理与系统参数检查 **2.1 逻辑卷管理** ...

    aix 5.3 安装oracle

    4. **Asynchronous Input Output (AIO)**:确保AIO可用,通过`#lsdev -Cc aio`命令检查状态,若状态为“Defined”,需通过smit进行配置。 ### 安装过程中的注意事项 在准备阶段完成之后,开始安装Oracle数据库。...

    在AIX上快速部署Oracle 9i

    通过`lsdev -Cc aio`命令检查,如果状态不是“Available”,使用`smit chaio`配置使其在重启后可用。 4. 检查并安装math library(bos.adt.libm)文件集,如果尚未安装,使用`smit install_latest`进行安装。此外,...

    AIX系统维护命令大全

    - 工具如`topas`用于实时查看系统状态,`iostat`监测I/O性能,`vmstat`分析CPU和内存使用,`lsps -a`查看交换空间。 4. 系统备份与恢复: - AIX提供多种备份策略,包括使用IBM Tivoli Storage Manager等工具进行...

    Websphere7.0 for AIX部署手册

    - **aio_maxreqs**:异步I/O的最大请求数应设置为65536或以上,可以通过`ioo -o aio_maxreqs`命令检查。 3. **用户和目录准备**: - 使用root用户创建独立的/was文件系统挂载点,并创建一个名为was的新用户,分配...

    pdf格式-AIX维护大全

    - **使用异步I/O(aio)提高性能**: aio允许在等待I/O操作的同时执行其他任务,从而提高整体系统性能。 - **管理PagingSpace**: 通过`chps`和`mkps`等命令来创建、调整和管理交换空间。 - **设置中文环境**: 通过修改...

    Oracle 11.2.0.4rac on AIX 实战安装指南

    同时,还需要确认磁盘属性是否已经正确设置,通过命令`lsattr -E l hdiskn`查看每个磁盘的状态。 ##### 2.3 清除PVID 在AIX系统中,物理卷标识(PVID)是存储设备的重要属性之一。在进行Oracle RAC安装前,需要确保...

    AIX双机配置

    6. 网络配置:网络的配置包括网卡速率、通讯方式、AIO配置、系统参数fullcore的设置,以及IP地址的检查和配置。网络配置确保双机系统之间能够顺畅通信,并在故障时实现快速切换。 7. Cluster配置:Cluster配置是指...

Global site tag (gtag.js) - Google Analytics