本次列出使用PCC负载均衡实例
网上看到过教程,感觉脚本来的快点,下面就是PCC4个ADSL的负载均衡的脚本:
/ip firewall address-list
add address=192.168.88.0/24 disabled=no list=local
/ip firewall mangle
add action=mark-connection chain=input disabled=no in-interface=pppoe-out1 \
new-connection-mark=pppoe-out1 passthrough=yes
add action=mark-connection chain=input disabled=no in-interface=pppoe-out2 \
new-connection-mark=pppoe-out2 passthrough=yes
add action=mark-connection chain=input disabled=no in-interface=pppoe-out3 \
new-connection-mark=pppoe-out3 passthrough=yes
add action=mark-connection chain=input disabled=no in-interface=pppoe-out4 \
new-connection-mark=pppoe-out4 passthrough=yes
add action=mark-routing chain=output connection-mark=pppoe-out1 disabled=no \
new-routing-mark=to_pppoe-out1 passthrough=yes
add action=mark-routing chain=output connection-mark=pppoe-out2 disabled=no \
new-routing-mark=to_pppoe-out2 passthrough=yes
add action=mark-routing chain=output connection-mark=pppoe-out3 disabled=no \
new-routing-mark=to_pppoe-out3 passthrough=yes
add action=mark-routing chain=output connection-mark=pppoe-out4 disabled=no \
new-routing-mark=to_pppoe-out4 passthrough=yes
add action=mark-connection chain=prerouting disabled=no dst-address-list=\
!local dst-address-type=!local new-connection-mark=pppoe-out1 \
passthrough=yes per-connection-classifier=both-addresses:4/0 \
src-address-list=local
add action=mark-connection chain=prerouting disabled=no dst-address-list=\
!local dst-address-type=!local new-connection-mark=pppoe-out2 \
passthrough=yes per-connection-classifier=both-addresses:4/1 \
src-address-list=local
add action=mark-connection chain=prerouting disabled=no dst-address-list=\
!local dst-address-type=!local new-connection-mark=pppoe-out3 \
passthrough=yes per-connection-classifier=both-addresses:4/2\
src-address-list=local
add action=mark-connection chain=prerouting disabled=no dst-address-list=\
!local dst-address-type=!local new-connection-mark=pppoe-out4 \
passthrough=yes per-connection-classifier=both-addresses:4/3 \
src-address-list=local
add action=mark-routing chain=prerouting connection-mark=pppoe-out1 disabled=\
no new-routing-mark=to_pppoe-out1 passthrough=no src-address-list=local
add action=mark-routing chain=prerouting connection-mark=pppoe-out2 disabled=\
no new-routing-mark=to_pppoe-out2 passthrough=no src-address-list=local
add action=mark-routing chain=prerouting connection-mark=pppoe-out3 disabled=\
no new-routing-mark=to_pppoe-out3 passthrough=no src-address-list=local
add action=mark-routing chain=prerouting connection-mark=pppoe-out4 disabled=\
no new-routing-mark=to_pppoe-out4 passthrough=no src-address-list=local
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
pppoe-out1 routing-mark=to_pppoe-out1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
pppoe-out2 routing-mark=to_pppoe-out2 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
pppoe-out3 routing-mark=to_pppoe-out3 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
pppoe-out4 routing-mark=to_pppoe-out4 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
pppoe-out1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
pppoe-out2 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
pppoe-out3 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
pppoe-out4 scope=30 target-scope=10
进入winbox ->NewTerminal ,在控制台paste以上脚本即可。
如果是固定4个IP的,可以将pppoe-out(1-4)改成ethernet(1-4),如果只有2个ADSL(或固定IP),代码中的
add action=mark-connection chain=prerouting disabled=no dst-address-list=\
!local dst-address-type=!local new-connection-mark=pppoe-out1 \
passthrough=yes per-connection-classifier=both-addresses:4/0 \
src-address-list=local
add action=mark-connection chain=prerouting disabled=no dst-address-list=\
!local dst-address-type=!local new-connection-mark=pppoe-out2 \
passthrough=yes per-connection-classifier=both-addresses:4/1 \
src-address-list=local
add action=mark-connection chain=prerouting disabled=no dst-address-list=\
!local dst-address-type=!local new-connection-mark=pppoe-out3 \
passthrough=yes per-connection-classifier=both-addresses:4/2\
src-address-list=local
add action=mark-connection chain=prerouting disabled=no dst-address-list=\
!local dst-address-type=!local new-connection-mark=pppoe-out4 \
passthrough=yes per-connection-classifier=both-addresses:4/3 \
src-address-list=local
要改成
add action=mark-connection chain=prerouting disabled=no dst-address-list=\
!local dst-address-type=!local new-connection-mark=pppoe-out1 \
passthrough=yes per-connection-classifier=both-addresses:2/0 \
src-address-list=local
add action=mark-connection chain=prerouting disabled=no dst-address-list=\
!local dst-address-type=!local new-connection-mark=pppoe-out2 \
passthrough=yes per-connection-classifier=both-addresses:2/1 \
src-address-list=local 。
出自 华翔博客 :http://www.looksky.net/?p=157
相关推荐
在“ROS 多拨负载均衡PCC全自动优化版”中,我们主要探讨的是如何利用ROS实现多条ISP(Internet Service Provider)线路的负载均衡,以及PCC(Priority Congestion Control)策略的自动化优化。这种技术对于提高网络...
总结来说,这个ROS_PCC负载均衡案例展示了如何利用ROS的强大功能,通过VLAN、PPPoE拨号和PCC负载均衡技术,有效地管理和优化多条AD线路的带宽资源,同时提供稳定且高效的家庭宽带服务。这一方案不仅降低了成本,还...
本文将详细介绍如何在ROS 3.30版本中通过PCC(Policy Based Routing,基于策略的路由)实现多条ADSL线路的负载均衡,并在此基础上完成特定端口的映射。 #### 端口映射的意义 端口映射是一种网络配置技术,通过...
在IT行业中,网络技术是至关重要的领域,而Ros双ADSL和NTH负载均衡的配置则是网络优化和高可用性方案中的一个实例。Ros(RouterOS)是由MicroTik公司开发的一款路由器操作系统,它提供了丰富的命令行接口(CLI)和图形...
"ros多线路叠加策略pcc超详细教程 图文" 该教程主要讲解了ROS(RouterOS)中PCC(Policy-Based Connection Classification)策略的实现,该策略可以实现负载均衡和路由选择。 首先,需要配置IP地址和DNS缓存功能,...
通过这种方式,我们可以确保网银流量始终通过特定的线路,从而解决在多线负载均衡下网银打不开的问题。同时,这也提醒我们在进行网络配置时,要考虑到不同应用和服务的特殊需求,避免一刀切的负载均衡策略影响到关键...
### RouterOS_ROS 通过交换机VLAN多线拨号并PCC负载均衡 #### 核心知识点概览 本文档旨在详细介绍如何利用RouterOS (ROS) 与H3C S1526交换机结合VLAN技术进行多线ADSL拨号接入,并在此基础上实现负载均衡的过程。...
### ROS软路由使用Nth实现负载均衡 #### 一、概述 ROS(RouterOS)是MikroTik公司开发的一款路由器操作...通过上述步骤,可以在ROS软路由上成功实现Nth负载均衡配置,有效利用多条ISP线路资源,提高网络整体性能。
ROS3.22 ADSL 5线NTH负载均衡与自动限速系统是网络管理中的一个重要环节,尤其在多线路接入环境中,它能够优化网络性能并确保服务的稳定性。在这个主题下,我们将深入探讨以下几个核心知识点: 1. **ROS(RouterOS)*...
ROS3.30 ADSL双线PCC及NTH负载均衡教程主要涵盖了如何在路由器操作系统(RouterOS)的3.30版本上实现ADSL双线路的带宽控制(PCC,即Priority and Control Channels)以及网络健康检查(NTH,Network Traffic Health...
总的来说,ROS4.0 实现同网关 PPPoE 负载均衡的目的是提高网络的带宽利用率和可靠性,通过多条线路分担流量,避免单点故障,同时优化网络性能。这种配置方法在小型办公室或家庭环境中尤其有用,可以最大化有限的网络...
PCC(Policy-Based Routing)是 ROS 中的一种负载均衡技术,它可以根据不同的流量策略将流量分配到不同的 WAN 口上,从而提高网络的可靠性和性能。在这个教程中,我们将使用 PCC 来实现多线路叠加策略。 二、网络...
1. **多线路负载均衡**:配置ROS进行多线路负载均衡,根据不同的源地址(如电信或网通)分配不同的线路。这可以通过设置路由表中的不同优先级和下一跳IP来实现。 2. **端口映射规则**:在ROS的NAT规则中,设定针对...
RouterOS 40条ADSL线路PCC负载均衡的案例
ros软路由中的负载均衡(PCC),自己写的,可直接粘贴复制到路由器中,实现多线路外网负载均衡
3. 配置负载均衡:ROS支持多种负载均衡策略,如轮询、最小连接数、带宽权重等。你可以根据实际需求选择合适的策略,确保流量均匀地分配到各个ADSL线路,或者优先使用空闲带宽更多的线路。 4. 设置路由规则:为了使...
在多线拔号场景中,ROS配合VLAN(虚拟局域网)技术可以实现更高效的网络连接和负载均衡。 在“ROS+VLAN25条ADSL 多线拔号”这个主题中,主要涉及以下几个关键知识点: 1. **ROS操作系统的应用**:ROS不仅用于基础...
在ROS系统中,实现双线负载均衡和故障切换是通过其内置的策略路由功能来完成的。首先,你需要了解如何配置两个不同的ISP(Internet Service Provider)连接,分别对应网通和电信线路。这通常涉及设置物理接口,如eth...
在路由器操作系统(RouterOS,简称ROS)5.x版本中,通过双线路(PPPoE拨号)的叠加和负载均衡,我们可以实现互联网连接的冗余和性能提升。以下是对这一主题的详细阐述: 首先,PPPoE(Point-to-Point Protocol over...