Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.
Input Specification:
Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:
For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.
Sample Input:
1234567899
Sample Output:
Yes
2469135798
#include<stdio.h>
#include<string.h>
char s[22];
char s2[22];
int a[10];
int main()
{
scanf("%s\n", s);
int i;
int j =0;
int temp = 0;
int carry = 0;
for(i = strlen(s)-1;i >= 0; i--){
temp = s[i] - '0';
a[temp]++;
temp = temp*2 + carry;
s2[i] = temp%10 + '0';
a[temp%10]--;
carry = temp/10;
}
if(carry != 0 ) a[carry]--;
int flag = 0;
for(i = 0; i< 10; i++){
if(a[i] != 0){
flag = 1;
break;
}
}
if(flag) printf("No\n");
else printf("Yes\n");
if(carry != 0 ) printf("%d",carry);
for(i = 0 ; i < strlen(s2); i++){
printf("%c",s2[i]);
}
printf("\n");
return 0;
}
分享到:
相关推荐
CAD填充图案(三百多种)-.pat文件 部分如下(篇幅有限) 2x12木地板.pat 45度人字形砖面(1).pat 8x8无缝砖.pat Z形砖.pat 丁字砖面1.pat 丁字砖面2.pat 三联蜂窝.pat 三角形拼铺.pat 不能通行的沼泽地.pat 乱沙.pat...
pat1.cpp
标题“pat1.rar_in”可能指的是一个包含图像处理补丁的压缩文件,而“in”标签可能是对内容的简要分类或关键词。压缩文件中的唯一子文件“pat1.m”很可能是一个MATLAB脚本,因为.m文件是MATLAB的源代码文件格式。...
Neural Networks and Deep Learni - Pat Nakamoto.azw3
dcu2pat.exe I:\delphi.trash\2007\lib\*.dcu wc -l .pat 26959 .pat \ida\flair\bin\sigmake.exe .pat d2007.sig : modules/leaves: 11149849/26655, COLLISIONS: 19389 After resolving of collisions (see ...
算法与数据结构它们分别涵盖了以下主要内容: 数据结构(Data Structures): 逻辑结构:描述数据元素之间的逻辑关系,如线性结构(如数组、链表)、树形结构(如二叉树、堆、B树)、图结构(有向图、无向图等)...
1009. 说反话 (20) 给定一句英语,要求你编写程序,将句中所有单词的顺序颠倒输出。 输入格式:测试输入包含一个测试用例,在一行内给出总长度不超过80的字符串。字符串由若干单词和若干空格组成,其中单词是由...
Paragon Alignment Tool_PAT.3.0.13045 内置激活码、中文版使用说明(PDF文档,工具安装后是英文界面,可参照中文版使用说明); 工具可用于SSD固态硬盘、机械硬盘、U盘、SD卡/TF卡等移动存储设备4K对齐,支持无损...
是由新加坡国立大学开发的一款形式化建模与验证工具集,支持进程代数、实时进程代数、时间自动机等多种建模语言...PAT工具的人机交互界面友好,支持多种验证方法,包括精化验证、死锁验证、可达性验证、LTL性质验证等。
【PAT答案_1001至1049】是一个包含多份编程题解的压缩包,主要针对PAT(Pacific Asia Test for Informatics and Computer Science)考试中的题目。PAT是面向亚太地区计算机科学与信息技术学生的专业认证考试,旨在检验...
标题中的“acwing, leetcode, kickstart, 算法模板, PAT 等等.zip”表明这是一个包含多个算法训练平台资源的压缩文件。这些平台都是程序员提升算法能力、准备编程竞赛的重要工具。让我们逐一深入探讨它们以及可能...
把acadiso.pat放到c:\Documents and Settings\当前用户名\Application Data\Autodesk\AUTOCAD 2009\R17.2\CHS\SUPPORT 文件下 适合各中版本的CAD
黑群晖最经典的版本 DSM_DS918+_24922.pat
适合在打基础的同学可以比较深入提前了解比较真实的做题情况,减少焦虑(无解压密码,解压后获得TXT文件)
根据给定的信息,本文将详细解释TS(Transport Stream)包解析中的关键概念,包括TS头、PAT(Program Association Table)、PMT(Program Map Table)以及PES(Packetized Elementary Stream)。这些是MPEG-2传输流...
### 配置PAT知识点详解 #### 一、PAT(Port Address Translation)概念解析 PAT(端口地址转换),是NAT(Network Address Translation)的一种特殊形式,主要用于将一个内部网络中的多个私有IP地址映射到一个或...
patb工程文件的说明文档,对patb工程文件的说明。adj、image、ori、cont。
标题 "patb.rar_enjoy3b8_newton_newton-raphson_数学计算_非线性有限元" 涉及的主题是使用Newton-Raphson方法解决一维非线性问题,具体应用在有限元分析中。Newton-Raphson方法是一种强大的数值迭代技术,常用于...
《MIS管理系统使用详解——以PAT项目客户管理为例》 MIS(Management Information System,管理信息系统)是现代企业信息化管理的重要工具,它整合了数据处理、业务流程与决策支持等功能,为企业提供高效的信息服务...
dcu2pat.exe I:\delphi.trash\2007\lib\*.dcu wc -l .pat 26959 .pat \ida\flair\bin\sigmake.exe .pat d2007.sig : modules/leaves: 11149849/26655, COLLISIONS: 19389 After resolving of collisions (see ...