`

湖南师范大学OJ-10021

    博客分类:
  • ACM
J# 
阅读更多
Lowest Bit 
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB 
Total submit users: 22, Accepted users: 22 
Problem 10021 : No special judgement 
Problem description
  Given an positive integer A (1 <= A <= 10^9), output the lowest bit of A.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.



Input
  Each line of input contains only an integer A (1 <= A <= 109). A line containing "0" indicates the end of input, and this line is not a part of the input data.


Output
  For each A in the input, output a line containing only its lowest bit.


Sample Input
26
8
0

Sample Output
2
8



import java.util.Scanner;


public class Acm10021 {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		Integer a = cin.nextInt();
		String binaryNum = null;
		String suffixNum = null;
		int result;
		while(a != 0){
			result = 0;
			binaryNum = new String();
			binaryNum = Integer.toBinaryString(a);
			suffixNum = new String();
			suffixNum = binaryNum.substring(binaryNum.lastIndexOf("1"), binaryNum.length());
			int j=0;
			for(int i=suffixNum.length(); i>0; i--){
				result += Integer.parseInt(suffixNum.substring(i-1, i))*Math.pow(2, j);
				j++;
			}
			System.out.println(result);
			a = cin.nextInt();
		}
	}
}

分享到:
评论

相关推荐

    HUNNU湖南师大oj部分题目代码

    【标题】"HUNNU湖南师大oj部分题目代码"涉及的是在线判题系统(Online Judge,简称OJ)中的编程题目解决方案,这些代码由2016级湖南师范大学的学生编写。在线判题系统是计算机科学教育中常用的一种工具,用于测试和...

    在线OJ网址大全在线OJ网址大全

    15. **杭州师范大学**() - **特点**:题库适合入门,便于新手练习。 - **适用人群**:适合编程初学者。 16. **华东师范大学**() - **特点**:题库质量高,难度适中。 - **适用人群**:适合中等水平的学习者...

    ACM网站大全(OJ+代码+贴吧)

    - 福建师范大学的在线评测系统。 - **华中科技大学 (HUST)**:`http://acm.hust.edu.cn/JudgeOnline/` - 华中科技大学的在线评测系统。 - **华东师范大学 (ECNU)**:`http://acm.cs.ecnu.edu.cn/` - 华东师范大学...

    OJ 网址汇总

    杭州电子科技大学(HDU)、浙江大学(ZJU)、北京大学(PKU)、同济大学...湖南大学(HNU)、香港大学(hkoi)、天津大学(TJU)、四川大学(SCU)、汕头大学(STU)、福州大学(FZU)、厦门大学(XMU)、福建师范大学...

    学习C语言的好网站和在线裁判系统 一些网站

    - 华东师范大学(ECNU):http://acm.cs.ecnu.edu.cn/ - 浙江工业大学(ZJUT):http://acm.zjut.edu.cn/ - 浙江师范大学(ZJNU):http://acm.zjnu.cn/ - VIJOS(虚拟信息竞赛系统):http://www.vijos.cn/ - *...

Global site tag (gtag.js) - Google Analytics