$sudo launchctl load /Library/LaunchDaemons/org.mongodb.mongod.plist
curl -O http://downloads.mongodb.org/osx/mongodb-osx-x86_64-1.4.0.tgz
tar xzf mongodb-osx-x86_64-1.4.0.tgz
sudo mv mongodb-osx-x86_64-1.4.0 /usr/local/mongodb
sudo mkdir /usr/local/mongodb_data /var/log/mongodb
sudo chown -R root /usr/local/mongodb
#Save as: /usr/local/mongodb/mongod.conf
# Store data alongside MongoDB instead of the default, /data/db/
dbpath = /usr/local/mongodb_data
# Only accept local connections
bind_ip = 127.0.0.1
Now, we’ll make a launchd job to register the server as an OS X daemon. launchd will start the server at startup, stop it before shutdown, make sure it stays up, and redirect its output to a nice log file.
#Save as: /Library/LaunchDaemons/org.mongodb.mongod.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN"
"http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>org.mongodb.mongod</string>
<key>ProgramArguments</key>
<array>
<string>/usr/local/mongodb/bin/mongod</string>
<string>run</string>
<string>--config</string>
<string>/usr/local/mongodb/mongod.conf</string>
</array>
<key>RunAtLoad</key>
<true/>
<key>KeepAlive</key>
<true/>
<key>WorkingDirectory</key>
<string>/usr/local/mongodb</string>
<key>StandardErrorPath</key>
<string>/var/log/mongodb/output.log</string>
<key>StandardOutPath</key>
<string>/var/log/mongodb/output.log</string>
</dict>
</plist>
Now we just need to load the launchd job:
sudo launchctl load /Library/LaunchDaemons/org.mongodb.mongod.plist
And that should do it! Try visiting http://localhost:28017 to see the status console for your database.
One last thing: you should probably add /usr/local/mongodb/bin to your $PATH. That way you can use the other binaries that ship with MongoDB, like the mongo console, mongoexport, and so on.
You can adjust your path the regular way by editing your shell’s profile, or you can use this nice paths.d mechanism that OS X provides:
sudo sh -c 'echo "/usr/local/mongodb/bin" > /etc/paths.d/mongodb'
Thanks to theozaurus in the comments below for that tip.
分享到:
相关推荐
**五、设置开机启动** 为了方便,你可以设置MongoDB在每次启动Mac时自动运行。这通常通过创建一个启动代理(Launch Agent)配置文件实现,例如`~/Library/LaunchAgents/com.mongodb.server.plist`。具体内容应包含...
在Mac环境下安装MongoDB,我们通常会使用Homebrew这个包管理器。首先,确保你的系统已经安装了Homebrew。如果没有,可以通过在终端输入以下命令来安装: ```bash /bin/bash -c "$(curl -fsSL ...
6. **设置开机启动**:为了每次重启 Mac 后自动启动 MongoDB,可以使用以下命令: ``` brew services start mongodb-community@4.0 ``` 压缩包中的文件 "mongodb-osx-x86_64-4.0.4" 是 MongoDB 的二进制发行版,...
### MongoDB在Linux上的安装与基本操作详解 #### 一、MongoDB在Linux上的安装 **1. 使用包管理工具或手动下载安装MongoDB** 在大多数Linux发行版上,您可以通过包管理工具轻松安装MongoDB。这里我们将分别介绍...
- 配置启动服务:设置MongoDB服务自动启动,以便开机时自动运行。 3. **启动与停止MongoDB服务**: - 启动:通过命令行启动MongoDB服务。 - 停止:同样通过命令行关闭MongoDB服务。 4. **基本操作**: - 连接...