`
Simone_chou
  • 浏览: 192815 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Alice and Bob(贪心 + multiset)

    博客分类:
  • HDOJ
 
阅读更多

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2571    Accepted Submission(s): 828


Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 

 

Input
The first line of the input is a number T (T <= 40) which means the number of test cases.
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.
 

 

Output
For each test case, output an answer using one line which contains just one number.
 

 

Sample Input
2
2
1 2
3 4
2 3
4 5
3
2 3
5 7
6 8
4 1
2 5
3 4
 

 

Sample Output

 

1
2

       题意:

       首先给出样例个数 T(1 ~ 50),每个样例给出 N (<= 100000)张牌,代表 Alice 和 Bob 各有 N 张牌,每张牌都有长(1 ~ 10 ^ 9)和宽(1 ~ 10 ^ 9),现要用 Alice 的牌去覆盖 Bob 的,必须长和宽都大于等于才能覆盖,问能够覆盖的最大数。

 

       思路:

       贪心 + multiset。与昨天的多校贪心题类似,先对牌统一按长由大到小排序,后用 Bob 的牌去匹配 Alice 的牌,选出 Alice 牌中长大于 Bob 长的牌,将宽放入 multiset 中,在从中选出在里面的牌中大于或者等于 Bob 牌的宽的第一个数,运用 upper_bound,之后从 multiset 中删去这张牌即可。用 multiset 的原因是可能宽度会有重复的。寻找的时候统计个数就好了。

       lower_bound 返回的是第一个大于或者等于 num的数,若全部都小于则返回 end;

       upper_bound 返回的是第一个大于 num 的数,若全部都小于则返回 end。

 

       AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>

using namespace std;

const int MAX = 100005;

typedef struct {
        int l, w;
} node;

node a[MAX], b[MAX];

bool cmp (node a, node b) {
        if (a.l != b.l) return a.l > b.l;
        return a.w > b.w;
}

int main() {
        int t;
        scanf("%d", &t);

        while (t--) {
                int n;
                scanf("%d", &n);

                for (int i = 0; i < n; ++i) {
                        scanf("%d%d", &a[i].l, &a[i].w);
                }

                for (int i = 0; i < n; ++i) {
                        scanf("%d%d", &b[i].l, &b[i].w);
                }

                sort(a, a + n, cmp);
                sort(b, b + n, cmp);

                int m = 0, ans = 0;
                multiset<int> s;
                for (int i = 0; i < n; ++i) {
                        while (m != n && a[m].l >= b[i].l) {
                                s.insert(a[m].w);
                                ++m;
                        }

                        multiset<int>::iterator it;
                        it = s.lower_bound(b[i].w);

                        if (it != s.end() && *it >= b[i].w) {
                                ++ans;
                                s.erase(it);
                        }
                }

                printf("%d\n", ans);
        }
}

 

 

 

 

分享到:
评论

相关推荐

    Almeza_MultiSet_6+_Fix_Update

    《Almeza MultiSet 6+ 修复更新详解:打造全自动软件安装体验》 在现代计算机使用中,软件安装往往是一项耗时且繁琐的工作。尤其是当需要安装大量软件时,手动逐一操作无疑会浪费大量的时间和精力。为此,专门用于...

    STL容器multiset的使用

    在这个话题中,我们将深入探讨STL容器中的`multiset`,并结合VC6.0环境下的代码示例进行讲解。 **一、STL multiset简介** `multiset`是STL中的一种关联容器,它类似于`set`,但允许插入重复元素。`multiset`内部...

    oracle cast (multiset()as )用法

    通过实例介绍了 cast(multiset() as) 的使用方法,以处理嵌套表的操作

    Set:Swift中Multiset和PredicateSet的实现

    Multiset ( 1 , 2 , 3 ) + Multiset ( 3 , 4 , 5 ) // == Multiset(1, 2, 3, 3, 4, 5) // Difference Multiset ( 1 , 2 , 3 ) - Multiset ( 2 , 3 ) // == Multiset(1) // Intersection Multiset ( 1 , 2 , 3 ) & ...

    懒人工具 Almeza MultiSet,软件全自动安装器Pro6.2.0.795(绿色中文)特别版

    Almeza MultiSet是一款强大的软件全自动安装器,它专为那些希望简化软件部署和管理的“懒人”设计。这款工具能够帮助用户自动化地安装、配置和管理多种应用程序,极大地节省了手动安装软件的时间和精力。Pro6.2.0....

    Python库 | multiset_multicover-0.4-cp37-cp37m-win_amd64.whl

    可能包括贪心算法、动态规划或更复杂的组合优化算法,这些算法可以处理大规模数据,找出最优解或近似最优解。使用这样的库,开发者可以避免从头实现这些复杂算法,从而节省时间和提高代码质量。 `cp37`和`cp37m`是...

    almeza multiset pro v8.7.6中文注册版.rar

    安装说明:安装后先不要立即运行Almeza MultiSet,将内附的“activate_multiset.amltkey”文件复制到C:\Program Files\Almeza\MultiSet目录下面即是正式版。点击菜单View--&gt;Language--&gt;在General中选择...

    Almeza MultiSet -Windows自动安装软件的工具

    《Almeza MultiSet——Windows自动安装软件利器详解》 在Windows操作系统中,软件的安装过程通常需要用户手动执行一系列步骤,这对于批量部署或者需要快速安装多款软件的场景而言,无疑增加了工作负担。为此,专业...

    Almeza MultiSet Pro 7.8.1绿色版

    MultiSet是一款界面简洁的自动程序安装工具。不需要编写程序,用这个程序可以是你从大量的程序安装过程中解放出来。并且可以在安装过程中实现注册信息的输入 Almeza MultiSet Pro 7.8.1绿色版 自动程序安装

    Almeza MultiSet(程序集成自动安装工具)6.7多国语言绿色特别版

    Almeza MultiSet可通过软件安装管理器将常用程序集成到一起,它先录制软件的安装过程,下次安装同一软件时就会采用“回放”的方式... 小提示:如果需要将MultiSet中的所有程序安装到位,那么直接选择“安装所有”即可

    C++multiset介绍及详细使用示例(源代码)

    ### C++ `multiset` 介绍及详细使用示例 #### 概述 在C++标准模板库(STL)中,`std::multiset`是一个关联容器,它能够存储可重复的元素,并且这些元素按照指定的排序规则进行排序。`std::multiset`中的元素默认...

    C++-中的multiset容器

    ### C++中的multiset容器详解 #### 引言 `multiset`是C++标准模板库(STL)中的一种关联容器,它主要用于存储数据,并能够从数据集合中取出数据。`multiset`的一个显著特点是它允许存储重复的键值,并且会自动根据...

    MultiSet自动程序安装工具

    让你从软件安装中解放,让你从此一键安装千万软件 让你从软件安装中解放,让你从此一键安装千万软件

    Python库 | multiset_multicover-0.2-cp310-cp310-win32.whl

    标题中的"multiset_multicover-0.2-cp310-cp310-win32.whl"就是一个这样的库,它针对Python 3.10版本进行了优化,并且适用于Windows 32位系统。 首先,我们来理解一下`multiset_multicover`库。在数学和计算机科学...

    Almeza MultiSet Pro 8.7.8 中文版 软件自动安装工具.zip

    Almeza MultiSet Pro 是一个自动安装程序用一个简单和方便的接口。很多时候,它需要花费大量的时间,用户在安装操作系统后,安装必要的程序。并在同一时间,用户需要更换光盘的CD-ROM和DVD-ROM驱动器,输入注册数据...

    C++ STL入门教程(7) multimap、multiset的使用

    C++ STL入门教程(7) multimap、multiset的使用 本文主要介绍了C++ STL中multimap和multiset的使用方法,multimap是一对多索引,multiset是多元集合,都是STL容器中非常重要的组件。 一、multimap(一对多索引) ...

    STL_multiset和STL_set–算法–笔记

    STL_multiset 方法:multisetst; 定义了一个multiset变量st,st里面可以存放T类型数据,并且能自动排序。开始st为空 排序规则:表达式”a&lt;b为true,则a排在b前面 可用的方法 目的 格式 添加元素 st.insert ...

    C++模板(vector、map、multimap、set、multiset)

    在C++标准库中,模板被广泛应用于STL(Standard Template Library,标准模板库),其中包括了各种容器如vector、map、multimap、set和multiset。这些容器都是模板类,它们提供了高效的数据组织和操作方式。 1. **...

    Python库 | multiset_multicover-0.3-cp37-cp37m-win32.whl

    在本例中,我们关注的是名为"multiset_multicover"的一个Python库,版本为0.3,它以whl(Wheel)格式提供,这是一种预编译的Python软件包格式,方便用户直接安装。 `multiset_multicover`库主要用于处理多重集...

    multiset:Java中的多集

    Java中的多集您只需要一个文件: : 因为我使用的是SpotBugs,所以有spotbugs-annotations-3.1.0.jar。 但是您也可以删除这些注释。 我的博客: :

Global site tag (gtag.js) - Google Analytics