`

1005

阅读更多

 

总时间限制:
1000ms
内存限制:
65536kB
描述
Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)

输入
The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.
输出
For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”
样例输入
2
1.0 1.0
25.0 0.0
样例输出
Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.
提示
1.No property will appear exactly on the semicircle boundary: it will either be inside or outside.
2.This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.
3.All locations are given in miles.
 
这篇文章翻译出来:
 
 
翻译有错,实属巧合!
 
描述:
Fred Mapper想要买Louisiana 的一些土地去建造他的房子,再调查土地的过程中,
他认识到Louisiana 现在正在每年以50平方米的范围缩减由于密西西比河的吞噬,
但是Fred想在靠这座房子度过他的余生,他需要知道他的土地是否会被淹没。
再做了更多的研究后,Fred认识到这里的土地正在像一个半圆形减少,这个圆形
是以(0,0)为中心,x轴把这个圆一分为2,x轴以下的都是水,这个半圆第一年的面积为0.
(半圆在下面有图解)
输入:
第一行输入一个正整数表示下面将会包含多少组数据,接下来的每一行将会包含笛卡尔坐标系
中x,y两个坐标点.这些浮点型数据都是以米(m)为单位,y坐标是非负的,不能输入(0,0).
输出:
输出每一行数据,每一行数据应该有如下格式:"Property N: This property will begin eroding in year Z.”.
 N是数据集,从1开始,Z是第一年(从1开始),将会在结束的那一年之内。Z必须是一个整数,最后一行数据,要输出
“END OF OUTPUT.”
提示:
1.半圆的边界没有数,要么在里面,要么在外面。
2.这个问题将会被自动判断,你的答案要匹配正确,包括大写,标点,空格,每一行后面都有句号
3.所有坐标都是以m为单位给出。
 
解决方案一:G++
 
 
#include<iostream>
#include<math.h>
#include<cstdio>
#define PI 3.1415926f
using namespace std ;
int main()
{
    int n ;
    cin>>n ;
    int j=1;
    while(n--)
    {
        float x ;
        cin>>x ;
        float y ;
        cin>>y ;
        double len = sqrt(x*x+y*y) ;
        double sum = 100 ;
        int i ;
        double r = sqrt(sum/PI) ;
        for(i=0;r<len;i++)
        {
            r = sqrt(sum/PI) ;
            sum = sum+100;

        }
        if(i==0){
         i= 1 ;
        }
        printf("Property %d: This property will begin eroding in year %d.\n"
                  ,j,i) ;
        j++ ;
    }
    cout<<"END OF OUTPUT."<<endl ;
       return 0 ;

}
 
 
 
解决方案二:Java
 
import java.util.Scanner;

public class Main{

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		// TODO Auto-generated method stub
     Scanner sc = new Scanner(System.in) ;
     int n = sc.nextInt() ;
     int m = n;
     float x,y;
     while(m>0)
     {
    	 x = sc.nextFloat() ;
    	 y = sc.nextFloat() ;
    	 float sum = 100 ;
    	 double len = Math.sqrt((double)(x*x+y*y));
    	 double r = Math.sqrt(100/Math.PI);
    	 int i ;
       	 for(i=0; len>r;i++)
    	 {    
    		 r = Math.sqrt(sum/Math.PI);
    		 sum += 100; 
         }
       	 if(i==0){
       		 i=1 ;
       	 }
    	 System.out.println("Property "+(n-m+1)+": This property will begin eroding in year "
        		 +i+".");
    	 
    	 
    	 m-- ;
     }
     System.out.println("END OF OUTPUT.") ;
	}

}
 
 核心思想:
 
 
 
其实就是随便选一个点,求多少年这个
 
点会被淹没。
 
 
分享到:
评论

相关推荐

    hp M1005打印机驱动

    ljM1005-HB-pnp-win2kxp-sc.exe是压缩包内的文件名,通常这样的文件是安装程序的可执行文件。lj可能是"laserjet"(激光打印机)的缩写,HB可能代表硬件或高性价比,pnp可能指即插即用(Plug and Play),win2kxp表明...

    HP1005激光打印机刷机固件

    【HP1005激光打印机刷机固件】是指针对HP1005型号的激光打印机进行固件更新的操作过程,旨在提升打印机的性能、稳定性或解决已知问题。固件是打印机内部运行的软件,它控制着打印硬件的所有功能。...

    打印机驱动 HP_ljM1005-HB-pnp-sc

    打印机驱动 HP_ljM1005-HB-pnp-sc打印机驱动 HP_ljM1005-HB-pnp-sc打印机驱动 HP_ljM1005-HB-pnp-sc打印机驱动 HP_ljM1005-HB-pnp-sc打印机驱动 HP_ljM1005-HB-pnp-sc打印机驱动 HP_ljM1005-HB-pnp-sc打印机驱动 HP_...

    惠普M1005打印机驱动

    在给定的压缩包中,文件"hp_ljm1005_drv_51820061_win7.exe"是专为惠普M1005打印机设计的Windows 7驱动程序。这个.exe文件是一个可执行文件,通常用于安装软件。在这个情况下,它是驱动程序的安装程序,用户只需双击...

    HP LaserJet M1005 MFP说明书

    ### HP LaserJet M1005 MFP 重要知识点 #### 设备基本信息 - **设备功能**:HP LaserJet M1005 MFP 是一款多功能一体机,它结合了打印、复印和扫描功能,适合办公室和家庭使用。 - **设备部件**: ...

    HP1005M激光打印机固件升级

    HP1005M激光打印机是一款经济实惠且高效的小型办公设备,主要针对个人和小型企业用户。固件升级是保持打印机性能优化和兼容性更新的重要步骤,它可以帮助解决可能出现的硬件或软件问题,提高打印质量和效率。...

    解决HP1005更换扫描头或主板复印放大变形

    本篇文章将详细探讨“解决HP1005更换扫描头或主板后复印放大变形”的技术解决方案,针对描述中提到的惠普1005一体机故障进行深入解析。 惠普1005是一款多功能激光一体机,集打印、复印和扫描功能于一体,深受小型...

    TV1005数据手册

    ### TV1005 数据手册知识点详述 #### 一、TV1005-1M 型微型精密交流电压互感器概述 ##### 1. 特点 - **体积小巧**:TV1005-1M 型微型精密交流电压互感器具有非常紧凑的设计,适用于空间有限的应用场景。 - **高...

    HPM1005驱动程序

    ljM1005-HB-pnp-win2kxp-sc.exe 是这个驱动程序的安装文件名,从文件名中我们可以获取以下信息: 1. ljM1005:这可能是HPM1005打印机系列的内部型号或代码。 2. HB:这可能代表“黑白数字”或者“高速”,暗示这是...

    hpm1005win7驱动

    关于安装HP LaserJet M1005在Windows 7上的驱动程序,用户首先需要下载这个ljM1005-HB-pnp-win32-sc.exe文件,然后双击运行,按照安装向导的提示进行操作。在安装过程中,系统会自动检测到打印机,并安装相应的驱动...

    hp_LJM1005_Full_Solution

    《全面解析惠普LJM1005一体机驱动程序》 在信息技术领域,驱动程序是连接硬件设备与操作系统的关键桥梁,确保系统能够正确识别并有效控制硬件设备。本文将详细探讨“hp_LJM1005_Full_Solution”这一解决方案,它专...

    HP1005mf恢复出厂设置

    以下将详细介绍如何对HP LaserJet M1005mfp进行恢复出厂设置的步骤。 首先,理解"恢复出厂设置"这个概念。恢复出厂设置意味着将设备的所有设置重置为最初出厂时的状态,包括网络设置、用户设置等,这通常用于解决因...

    惠普打印机LJM1005驱动.zip

    惠普打印机LJM1005驱动是一款专为惠普品牌的LJM1005型号打印机设计的驱动程序。在计算机科学中,驱动程序是一种软件组件,它允许操作系统与硬件设备进行通信,确保硬件能够正常运行。对于打印机来说,驱动程序是必不...

    打印机驱动 HP_Laser_NS_MFP_1005_1005c

    打印机驱动 HP_Laser_NS_MFP_1005_1005c打印机驱动 HP_Laser_NS_MFP_1005_1005c打印机驱动 HP_Laser_NS_MFP_1005_1005c打印机驱动 HP_Laser_NS_MFP_1005_1005c打印机驱动 HP_Laser_NS_MFP_1005_1005c打印机驱动 HP_...

    LJM1005_Full_Solution.rar

    《全面解析LJM1005打印机解决方案》 在日常办公和家庭打印需求中,一款稳定、高效的打印机驱动是至关重要的。"LJM1005_Full_Solution.rar"正是针对这一需求提供的综合解决方案,它包含了打印机驱动的完整安装包,...

    TP-LINK TL-SG1005D产品手册

    TP-LINK TL-SG1005D是一款全千兆以太网交换机,专为提升家庭和企业网络性能而设计。这款交换机的核心特点在于它提供了五个10/100/1000M自适应RJ45端口,支持自动协商功能,能根据连接的设备自动调整其传输方式和速率...

    HP-LJ-M1005-MFP-中文维修手册.pdf

    ### HP LaserJet M1005 MFP 维修手册知识点总结 #### 一、设备信息 **快速访问设备信息** - 包含了HP LaserJet M1005 MFP的基本信息,如型号和序列号等关键数据,便于用户快速获取设备的身份信息。...

    惠普M1005更换主板或者扫描组件后内容半截黑或者放大的解决办法

    【惠普M1005打印机问题解析及解决方案】 惠普M1005是一款功能丰富的激光多功能一体机,常见于小型办公室或个人使用。在更换主板或扫描组件后,可能会遇到打印或扫描内容出现半截黑或者放大的问题,这通常与硬件更换...

    sihp1005.tar.gz

    本案例中,我们关注的是"sihp1005.tar.gz"压缩包,它专门为ARMbian操作系统提供了惠普1005打印机的驱动支持。 首先,让我们了解一下ARMbian。ARMbian是一个开源项目,它基于Debian或Ubuntu,专门用于各种基于ARM...

    惠普打印机M1005固件更新

    HPM1005_Series_FW_Upgrade_20141010HP LaserJet M1005 MFP 固件更新

Global site tag (gtag.js) - Google Analytics