`
Simone_chou
  • 浏览: 192760 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

I Hate It(线段树)

    博客分类:
  • HDOJ
 
阅读更多

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28169    Accepted Submission(s): 11168

Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 
Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 
Output
对于每一次询问操作,在一行里面输出最高成绩。
 
Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
 
Q 3 4
Q 4 5
U 2 9
Q 1 5
 
Sample Output
5
6
5
9
Hint
Huge input,the C function scanf() will work better than cin

     题意:

     多case输入,每个case包含N(0到200000)个人和M(0到5000)条信息。随后给出N个人的成绩。信息有两类,当为Q  a  b时,表示求a到b号同学成绩最高的一位,输出这个成绩;当为C  a  b时,表示将a同学的成绩变为b成绩。

 

     思路:

     线段树基础题。求最大值。与之前做的求和条件有点不同而已,大致一样。将结构体的总和改成最大值就好了。

 

     AC:

#include<stdio.h>
#include<string.h>
#define MAX 2000000+5

typedef struct
{
	int st;  //区间起点
	int en;  //区间重点
	int max; //区间最大值
}node;

int student[MAX];
node no[MAX];
int ma;

//递归建树过程
void build(int from,int to,int i)
{
	int mid=(from+to)/2;
	no[i].st=from;
	no[i].en=to;
	if(from==to)
	{
		no[i].max=student[from];
		return;
	}
//当from==to的时候,只有自己的成绩,所以直接赋值就好了
	build(from,mid,2*i);
	build(mid+1,to,2*i+1);
	no[i].max=(no[2*i].max>no[2*i+1].max?no[2*i].max:no[2*i+1].max);
//这个条件改了,max值是对比最大得出
}

void change(int who,int grade,int i)
{
	int mid=(no[i].st+no[i].en)/2;
	if(no[i].st==no[i].en&&no[i].st==who)
	{
		no[i].max=grade;
		return;
	}
	if(who<=mid)   change(who,grade,2*i);
	if(who>=mid+1) change(who,grade,2*i+1);
	no[i].max=(no[2*i].max>no[2*i+1].max?no[2*i].max:no[2*i+1].max);
//同样的,这里也为对比赋值
}

void search(int from,int to,int i)
{
	int mid=(no[i].st+no[i].en)/2;
	if(from==no[i].st&&to==no[i].en)
	{
		ma=(ma>no[i].max?ma:no[i].max);
//这里也是对比得出
		return;
	}
	if(from>=mid+1) search(from,to,2*i+1);
	if(to<=mid)     search(from,to,2*i);
	if(from<=mid&&to>=mid+1)
	{
		search(from,mid,2*i);
		search(mid+1,to,2*i+1);
	}
}

int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(student,0,sizeof(student));
		memset(no,0,sizeof(no));
		for(int i=1;i<=n;i++)
			scanf("%d",&student[i]);
		build(1,n,1);
		while(m--)
		{
			char c;
			scanf(" %c",&c);
			if(c=='Q')
			{
				int from,to;
				scanf("%d%d",&from,&to);
				ma=0;
				search(from,to,1);
				printf("%d\n",ma);
			}
			if(c=='U')
			{
				int who,grade;
				scanf("%d%d",&who,&grade);
				change(who,grade,1);
			}
		}
	}
	return 0;
}

  

    14-07-19 更新 AC 代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>

using namespace std;

const int MAX = 200005;

int num[MAX], tree[MAX * 5];

void build (int node, int l, int r) {
        int mid = l + (r - l) / 2;

        if (l == r) {
                tree[node] = num[l];
        } else {
                build (node * 2, l, mid);
                build (node * 2 + 1, mid + 1, r);

                tree[node] = max(tree[node * 2], tree[node * 2 + 1]);
        }
}

int query (int node, int l, int r, int al, int ar) {

        int mid = l + (r - l) / 2;

        if (ar < l || al > r) return -1;
        else if (al <= l && ar >= r) return tree[node];
        else return max( query(node * 2, l, mid, al, ar),
                         query(node * 2 + 1, mid + 1, r, al, ar) );

}

void update (int node, int l, int r, int num, int ans) {
        int mid = l + (r - l) / 2;

        if (l == r && l == num) tree[node] = ans;
        else {
                if (num <= mid) update(node * 2, l, mid, num, ans);
                else update(node * 2 + 1, mid + 1, r, num, ans);

                tree[node] = max(tree[node * 2], tree[node * 2 + 1]);
        }

}

int main() {
        int n, m;

        while(~scanf("%d%d", &n, &m)) {

                for (int i = 1; i <= n; ++i) {
                        scanf("%d", &num[i]);
                }

                build(1, 1, n);

                while(m--) {
                        char q;
                        int a, b;

                        scanf(" %c%d%d", &q, &a, &b);

                        if (q == 'Q') {
                                int ans = query(1, 1, n, a, b);
                                printf("%d\n", ans);
                        } else {
                                update(1, 1, n, a, b);
                        }

                }

        }
}

 

分享到:
评论

相关推荐

    完全版线段树

    - `ohdu1754 I Hate It`:虽然题目描述未给出,但根据上下文,可以推测这同样是一个涉及到线段树的更新和查询的问题。 线段树的优化还包括懒惰标记(Lazy Propagation)技术,用于处理连续的区间更新,避免不必要的...

    线段树专辑

    在"敌兵布阵"中,线段树用于维护区间求和,而"I Hate It"则演示了如何使用线段树找到区间内的最值。 线段树的灵活性和高效性使其成为解决大量区间查询和更新问题的首选工具。随着对更高级数据结构如Splay树的学习,...

    线段树总结

    另一道题目 `ohdu1754 I Hate It` 可能涉及区间最值查询,但具体的实现细节未给出。 线段树可以扩展应用于各种问题,如区间加权和、区间最大值/最小值、区间异或和等。学习和熟练掌握线段树不仅有助于解决算法竞赛...

    I Hate Everything About You Tab by Three Days Grace .pdf

    I Hate Everything About You Tab by Three Days Grace .pdf

    吉他谱_I Hate Everything About You - Three Days Grace.pdf

    初级入门吉他谱 guitar tab

    题解:AtCoder Beginner Contest 262D - I Hate Non-integer Number

    代码

    I hate comment box-crx插件

    【标题】:“I hate comment box-crx插件”是一个针对浏览器扩展程序的工具,主要用于消除网页上烦人的评论框。 【描述】:“语言:中文 (繁體)”表明该插件支持繁体中文,适合中文用户使用。描述中提到“world.yam....

    第三届阿里云算法赛_i_hate_mcdonalds团队_解决方案_3rd_security_competition.zip

    第三届阿里云算法赛_i_hate_mcdonalds团队_解决方案_3rd_security_competition

    Build APIs You Won't Hate

    Build APIs You Won't Hate,教你如何构建优美的API,让你的API简单易懂!

    CSDN技术文档大全

    I hate to admit it but it was pretty bad. A very humbling experience for sure. My skills are vastly improved since that time. In fact, I've notice changes in just a few months. Have you ever gone ...

    It的用法讲解与练习题.doc

    - **指代抽象事物**:It可用于指代抽象概念,如情感状态或情境,如"I hate it when people talk with a full mouth."中的it代表了"people talking with a full mouth"这一行为。 2. **非人称代词**: - **指天气...

    my-robot.doc

    It will be a product of AI and it can do so many things for me, including helping me with all of my housework, especially cleaning the floor which i hate to do most. It could cook the meals anytime ...

    Build APIs You Wont Hate 2014.pdf

    Build APIs You Wont Hate 2014.pdf

    高中英语It的用法专项练习题.docx

    10. I hate _____ when people talk with their mouths full. "it"在此作形式宾语,真正的宾语是"when people talk with their mouths full"这个从句。答案为A. it。 11. It is the ability to do the job _____ ...

    IHate66:有一天,我在 I-66 上遇到了交通堵塞。 这就像隔天一样,但今天我想制作一个交通模拟器

    标题"IHate66"暗示了一个基于作者在I-66公路上遇到的交通拥堵经历的项目,而这个项目的目标是通过编程来模拟交通流量和可能的拥堵情况。 JavaScript,全称为ECMAScript,是一种轻量级的解释型编程语言,主要应用于...

    罗马乌尔都语中的仇恨语音检测_Hate Speech Detection in Roman Urdu

    It can incite violence, harm, or discrimination and can undermine social harmony and human rights. Detecting and mitigating hate speech is crucial for maintaining a safe and inclusive online ...

    i-hate-everyone:一个厚颜无耻的 2D 粒子系统游戏

    本文将深入探讨一款名为"I-hate-everyone"的游戏,它是一款基于2D粒子系统的厚颜无耻之作。这款游戏巧妙地运用了JavaScript编程语言,为玩家带来独特的互动体验。 首先,让我们来了解2D粒子系统。在游戏开发中,...

    语法专题十:it的用法.doc

    7. "appreciate, love, like, hate, see to(负责,注意) + it + 从句"结构中,"it"作形式宾语,真正的宾语是其后的从句。例如:"I appreciate it if you could help me."(如果你能帮我,我会很感激)。 巩固练习...

    it的用法 (2).doc

    - "I find it important (for you) to study English."(我觉得对你来说学习英语很重要。) - "He makes it a rule that he gets up before dawn."(他规定自己黎明前起床。) - "Jim takes it for granted that ...

Global site tag (gtag.js) - Google Analytics