`
Simone_chou
  • 浏览: 192855 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Ubiquitous Religions(并查集)

    博客分类:
  • POJ
 
阅读更多
Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 20788   Accepted: 10212

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.
   题意:   
   给出N(0到50000)个同学,M种关系,判断一共有多少堆同学圈。 
   思路:   
   给出关系求有多少个集合。简单并查集。
AC:
#include<stdio.h>
#define max 50000
int root[max];
int find(int a)
{
	int x=a,t;
	while(x!=root[x])
	  x=root[x];
	while(x!=a)
	{
		t=root[a];
		root[a]=x;
		a=t;
	}
	return x;
}
int main()
{
	int n,m,time=0;
	while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
	{
		int ans=0;
		time++;
		for(int i=1;i<=n;i++)
		   root[i]=i;
		while(m--)
		{
			int a,b;
			int fa,fb;
			scanf("%d%d",&a,&b);
			fa=find(a);
			fb=find(b);
			if(fa!=fb)  root[fa]=fb;
		}
		for(int i=1;i<=n;i++)
		 if(root[i]==i) ans++;
		printf("Case %d: %d\n",time,ans);
	}
	return 0;
}
    总结:
    简单并查集,跟之前做过的类型一样,当复习一遍。
分享到:
评论
2 楼 Simone_chou 2013-08-21  
沙茶敏 写道
只是来看你是不是在熬夜

当然不是。哈哈
1 楼 沙茶敏 2013-08-21  
只是来看你是不是在熬夜

相关推荐

    Ubiquitous Computing

    Stefan Poslad编著的Ubiquitous Computing原版PDF书籍 下载于http://onlinelibrary.wiley.com 书籍的信息请参见http://www.elec.qmul.ac.uk/people/stefan/ubicom

    Advances in Computer Science and Ubiquitous Computing

    《计算机科学与泛在计算的进展》(Advances in Computer Science and Ubiquitous Computing)是一部汇集了当前计算机科学领域前沿研究的重要著作。该书由Doo-Soon Park、Han-Chieh Chao、Young-Sik Jeong和James J. ...

    The Ubiquitous B-Tree

    作者Douglas Comer通过本文回顾了B树的基本概念、成功的原因,并深入探讨了其主要变体——B+树的特点和应用场景。 #### B树概述 B树是一种自平衡的多路搜索树,通常用于数据库和文件系统中。它能够维持数据的有序...

    Ubiquitous Communications and Network Computing

    Lecture Notes of the Institute for Computer Sciences, Social Informatics and Telecommunications Engineering

    Ubiquitous Computing Application and Wireless Sensor

    LNEE publishes authored monographs and contributed volumes which present cutting edge research information as well as new perspectives on classical fields, while maintaining Springer's high standards ...

    ubiquitous computing survey(关于普适计算国外大学的项目介绍)

    许多大型软件公司和流行杂志已经开始讨论这一概念,并常常创造自己的术语,但实际上描述的是类似的想法。 研究界大约十年前就开始关注这一话题,如今许多研究小组都在投入大量的努力和资金来探索普适计算的各个方面...

    商业普适计算(Ubiquitous Computing for Business)

    - **Adam Greenfield**:现任UrbanScale管理总监,并著有《Everyware: The Dawning Age of Ubiquitous Computing》,他高度赞扬本书是当前稀缺权威参考文献中的杰出作品,认为它与Kuniavsky的《Smart Things》一样,...

    System Software for Ubiquitous Computing

    随着技术的不断发展,普适计算(Ubiquitous Computing,又称Ubicomp)已成为一个重要的研究领域。普适计算强调的是将计算能力无缝地融入到日常生活中,使得用户能够在任何地点、任何时间获取所需的信息和服务。本文...

    Ubiquitous Computing教材PPT slides

    《普适计算与移动计算》教材的PPT幻灯片集合涵盖了多个章节的内容,这些章节包括但不限于 Ubiquitous Computing 的基础概念、系统架构、技术应用以及未来趋势等关键主题。以下是对每个章节幻灯片的详细解读: 1. **...

    Evolution Toward Artificial Intelligence of Things Under 6G Ubiquitous⁃X.pdf

    文章提出,物联网(IoT)将迈进人工智能的事物(AIoT)时代,并引入了 Ubiquitous-X 的概念。Ubiquitous-X 是一种提供普遍智能移动社会的基础技术,由物联网设备组成,并通过连接分享信息,实现监控和响应。 在探讨...

    An incentive compatible reputation mechanism for ubiquitous

    随着便携式设备的出现以及无线网络技术的进步,泛在计算(Ubiquitous Computing)这一愿景正逐渐变为现实。泛在计算旨在通过无缝利用周围环境中可用的服务来简化用户的任务。在这些分布式环境中,开放性是其主要特征...

    Asterisk with IPv6 Seamless and Ubiquitous VoIP

    标题与描述:“Asterisk与IPv6:无缝与无处不在的VoIP” 知识点: 一、Asterisk与IPv6的结合 Asterisk是一款开放源代码的电话系统平台,可以构建电话网络中的各种功能,如语音邮件、会议、IVR(交互式语音应答)...

    Flexible Electronics: The Next Ubiquitous Platform

    通过将柔性电子设备直接集成到人体皮肤、心脏甚至大脑上,可以实现对生理参数的实时监测,并提供更有效的治疗手段。 ##### 3.1 生物集成设备 生物集成设备是指能够直接与生物组织接触并发挥功能的柔性电子装置。...

    ISO IEC IEEE 18880:2015 Information technology — Ubiquitous green community control network protocol - 完整英文电子版(74页).pdf

    ISO IEC IEEE 18880:2015 Information technology — Ubiquitous green community control network protocol - 完整英文电子版(74页).pdf

    java版商城源码下载-ubiquitous-train:无处不在的火车

    java版商城源码下载 mall 说明 基于SpringBoot+MyBatis的电商系统,包括前台商城系统及后台管理系统。 如果该项目对您有帮助,您可以点右上角 "Star" 支持一下 谢谢! 或者您可以 ...一下,该项目将持续更新,不断完善...

    CRC.Press.Cloud.Computing.Technologies.and.Strategies.of.the.Ubiquitous.Data.Center

    《CRC.Press.Cloud.Computing.Technologies.and.Strategies.of.the.Ubiquitous.Data.Center》一书由Brian J.S. Chee与Curtis Franklin Jr.合著,由CRC Press出版社出版,隶属于Taylor & Francis集团。该书深入探讨了...

    ubiquitous-octo-fortnight

    若要深入了解"ubiquitous-octo-fortnight"项目,你需要解压文件并查看其内容,如`README.md`文件,以获取项目的具体信息和使用指南。同时,通过阅读源代码和运行测试,你可以了解项目的工作原理和实现细节。如果项目...

    ubiquitous-basson:演示版

    在深入探讨ubiquitous-basson项目之前,我们需要解压文件并查看其包含的内容,如源代码(.java文件)、配置文件(如.xml或.properties)、测试代码(.java文件位于test目录下)、文档(README.md或其他格式)以及...

    MAGE for Ubiquitous-开源

    综上所述,MAGE for Ubiquitous 是一个面向网格和无处不在环境的移动代理框架,通过其独特的三层架构实现了网络透明性,并利用开源的优势促进了其持续发展。对于那些寻求在分布式计算环境中实现高效资源管理和灵活...

Global site tag (gtag.js) - Google Analytics