`

I Hate It 线段树找区间最大值

 
阅读更多

 

I Hate It

Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2995 Accepted Submission(s): 943


Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

 

Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5
 

 

Sample Output

 

5
6
5
9

#include<stdio.h>
#define max(a,b) a>b?a:b
struct Student
{
	int zuo;
	int you;
	int date;
}student[200000*3];
int p[200000+10];
void buildtree(int a,int b,int n=1)
{
	if(a==b)
	{
		student[n].zuo=student[n].you=a;
		student[n].date=p[a];
		return;
	}
	int zhong=(a+b)>>1;
	buildtree(a,zhong,2*n);
	buildtree(zhong+1,b,2*n+1);
	student[n].zuo=a;
	student[n].you=b;
	student[n].date=max(student[2*n].date,student[2*n+1].date);
}
int addtree(int a,int b,int n)
{
	
	if(student[n].zuo==student[n].you&&student[n].zuo==a)
	{
		student[n].date=b;
		return(student[n].date);
	}
	int zhong=(student[n].zuo+student[n].you)>>1;
	int q;
	if(a<=zhong)
	{
		q=addtree(a,b,2*n);
		student[n].date=max(q,student[2*n+1].date);
	}
	else 
	{
		q=addtree(a,b,2*n+1);
		student[n].date=max(student[2*n].date,q);
	}
	return(student[n].date);
}
int findtree(int a,int b,int n)
{
	if(student[n].zuo==a&&student[n].you==b)return(student[n].date);
	int zhong=(student[n].zuo+student[n].you)>>1;
	if(b<=zhong)return(findtree(a,b,2*n));
	else if(a>zhong)return(findtree(a,b,2*n+1));
	else
	{
		int w,e;
		w=findtree(a,zhong,2*n);
		e=findtree(zhong+1,b,2*n+1);
		return(max(w,e));
	}
}
int main()
{
	//freopen("in.txt","r",stdin);
	int M,N;
	int i;
	char str[2];
	int a,b;
	while(scanf("%d%d",&N,&M)!=EOF)
	{
		for(i=1;i<=N;i++)
			scanf("%d",&p[i]);
		buildtree(1,N,1);
		while(M--)
		{
			scanf("%s",str);
			if(str[0]=='Q')
			{
				scanf("%d%d",&a,&b);
				printf("%d\n",findtree(a,b,1));
				continue;
			}
			if(str[0]=='U')
			{
				scanf("%d%d",&a,&b);
				addtree(a,b,1);
			}
		}
	}
	return(0);
}

 

 

 

分享到:
评论

相关推荐

    完全版线段树

    - `ohdu1754 I Hate It`:虽然题目描述未给出,但根据上下文,可以推测这同样是一个涉及到线段树的更新和查询的问题。 线段树的优化还包括懒惰标记(Lazy Propagation)技术,用于处理连续的区间更新,避免不必要的...

    线段树专辑

    在"敌兵布阵"中,线段树用于维护区间求和,而"I Hate It"则演示了如何使用线段树找到区间内的最值。 线段树的灵活性和高效性使其成为解决大量区间查询和更新问题的首选工具。随着对更高级数据结构如Splay树的学习,...

    线段树总结

    另一道题目 `ohdu1754 I Hate It` 可能涉及区间最值查询,但具体的实现细节未给出。 线段树可以扩展应用于各种问题,如区间加权和、区间最大值/最小值、区间异或和等。学习和熟练掌握线段树不仅有助于解决算法竞赛...

    I Hate Everything About You Tab by Three Days Grace .pdf

    I Hate Everything About You Tab by Three Days Grace .pdf

    Build APIs You Won't Hate

    Build APIs You Won't Hate,教你如何构建优美的API,让你的API简单易懂!

    吉他谱_I Hate Everything About You - Three Days Grace.pdf

    初级入门吉他谱 guitar tab

    题解:AtCoder Beginner Contest 262D - I Hate Non-integer Number

    代码

    第三届阿里云算法赛_i_hate_mcdonalds团队_解决方案_3rd_security_competition.zip

    第三届阿里云算法赛_i_hate_mcdonalds团队_解决方案_3rd_security_competition

    I hate comment box-crx插件

    【标题】:“I hate comment box-crx插件”是一个针对浏览器扩展程序的工具,主要用于消除网页上烦人的评论框。 【描述】:“语言:中文 (繁體)”表明该插件支持繁体中文,适合中文用户使用。描述中提到“world.yam....

    CSDN技术文档大全

    I hate to admit it but it was pretty bad. A very humbling experience for sure. My skills are vastly improved since that time. In fact, I've notice changes in just a few months. Have you ever gone ...

    Build APIs You Wont Hate 2014.pdf

    Build APIs You Wont Hate 2014.pdf

    It的用法讲解与练习题.doc

    - **指代抽象事物**:It可用于指代抽象概念,如情感状态或情境,如"I hate it when people talk with a full mouth."中的it代表了"people talking with a full mouth"这一行为。 2. **非人称代词**: - **指天气...

    my-robot.doc

    It will be a product of AI and it can do so many things for me, including helping me with all of my housework, especially cleaning the floor which i hate to do most. It could cook the meals anytime ...

    高中英语It的用法专项练习题.docx

    10. I hate _____ when people talk with their mouths full. "it"在此作形式宾语,真正的宾语是"when people talk with their mouths full"这个从句。答案为A. it。 11. It is the ability to do the job _____ ...

    语法专题十:it的用法.doc

    7. "appreciate, love, like, hate, see to(负责,注意) + it + 从句"结构中,"it"作形式宾语,真正的宾语是其后的从句。例如:"I appreciate it if you could help me."(如果你能帮我,我会很感激)。 巩固练习...

    罗马乌尔都语中的仇恨语音检测_Hate Speech Detection in Roman Urdu

    It can incite violence, harm, or discrimination and can undermine social harmony and human rights. Detecting and mitigating hate speech is crucial for maintaining a safe and inclusive online ...

    Stop Asian Hate! Refining Detection of Anti-Asian Hate Speech D

    Stop Asian Hate! Refining Detection of Anti-Asian Hate Speech During the COVID-19 Pandemic_停止亚洲仇恨!2019冠状病毒疾病流行期间反亚裔仇恨言语的检测.pdf

    i-hate-everyone:一个厚颜无耻的 2D 粒子系统游戏

    本文将深入探讨一款名为"I-hate-everyone"的游戏,它是一款基于2D粒子系统的厚颜无耻之作。这款游戏巧妙地运用了JavaScript编程语言,为玩家带来独特的互动体验。 首先,让我们来了解2D粒子系统。在游戏开发中,...

    it的用法 (2).doc

    - "I find it important (for you) to study English."(我觉得对你来说学习英语很重要。) - "He makes it a rule that he gets up before dawn."(他规定自己黎明前起床。) - "Jim takes it for granted that ...

Global site tag (gtag.js) - Google Analytics