`
hellobin
  • 浏览: 67241 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 488 - Triangle Wave

    博客分类:
  • UVA
 
阅读更多

In this problem you are to generate a triangular wave form according to a specified pair of Amplitude and Frequency.

 

Input and Output

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

Each input set will contain two integers, each on a separate line. The first integer is the Amplitude; the second integer is the Frequency.

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For the output of your program, you will be printing wave forms each separated by a blank line. The total number of wave forms equals the Frequency, and the horizontal ``height'' of each wave equals the Amplitude. The Amplitude will never be greater than nine.

The waveform itself should be filled with integers on each line which indicate the ``height'' of that line.

NOTE:There is a blank line after each separate waveform,excludingthe last one.

Sample Input

 

1

3
2

Sample Output

 

1
22
333
22
1

1
22
333
22
1



#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 105

int n;
int amp, fre;



void printout(bool islast){

	for(int k=0; k<fre; k++){
		for(int i=1; i<=amp; i++){
			for(int j=1; j<=i; j++){
				printf("%d", i);
			}
			printf("\n");
		}
		for(int i=amp-1; i>=1; i--){
			for(int j=1; j<=i; j++){
				printf("%d", i);
			}
			printf("\n");
		}

		if(!islast){
			printf("\n");
		}
		else{
			if(k!=fre-1){
				printf("\n");
			}
		}
	}
}

int main(){

#ifndef ONLINE_JUDGE
	freopen("488.in", "r", stdin);
	freopen("488.out", "w", stdout); 
#endif

	scanf("%d", &n);

	for(int i=0; i<n; i++){
		getchar();
		getchar();

		scanf("%d%d", &, &fre);

		if(i != n-1){
			printout(false);
		}
		else{
			printout(true);
		}
		
	}



}


#endif

分享到:
评论

相关推荐

    Python库 | Flask-Triangle-joeflack4-0.5.6.zip

    资源分类:Python库 所属语言:Python 资源全名:Flask-Triangle-joeflack4-0.5.6.zip 资源来源:官方 安装方法:https://lanzao.blog.csdn.net/article/details/101784059

    output-triangle-wave.zip_pcf8591三角波_wave

    标题中的"output-triangle-wave.zip_pcf8591三角波_wave"暗示了这是一个关于使用PCF8591芯片生成三角波形的项目。PCF8591是一款集成模拟输入/输出(I/O)的集成电路,常用于微控制器(MCU)系统中进行模拟信号的处理...

    largest-triangle-three-buckets.js

    "largest-triangle-three-buckets.js" 是一个 JavaScript 文件,实现了 Largest Triangle Three Buckets 算法。这个算法主要用于在二维平面上找到一组点中能够构成的最大三角形面积。在图像处理、数据可视化以及...

    Go-triangle-使用delaunay三角网将图像转换为计算机艺术

    "Go-triangle-使用Delaunay三角网将图像转换为计算机艺术"这个项目,利用Go语言实现了一个将像素图像转换成基于Delaunay三角网的艺术作品的工具。Delaunay三角网是一种几何构造,广泛应用于各种领域,如地理信息系统...

    Hello-Triangle-01.zip

    Hello-Triangle-01.zip

    开源项目-esimov-triangle.zip

    开源项目“esimov-triangle.zip”是一个基于Go语言实现的图像处理工具,它能够将普通的数字图像转化为计算机艺术风格的图像。这个项目的核心功能是三角化算法,它通过将图像拆分成多个三角形来创建出独特的艺术效果...

    Yang-hui-triangle-algorithm.rar_triangle

    triangle[i][j] = triangle[i - 1][j - 1] + triangle[i - 1][j]; } } printTriangle(triangle); } private static void printTriangle(int[][] triangle) { for (int[] row : triangle) { for (int num...

    js-leetcode题解之118-pascal's-triangle.js

    1. Pascal's Triangle(帕斯卡三角形)的定义:帕斯卡三角形是一个数字组成的三角形,其中每行数字左右对称,且每行的首尾数字为1,每个数字等于它正上方两数之和。 2. LeetCode题目编号118:该编号代表的是LeetCode...

    Solving-equations-triangle-line.rar_Thomas!

    标题中的"Solving-equations-triangle-line.rar_Thomas!"提到了使用Thomas算法来解决对称三角形线性方程组的问题。这是一个在数值分析领域中常用的方法,尤其适用于处理具有特定结构的线性系统。让我们深入了解一下...

    dsh-disclosure-triangle-1.0.zip

    《git-like-cli:基于Java注释的命令行框架解析》 在信息技术领域,命令行界面(CLI)一直是程序员和系统管理员的重要工具。CLI以其高效、直接的交互方式,深受技术爱好者喜爱。今天我们要探讨的是一个名为“git-...

    js-leetcode题解之119-pascal's-triangle-II.js

    在探讨Js-leetcode题解之119-Pascal's-Triangle-II.js的知识点之前,我们首先需要了解Pascal's Triangle(帕斯卡三角形)的基本概念。帕斯卡三角形是由数字组成的三角形数组,它的每一行数字都是由上一行的数字相邻...

    Draw-a-triangle--square.rar_square openGL_triangle

    链接OpenGL库,绘制一个简单的图形,比如三角形和正方形

    sierpinski-triangle.zip_Sierpinski_triangle_triangle code

    **塞尔皮斯基三角形(Sierpinski Triangle)** 塞尔皮斯基三角形,又称为谢尔宾斯基三角或谢尔宾斯基金字塔,是数学中一个经典的分形几何形状。这个图形是由波兰数学家瓦迪斯瓦夫·塞尔皮斯基在1915年提出的。它...

    python-leetcode题解之119-Pascal's-Triangle-II

    1. Pascal's Triangle(帕斯卡三角形)简介:帕斯卡三角形是一个数字阵列,每一行的数字表示组合数(C),其中每个数字等于它上方两个数字之和,边缘的数字总是1。这个三角形在数学的组合学领域具有重要作用。 2. ...

    python-leetcode题解之120-Triangle

    针对120题“Triangle”,一道典型的动态规划问题,程序员需要利用Python来编写一个有效的解决方案。这个问题要求我们找到从三角形顶部到底部的最小路径和,路径的规则是只能移动到下一行相邻的数字上。 在具体编程...

    python-leetcode题解之118-Pascal's-Triangle

    1. Pascal's Triangle(帕斯卡三角形)的定义和特性:帕斯卡三角形是一个数字三角形,每行数字左右对称,其中每行的首尾数字都是1,其余每个数字等于它上方两个数字之和。此三角形与二项式系数有密切关系,常用于...

    js-leetcode题解之120-triangle.js

    本篇题解所针对的问题是 LeetCode 上编号为 120 的题目——“Triangle”(三角形)。该问题要求编写一个函数,以处理一个代表数字三角形的二维数组,找出从顶部到底部的最小路径和,其中每次只能移动到下一行相邻的...

    gl-triangle-strip-indexer:为三角形条状网格创建元素索引

    gl-triangle-strip-indexer 创建能够传递给三角形条状网格的 WebGL 元素数组的类型化数组。 var createIndices = require ( 'gl-triangle-strip-indexer' ) var createBuffer = require ( 'gl-buffer' ) var ...

    GL2-triangle.rar_gl2.zip_triangle

    用OpenGL實現的各種三角函數分段顯示,初學OpenGL所寫的代碼。

    react-black-triangle:经过优化的React入门套件。 克隆,遵循自述文件,并在不到两分钟的时间内拥有可运行的应用程序

    HELLO:react-black-triangle(和 )的版本为v0.1-如果您发现此代码很简洁,可以让我知道您想在哪里查看更多文档,从而使它变得更好! react-black-triangle为您提供直接构建基于React的应用程序所需的代码和约定。...

Global site tag (gtag.js) - Google Analytics