`
hellobin
  • 浏览: 65462 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 623 - 500!

    博客分类:
  • UVA
 
阅读更多

 

In these days you can more and more often happen to see programs which perform some useful calculations being executed rather then trivial screen savers. Some of them check the system message queue and in case of finding it empty (for examples somebody is editing a file and stays idle for some time) execute its own algorithm.

As an examples we can give programs which calculate primary numbers.

 


One can also imagine a program which calculates a factorial of given numbers. In this case it is the time complexity of orderO(n) which makes troubles, but the memory requirements. Considering the fact that 500! gives 1135-digit number no standard, neither integer nor floating, data type is applicable here.

 


Your task is to write a programs which calculates a factorial of a given number.

Assumptions:Value of a number ``n" which factorial should be calculated of does not exceed 1000 (although 500! is the name of the problem, 500! is a small limit).

 

Input

Any number of lines, each containing value ``n" for which you should provide value ofn!

 

Output

2 lines for each input case. First should contain value ``n" followed by character `!'. The second should contain calculated valuen!.

 

Sample Input

 

10
30
50
100

 

Sample Output

10!
3628800
30!
265252859812191058636308480000000
50!
30414093201713378043612608166064768844377641568960512000000000000
100!
93326215443944152681699238856266700490715968264381621468592963895217599993229915608941463976156518286253697920827223758251185210916864000000000000000000000000

 

 

模拟乘法,预先计算好所有阶乘

 

 

#define RUN
#ifdef RUN

#include<stdio.h>
#include<string.h>
const int maxn = 3000;
int f[1000][maxn];
int tmp[maxn];


void printout(){
	for(int i=0; i<1000; i++){
		for(int j=0; j<maxn; j++){
			printf("%d", f[i][j]);
		}
		printf("\n");
	}
}

void init(){
	memset(f, 0, sizeof(f));
	memset(tmp, 0, sizeof(tmp));

	f[0][0] = 1;
	tmp[0] = 1;
	int i;
	for(i = 2; i <= 1000; i++) {
		int c = 0;
		for(int j = 0; j < maxn; j++) {
			int s = tmp[j] * i + c;
			tmp[j] = s % 10;
			c = s / 10;
		}
		memcpy(f[i-1], tmp, sizeof(tmp));
	}

	//printout();
}


int main() {

#ifndef ONLINE_JUDGE
	freopen("623.in", "r", stdin);
	freopen("623.out", "w", stdout); 
#endif

	int i, j, n;
	init();
	
	while(scanf("%d", &n) == 1){

		printf("%d!\n", n);

		if(n == 0){
			printf("1");
		}
		else{
			for(j = maxn-1; j >= 0; j--) if(f[n-1][j]) break;
			for(i = j; i >= 0; i--) printf("%d", f[n-1][i]);
		}

		printf("\n");
	}

	
	return 0;
}


#endif



 

 

分享到:
评论

相关推荐

    UVaOJ-401(Palindromes).zip_401 Palindromes

    标题中的"UVaOJ-401(Palindromes)"表明这是一个关于解决UVa Online Judge(UVa OJ)上编号为401的编程挑战,该挑战的主题是"Palindromes",即回文串。回文串是指一个字符串无论从前读到后还是从后读到前都是相同的,...

    Uva 1510 - Neon Sign

    ### Uva 1510 - Neon Sign #### 问题背景与描述 在题目“Uva 1510 - Neon Sign”中,我们面对的是一个霓虹灯招牌设计问题。该霓虹灯招牌由一系列位于圆周上的角点组成,并通过发光管连接这些角点。发光管有两种...

    uva705-Slash-Maze-.rar_Slash_uva705

    【标题】"uva705-Slash-Maze-.rar_Slash_uva705" 指向的是一个在UVa Online Judge (UVa OJ) 上提交并通过的编程问题,具体为问题编号705,名为"Slash Maze"。这个压缩包很可能包含了该问题的解决方案源代码。 ...

    开源项目-codingsince1985-UVa#uva-online-judge-solutions-in-golang.zip

    开源项目-codingsince1985-UVa#uva-online-judge-solutions-in-golang.zip,两年来每天都在解决一个uva在线裁判问题,算起来…

    UVA100~200---52道题accept代码,均顺利accept过

    这些文件名代表的是在UVA(University of Virginia)在线判题系统上解决的编程题目,主要是C++语言编写的解决方案。UVA是一个知名的在线编程竞赛平台,它提供了大量的算法问题供程序员挑战,有助于提高编程技能和...

    Algorithm-UVA-Solutions-in-Python.zip

    《Python解构UVA算法竞赛:深度探索与实践》 在计算机科学领域,算法是解决问题的核心,它是一系列精心设计的步骤,旨在高效地解决特定问题或执行特定任务。UVA(University of Virginia)在线判题系统是全球知名的...

    UVA133-TheDoleQueue.zip_site:www.pudn.com_uva133

    《UVA133 - 救济金发放问题:The Dole Queue》 在计算机科学领域,算法是解决问题的关键工具,特别是在处理复杂数据结构和优化问题时。UVA(University of Virginia)在线判题系统提供了丰富的算法题目供程序员挑战...

    uva532-Dungeon-Master.rar_dungeon

    《UVA532 Dungeon Master:解密游戏编程的深度探索》 在计算机科学与编程领域,UVA(University of Virginia)在线判题系统是一个深受程序员喜爱的平台,它提供了丰富的算法题目供学习者挑战。其中,编号为532的...

    tpcw-nyu-uva-client 客户端

    "tpcw-nyu-uva-client 客户端"是一个专为TPCW(Transaction Processing Performance Council Workloads)设计的应用程序,由纽约大学(NYU)和弗吉尼亚大学(UVA)共同开发。这个客户端软件主要用于模拟和评估数据库...

Global site tag (gtag.js) - Google Analytics