`
hellobin
  • 浏览: 65463 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

UVA 725 - Division

    博客分类:
  • UVA
 
阅读更多

 

Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits0through9once each, such that the first number divided by the second is equal to an integerN, where$2\le N \le 79$. That is,

 


abcde / fghij =N

where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

 

Input

Each line of the input file consists of a valid integerN. An input of zero is to terminate the program.

 

Output

Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).

Your output should be in the following general form:

 


xxxxx / xxxxx =N

xxxxx / xxxxx =N

.

.

 


In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions forN.". Separate the output for two different values ofNby a blank line.

 

Sample Input

61
62
0

 

Sample Output

There are no solutions for 61.

79546 / 01283 = 62
94736 / 01528 = 62

 

 

 

 

#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 1000



bool check(int a, int b){
	int repeat[11] = {0};

	if(a < 10000){
		repeat[0]++;
	}
	if(b < 10000){
		repeat[0]++;
	}

	if(repeat[0] > 1){
		return false;
	}

	while(a != 0){
		int remain = a % 10;
		if(repeat[remain] != 0){
			return false;
		}
		repeat[remain]++;
		a /= 10;
	}

	while(b != 0){
		int remain = b % 10;
		if(repeat[remain] != 0){
			return false;
		}
		repeat[remain]++;
		b /= 10;
	}

	return true;
}

void play(int n){

	int fghij = 1234;
	int abcde = n * fghij;

	bool found = false;
	for(; abcde<100000; ++fghij){
		abcde = n * fghij;
		if(check(abcde, fghij)){
			found = true;
			//自动补零
			printf("%05d / %05d = %d\n", abcde, fghij, n);
		}
	}

	if(!found){
		printf("There are no solutions for %d.\n", n);
	}
}


int main(){

#ifndef ONLINE_JUDGE
	freopen("725.in", "r", stdin);
	freopen("725.out", "w", stdout); 
#endif

	int n;

	// 有用的技巧来避免结尾多输出一空行
	bool blank = false;

	while(scanf("%d",&n)==1 && n){
		if(blank){
			printf("\n");
		}
		play(n);
		blank = true;
	}


}


#endif



 

分享到:
评论

相关推荐

    UVaOJ-401(Palindromes).zip_401 Palindromes

    标题中的"UVaOJ-401(Palindromes)"表明这是一个关于解决UVa Online Judge(UVa OJ)上编号为401的编程挑战,该挑战的主题是"Palindromes",即回文串。回文串是指一个字符串无论从前读到后还是从后读到前都是相同的,...

    Uva 1510 - Neon Sign

    ### Uva 1510 - Neon Sign #### 问题背景与描述 在题目“Uva 1510 - Neon Sign”中,我们面对的是一个霓虹灯招牌设计问题。该霓虹灯招牌由一系列位于圆周上的角点组成,并通过发光管连接这些角点。发光管有两种...

    uva705-Slash-Maze-.rar_Slash_uva705

    【标题】"uva705-Slash-Maze-.rar_Slash_uva705" 指向的是一个在UVa Online Judge (UVa OJ) 上提交并通过的编程问题,具体为问题编号705,名为"Slash Maze"。这个压缩包很可能包含了该问题的解决方案源代码。 ...

    UVA100~200---52道题accept代码,均顺利accept过

    这些文件名代表的是在UVA(University of Virginia)在线判题系统上解决的编程题目,主要是C++语言编写的解决方案。UVA是一个知名的在线编程竞赛平台,它提供了大量的算法问题供程序员挑战,有助于提高编程技能和...

    开源项目-codingsince1985-UVa#uva-online-judge-solutions-in-golang.zip

    开源项目-codingsince1985-UVa#uva-online-judge-solutions-in-golang.zip,两年来每天都在解决一个uva在线裁判问题,算起来…

    UVA133-TheDoleQueue.zip_site:www.pudn.com_uva133

    《UVA133 - 救济金发放问题:The Dole Queue》 在计算机科学领域,算法是解决问题的关键工具,特别是在处理复杂数据结构和优化问题时。UVA(University of Virginia)在线判题系统提供了丰富的算法题目供程序员挑战...

    Algorithm-UVA-Solutions-in-Python.zip

    "Algorithm-UVA-Solutions-in-Python.zip"这个压缩包文件正是针对UVA竞赛中问题的Python 3解决方案集合。 Python作为一门易学且功能强大的编程语言,因其简洁的语法和丰富的库支持,成为了许多算法爱好者和开发者的...

    uva532-Dungeon-Master.rar_dungeon

    《UVA532 Dungeon Master:解密游戏编程的深度探索》 在计算机科学与编程领域,UVA(University of Virginia)在线判题系统是一个深受程序员喜爱的平台,它提供了丰富的算法题目供学习者挑战。其中,编号为532的...

    tpcw-nyu-uva-client 客户端

    "tpcw-nyu-uva-client 客户端"是一个专为TPCW(Transaction Processing Performance Council Workloads)设计的应用程序,由纽约大学(NYU)和弗吉尼亚大学(UVA)共同开发。这个客户端软件主要用于模拟和评估数据库...

Global site tag (gtag.js) - Google Analytics