Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input
Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.
Output
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input
-1000000 9
Sample Output
-999,991
#include<stdio.h>
int main()
{
int a,b;
int sum;
while(scanf("%d%d\n",&a,&b) != EOF){
sum = a+b;
if(sum < 0){
printf("-");
sum = -sum;
}
if(sum>=1000000){
printf("%d,%03d,%03d\n",sum/1000000, (sum/1000)%1000, sum%1000);
}
else if(sum >= 1000){
printf("%d,%03d\n",sum/1000,sum%1000);
} else{
printf("%d\n", sum);
}
}
return 0;
}
分享到:
相关推荐
【JAVA】1001 A+B Format (20分) 是PAT甲级(Advanced Level)实战中的一个编程题目,目标是计算两个整数a和b的和,并按照标准格式输出,即每三位数字之间用逗号分隔,除非数字少于四位。题目要求输入为-10^6至10^6...
1001. A+B Format (20) 是一道基础的数学计算题目,要求计算两个整数a和b的和,并按照标准格式输出。标准格式指的是将数字分隔成每三个数字一组,中间用逗号隔开,除非总数少于四个数字。例如,输入为-1000000和9时...
1001. A+B Format(20分): 这是一个基础的加法问题,要求将两个整数相加,并按照标准格式输出结果。标准格式意味着数字每三位一组,用逗号隔开,除非数字少于四位。输入包含一个测试案例,包含两个整数a和b,它们...
题目 题目链接 思路 把数字转化为字符串,倒序输出 大神的都是数字直接转为字符串,学到了 代码 第一个测试点不过,有会的可以帮我... a = a + b; if(a == 0) cout << 0; if(a<0) { a = -a; cout < 0){
1. A+B Format (20) A+B Format是一个基本的计算题,要求考生编写一个程序来计算A+B的值。该题目考察了考生的基本编程能力和算法设计能力。 知识点: * 变量声明和赋值 * 基本算术运算符 * 输出格式控制 2. A+B ...
1001题——A+B Format,这道题目要求计算两个整数a和b的和,并以标准格式输出结果。标准格式是指数字每三位一组,用逗号分隔,除非数字不足四位。输入包含一个测试案例,由两个整数a和b组成,它们之间用空格隔开,且...
1. 字符串处理:在题解1001 "A+B Format"中,提到了如何将两个整数的和转换为字符串,并在转换后的字符串中,每隔三位数字插入一个逗号(除了最后四位数字)。这是典型的字符串处理技术,具体实现过程中,先将整数和...
例如,1001题"A+B Format"要求计算两个整数的和,并按照标准格式输出,即每三位数字用逗号隔开,除非是四位数以内。解题时,需要将整数和转换为字符串形式,然后逐位输出,每三位数字后加逗号,注意负号和最后一位...
**题1001:A+B Format (20)** 这道题目要求计算两个整数a和b的和,然后按照特定格式输出结果。输入包含一对整数,输出时需要将数字分隔成每三个一组,并用逗号隔开,除非总数少于四位。例如,输入-1000000和9,输出...
A+B Format(20 分) 1002 A+B for Polynomials(25 分) 解题思路 对于 C++ 版本的算法,此题并未特别说明指数为整数,但测试用例均通过。 1003 Emergency(25 分) 解题思路 先通过 dijkstra 算法求出最短的路径...
SYNONYMS pole editing, control point editing, surface editing, b-surface editing, spline editing, curve editing, shape surface, shape curve, shape spline HELP DSN_xform BITMAP xform ACTIONS ...
b 另外开上一屏; f 另外开下一屏; h 帮助; q或Ctrl+C 退出; /字符串 从上往下查找匹配的字符串; ?字符串 从下往上查找匹配的字符串; n 继续查找。 四、退出命令 exit 退出; DOS内部命令 用于退出...
对于**输出格式化**,C#提供了丰富的格式化选项,如`string.Format()`方法和`Console.WriteLine()`的格式化参数。例如: ```csharp int number = 12345; Console.WriteLine("The number is {0}", number); // 输出...
[2960379] Fix build with -Wformat -Werror=format-security by Per Oyvind Karlsen [2938273] allow instrumentation to change execute by Konrad Grochowski [2926072] Indirection operators in expressions...