完美立方
总时间限制:
1000ms
内存限制:
65536kB
描述
For hundreds of years Fermat's Last Theorem, which stated simply that for n > 2 there exist no integers a, b, c > 1 such that a^n = b^n + c^n, has remained elusively unproven. (A recent proof is believed to be correct, though it is still undergoing scrutiny.) It is possible, however, to find integers greater than 1 that satisfy the "perfect cube" equation a^3 = b^3 + c^3 + d^3 (e.g. a quick calculation will show that the equation 12^3 = 6^3 + 8^3 + 10^3 is indeed true). This problem requires that you write a program to find all sets of numbers {a,b,c,d} which satisfy this equation for a <= N.
输入
One integer N (N <= 100).
输出
The output should be listed as shown below, one perfect cube per line, in non-decreasing order of a (i.e. the lines should be sorted by their a values). The values of b, c, and d should also be listed in non-decreasing order on the line itself. There do exist several values of a which can be produced from multiple distinct sets of b, c, and d triples. In these cases, the triples with the smaller b values should be listed first.
样例输入
24
样例输出
Cube = 6, Triple = (3,4,5)
Cube = 12, Triple = (6,8,10)
Cube = 18, Triple = (2,12,16)
Cube = 18, Triple = (9,12,15)
Cube = 19, Triple = (3,10,18)
Cube = 20, Triple = (7,14,17)
Cube = 24, Triple = (12,16,20)
翻译
问题描述: a3 = b3 + c3 + d3为完美立方等式。例如123 = 63 + 83 + 103 。编写一个程序,对任给的正整数N (N≤100),寻找所有的四元组(a, b, c, d),使得a3 = b3 + c3 + d3,其中1<a, b, c, d ≤N。
输入:正整数N (N≤100)
输出:每行输出一个完美立方,按照a的值,从小到大依次输出。当两个完美立方等式中a的值相同,则依次按照b、c、d进行非降升序排列输出,即b值小的先输出、然后c值小的先输出、然后d值小的先输出。
解决方法: G++ 逐一枚举a,b,c,d,
#include<iostream>
using namespace std ;
int main()
{
int M[101] ;
int N,i ;
cin>>N;
for(i=0;i<=N;i++) M[i] = i*i*i ;
for(int a=2;a<=N;a++)
for(int b=2;b<N;b++)
for(int c=b;c<N;c++)
for(int d=c;d<N;d++)
{
int sum =b*b*b+c*c*c+d*d*d ;
if(sum==M[a])
cout<<"Cube = "<<a<<", Triple = ("<<b<<","<<c<<","<<d<<")"<<endl ;
}
}
分享到:
相关推荐
**例1:完美立方(POJ1543)**: 这是一个寻找完美立方等式的实例。给定一个正整数N,目标是找到所有满足a³ = b³ + c³ + d³的四元组(a, b, c, d),其中1, b, c, d≤N。枚举策略是遍历a, b, c, d的所有可能组合,...
例如,在"完美立方"问题(POJ1543)中,我们需要找到所有满足a³ = b³ + c³ + d³的正整数四元组(a, b, c, d),其中1 , b, c, d ≤ N。为了解决这个问题,我们可以采用四重循环枚举a、b、c、d的值,逐一判断它们...
1176, 1231, 1256, 1270, 1321, 1543, 1606, 1664, 1731,1742, 1745, 1847, 1915, 1950, 2038, 2157, 2182, 2183, 2381, 2386, 2426, 不易:1024, 1054, 1117, 1167, 1708, 1746, 1775, 1878, 1903, 1966, 2046,...
1489 2^x mod n = 1 简单题,应该有好算法,不过枚举就可以过…… 1503 One Person "The Price is Right" 简单题,POI Eggs的翻版 1512 Water Treatment Plants 简单题,组合计数 1526 Big Number 简单题,不过O(1...
1489 2^x mod n = 1 简单题,应该有好算法,不过枚举就可以过…… 1503 One Person "The Price is Right" 简单题,POI Eggs的翻版 1512 Water Treatment Plants 简单题,组合计数 1526 Big Number 简单题,不过O(1...