`

hdu 2588 GCD

阅读更多

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 405    Accepted Submission(s): 172

Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

 

Output
For each test case,output the answer on a single line.

 

Sample Input
3 1 1 10 2 10000 72

 

Sample Output
1 6 260
 
           题目大意: 给你N和M,求满足1<=X<=N,(X,N)>=M中 x的个数。
思路:要用到欧拉函数,还要算出N的约数,eular(N/约数)且约数>=M就是其中一个数的和。刚好就是,自己推一下就知道。
代码:
#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;

int a[100005];
int cnt;

int eular(int n)
{
    int i, ans = n;
    for(i = 2; i*i <= n; i++)
    {
        if(n%i == 0)
        {
            ans -= ans/i;
            while(n%i == 0)
                n /= i;
        }
    }
    if(n > 1) ans -= ans/n;

    return ans;
}

void init(int n)    //找出n的约数并保存于数组a中
{
    int i;
    cnt = 0;
    for(i = 1; i*i < n; i++)
    {
        if(n%i == 0)
        {
            a[cnt++] = i;
            a[cnt++] = n/i;
        }
    }
    if(n%i == 0) a[cnt++] = i;
    sort(a, a+cnt);
}

int main()
{
    int i, t, n, m, sum;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d %d", &n, &m);
        init(n);
        sum = 0;
        for(i = 0; i < cnt; i++)
        {
            if(a[i] >= m)
            {
                sum += eular(n/a[i]); //总和就是各个eular(n/a[i])的和
            }
        }
        printf("%d\n", sum);
    }

    return 0;
}
 
 
0
0
分享到:
评论

相关推荐

    hdu 1695 GCD(欧拉函数+容斥原理).docx

    "hdu 1695 GCD(欧拉函数+容斥原理)" 题目大意是:给定 a, b, c, d, k,找到一队 x, y,满足 g(x, y) = k,且 x ∈ [1, b], y ∈ [1, d],问有多少对符合要求的 (x, y)。 思路是:gcd(x, y) == k 解释 x, y 都能...

    HDU1019(2028)解题报告

    Least Common Multiple ...先利用gcd算法求两个数的最大公约数,再考虑最小公倍数=两数乘积/最大公约数,即可求得最小公倍数。 注意:要考虑到输入的输入的n个数中的0,有0的要去掉0求其他数的最小公倍数。 代码:

    HDU+2000-2099+解题报告

    5. **数论**:包括最大公约数(GCD)、最小公倍数(LCM)、模逆、线性同余方程、素数判断等。 6. **数据结构**:堆(大顶堆、小顶堆)、平衡二叉搜索树(AVL、红黑树)、树状数组、 Fenwick Tree(二分索引树)等。 7....

    code_hdu.rar_ACM_The First_hdu_test case example

    n and gcd(x,n)=1. For example, f(5,1)=6 and f(5,5)=11. You are given the value of m and (f(n,m)?n)⊕n, where ``⊕’’ denotes the bitwise XOR operation. Please write a program to find the smallest ...

    算术(HDU-6715).rar

    标题中的“算术(HDU-6715)”很可能是指一个编程竞赛或在线教育平台上的一个问题或挑战,通常这类题目会涉及到算法和数学的应用。由于没有具体的标签信息,我们将根据题目标题和可能的内容来推测相关的IT知识点。 ...

    人工智能基础-线性同余方程.pdf

    此外,对于一定范围内解的个数,如 HDU 1573 题目,可以先求出方程组的一个解,然后通过求解通解 `x = x0 + k * lcm` 来找到所有解,其中 `x0` 是最小非负解,`lcm` 是所有方程分母的最小公倍数。 在人工智能领域,...

    POJ3006-Dirichlet's Theorem on Arithmetic Progressions

    在解决这道POJ3006问题时,开发者可能会使用到一些基本的数论技巧,比如欧几里得算法(Euclidean Algorithm)来计算最大公约数(GCD),以及筛法(Sieve Method)来找出素数。此外,还可能涉及到高效搜索或动态规划...

    ACM程序设计 简单数学题

    1. 算术:ACM中的简单数学题可能涉及基本的加减乘除运算,以及整数的性质,例如最大公约数(GCD)、最小公倍数(LCM)的计算。有时候,快速幂算法、模逆运算等也会被用于优化计算效率。 2. 代数:线性方程、二次...

    ACM之特殊的数

    "HDUACM201509版_05 特殊的数.ppt" 这个文件很可能包含了一些具体的例子和解题思路,通过学习这个材料,你可以深入了解如何在实际问题中应用这些特殊数的概念。记住,ACM竞赛不仅是对编程技能的考验,更是对数学思维...

    kuangbin acm模板超级好用

    2.3 扩展欧几里得算法(求 ax+by=gcd 的解以及逆元) . . . . . . . . . . . . . . . 27 2.4 求逆元 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28 2.4.1 扩展欧几里德法 ...

    ACM培训讲义

    1. **数论**:模运算、最大公约数(GCD)、最小公倍数(LCM)、质因数分解等在密码学和计算复杂性分析中常见。 2. **组合数学**:排列组合、鸽巢原理、容斥原理等在处理计数问题时不可或缺。 3. **线性代数**:...

    杭电ACM的11页部分题Java源代码

    例如,求最大公约数(GCD)、最小公倍数(LCM)、质数判断等。 8. **字符串处理**:题目中提到的2030题,可能是关于字符串处理的,正则表达式是处理字符串的一种强大工具,但也可以用C语言的字符串函数解决。 9. *...

Global site tag (gtag.js) - Google Analytics