`
wanghailiang333
  • 浏览: 198743 次
  • 性别: Icon_minigender_1
  • 来自: 广西
社区版块
存档分类
最新评论

Minimal Ratio Tree

阅读更多

Minimal Ratio Tree

Problem Description

For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.



Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.

 

Input

Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the input. The next line contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the diagonal will be all 0, since there is no edge connecting a node with itself.



All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].

The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree.

 

Output

For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number; if there's a tie, look at the second smallest node number, etc. Please note that the nodes are numbered from 1 .

 

Sample Input

3 2
30 20 10
0 6 2
6 0 3
2 3 0
2 2
1 1
0 2
2 0
0 0

Sample Output

1 3
1 2

 

 

自己的解答:

最后的错误是输出格式错了,在数字的最后是没有空格的...

#include <iostream>
#include <cstring>
#include <fstream>
using namespace std;


int n,m;
int node[20],edge[20][20];
int a[20];
int tmin[20];
int minValue[2] ;  //0 分子  1 分母

int prim(){
	int i,j;
	int visE[20][20];
	int visN[20],p1,p2;
	int minE ;
	int sumNum = 0;
	memset(visE,0,sizeof(visE));
	memset(visN, 0, sizeof(visN));
	int nodeN = 1;
	visN[a[0]] = 1;
	while(1){
		minE = -1;
		for(i=0 ; i<m ; i++){
			for(j= i+1 ; j<m ;j++) if(visE[a[i]][a[j]] == 0 &&
				((visN[a[i]]!=0 && visN[a[j]]==0) || (visN[a[i]]==0 && visN[a[j]]!=0)) //点必须在已找到的点种扩展
				){
				if(minE == -1 || minE > edge[a[i]][a[j]]){
					minE = edge[a[i]][a[j]];
					p1 = a[i];
					p2 = a[j];
				}
			}
		}
		visE[p1][p2] = 1;
		visN[p1] = 1;
		visN[p2] = 1;
		sumNum += minE;
		nodeN++;
		if(nodeN == m)
			break;
	}
	return sumNum;
}

void zuhe(int _i,int cur)
{
	int i;
	if(cur==m)
	{
		// 处理
		int sumN=0,sumE=0;
		for(i=0 ; i<m ; i++){
			sumN += node[a[i]];
		}
		sumE = prim();
		if(minValue[0] == -1 || minValue[0]*sumN > sumE*minValue[1]){
			minValue[0] = sumE;
			minValue[1] = sumN;
			memcpy(tmin, a, sizeof(a));
		}
		return;
	}

	for(i=_i; i<n ; i++){
		a[cur] = i;
		zuhe(i+1,cur+1);
	}
}

int main(){

	int i,j;
	
	while(1)
	{
		cin>>n>>m;
		if(n == 0 && m == 0)
			break;

		for(i=0; i<n; i++)
		{
			cin>>node[i];  //节点的权值
		} //for
		for(i=0; i<n; i++)
		{
			for(j=0; j<n; j++)
			{
				cin>>edge[i][j];  // 边的权值
			} //for
		} //for

		minValue[0] = -1;
		memset(tmin , -1 ,sizeof(tmin));

		zuhe(0,0);

		//cout<<"ans:";
		cout<<tmin[0]+1;
		for(i=1 ; i<m ; i++){
			cout<<" "<<tmin[i]+1;
		}
		cout<<endl;


	}//while
	return 0;
}
 

 

 

0
1
分享到:
评论

相关推荐

    最小生成树+并查集题目列表.docx

    本资源提供了多种关于枚举最小生成树的题目,例如 find the most comfortable road、Minimal Ratio Tree等。 同构图 同构图是一种图论概念,指的是两个图结构相同的图。本资源提供了关于同构图的题目,例如 Hand ...

    最小的书签树「Minimal Bookmarks Tree」-crx插件

    在工具栏按钮下显示书签树,并在omnibox中使用...最小书签树是完全开源的,可在github上找到:https://github.com/rpkamp/chrome-minimal-bookmarks-tree任何和所有建议都欢迎! 支持语言:Deutsch,English,Nederlands

    运筹学课程教学设计2-Tree and minimal tree of graph树与图的最小树-英文版.docx

    运筹学课程教学设计2-Tree and minimal tree of graph树与图的最小树-英文版.docx

    ember-cli-minimal-tree:使用 ember 1.12 和 ember-data 1.0.0-beta.17 创建的最小树插件菜单

    Ember-cli-minimal-tree 这个简单的插件提供了一个前端用户菜单树,用户可以在其中添加和删除第一级或子目录中的类别。安装npm install ember-cli-minimal-tree跑步ember server 在访问您的应用程序。指示检查测试/...

    运筹学试讲2-Tree and minimal tree of graph树与图的最小树-英文版.pptx

    寻找最小树(minimal tree)是图论中的一个重要问题,这通常指的是在保持所有顶点连接性的前提下,边的总权重尽可能小的生成树。这个问题在实际应用中非常常见,例如在构建通信网络、交通路线规划或者最小成本设计...

    Minimal Bookmarks Tree-crx插件

    语言:Deutsch,English,Nederlands 在工具栏按钮下显示一棵书签树,并使用关键字“ bm”在多功能框中搜索您的书签。 此扩展程序在右上角的Chrome浏览器中添加了一个按钮(“三点”设置按钮旁边)。...

    reset_minimal.zip

    重置工具:reset_minimal.zip reset_minimal.zip 是一个压缩包文件,它包含了用于系统重置或恢复的工具。这个工具可能被设计为简洁、轻量级的解决方案,适用于那些希望快速恢复计算机到初始状态的用户。"minimal"一...

    Bootstrap Minimal v1.3

    Bootstrap Minimal v1.3 是一个基于Bootstrap框架的前端设计模板,专为网页开发人员和设计师设计。Bootstrap是最流行且广泛使用的HTML、CSS和JS框架,它简化了网页开发过程,提供了响应式布局和一系列预定义的组件,...

    minimal_adb_fastboot.zip

    《全面解析minimal_adb_fastboot.zip:安卓设备管理与刷机必备工具》 在安卓世界里,ADB(Android Debug Bridge)和fastboot是开发者和高级用户不可或缺的工具,它们为设备管理和系统刷机提供了强大的支持。...

    CentOS-7.9-x86_64-minimal

    **标题解析:** "CentOS-7.9-x86_64-minimal" 这个标题代表的是CentOS操作系统的第7版本的第9次更新(也称为7.9或2009版本),针对x86_64架构的计算机系统,采用的是精简版(Minimal)安装镜像。 **描述解读:** ...

    CentOS-7-x86_64-Minimal-1810.zip

    描述中的"CentOS-7.6-1810-x86_64-Minimal.iso"进一步确认了这是CentOS 7.6的最小化安装版,即 Minimal 版本,它是官方发布的版本,适合那些希望从头开始配置服务器或进行轻量级操作系统的用户。"1810"再次强调了...

    fp-tree详细介绍

    - 首先,我们需要设定一个最小支持度阈值(例如,minimal support = 3)。这意味着任何项集必须在至少3笔交易中出现才能被认为是频繁的。 - 对数据库中的所有交易进行扫描,统计每个项目的频率,并将这些项目按照...

    reset_minimal.rar

    标题“reset_minimal.rar”暗示了这是一个用于系统重置或恢复的基本工具,可能是为了帮助用户在Windows操作系统中解决常见问题。解压缩后得到的是一个名为“reset_minimal.cmd”的CMD批处理文件,这通常是由一系列...

    Bootstrap后台模板Minimal

    Bootstrap后台模板Minimal是一款基于Bootstrap框架设计的简洁后台管理界面模板,特别适合美工人员和初学者作为参考。Bootstrap是Twitter推出的一个开源的用于前端开发的工具包,它包含了一系列CSS和JavaScript组件,...

    CentOS 7 x86_64 Minimal 1810

    CentOS 7 x86_64 Minimal 1810

    CentOS-7-x86-64-Minimal-2009.iso

    CentOS-7-x86_64-Minimal-2009.iso是一个针对x86_64架构系统的CentOS 7版本的ISO镜像文件。它包含了运行CentOS操作系统所需的最基本组件和软件包,相较于完整版或桌面版,它没有预装许多额外的应用程序和图形界面,...

    reset_minimal.zip下载

    reset_minimal.zip 文件是一个压缩包,通常在 IT 领域中用于系统恢复或修复操作。这个特定的压缩包可能包含了一些基本的工具或者命令脚本,以帮助用户执行计算机的最小化重置。"reset_minimal.zip" 的名称暗示了它的...

Global site tag (gtag.js) - Google Analytics