`
Dev|il
  • 浏览: 125208 次
  • 性别: Icon_minigender_1
  • 来自: 成都
社区版块
存档分类
最新评论

HDU3999(The order of a Tree)

    博客分类:
 
阅读更多
The order of a Tree

Problem Description
As we know,the shape of a binary search tree is greatly related to the order of keys we insert. To be precisely:
1.  insert a key k to a empty tree, then the tree become a tree with
only one node;
2.  insert a key k to a nonempty tree, if k is less than the root ,insert
it to the left sub-tree;else insert k to the right sub-tree.
We call the order of keys we insert “the order of a tree”,your task is,given a oder of a tree, find the order of a tree with the least lexicographic order that generate the same tree.Two trees are the same if and only if they have the same shape.



Input
There are multiple test cases in an input file. The first line of each testcase is an integer n(n <= 100,000),represent the number of nodes.The second line has n intergers,k1 to kn,represent the order of a tree.To make if more simple, k1 to kn is a sequence of 1 to n.



Output
One line with n intergers, which are the order of a tree that generate the same tree with the least lexicographic.



Sample Input
4

1 3 4 2


Sample Output
1 3 2 4

题意:如果树为空,则插入的第一个数为根
     如果树不为空,则小于根的插入到它的左子树,否则插入到右子树
#include <iostream>
using namespace std;

typedef struct tree_Node{
	int data;
	struct tree_Node *lchild, *rchild;
	tree_Node(){ lchild = rchild = NULL; }
}*tree;

void dlr(tree t, bool flag)
{
	if(t != NULL)
	{
		if(flag)
		 cout<<t->data;
		else
			cout<<" "<<t->data;
		dlr(t->lchild, false);
		dlr(t->rchild, false);
	}
}
void insert(int data, tree &t)
{
	if(t == NULL)
	{
		t = new tree_Node();
		t->data = data;
		return;
	}
	if(t->data > data)
		insert(data, t->lchild);
	else
		insert(data, t->rchild);
}

void destory(tree t)
{
	if(t != NULL)
	{
		destory(t->lchild);
		destory(t->rchild);
		delete t;
	}
}
int main()
{
	int i, n, data;
	while(cin>>n)
	{
		tree t = NULL;
		for(i = 0; i < n; i++)
		{
			cin>>data;
			insert(data, t); //插入数据
		}
		dlr(t, true); //先序遍历
		destory(t); //释放内存
		cout<<endl;
	}
	return 0;
}
分享到:
评论

相关推荐

    hdu 3333 turing tree 解题报告

    题目“HDU 3333 Turing Tree”要求解决的问题是:给定一个整数序列和一系列区间,计算每个区间内不重复数字的和。由于数据规模较大(N ,000, K ,000),直接的暴力方法效率过低,因此我们需要采用一种更高效的数据...

    HDU1019(2028)解题报告

    The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105. Input Input...

    hdu.rar_hdu

    HDU(杭州电子科技大学在线评测系统)是一个深受程序员喜爱的在线编程练习平台,它提供了丰富的算法题目供用户挑战,帮助他们提升编程技能和算法理解能力。"hdu.rar_hdu"这个压缩包文件很可能是某位程序员整理的他在...

    HDU题目java实现

    【标题】"HDU题目java实现"所涉及的知识点主要集中在使用Java编程语言解决杭州电子科技大学(HDU)在线评测系统中的算法问题。HDU是一个知名的在线编程竞赛平台,它提供了大量的算法题目供参赛者练习和提交解决方案...

    HDU_2010.rar_hdu 2010_hdu 20_hdu acm20

    【标题】"HDU_2010.rar"是一个压缩包文件,其中包含了与"HDU 2010"相关的资源,特别是针对"HDU ACM20"比赛的编程题目。"hdu 2010"和"hdu 20"可能是该比赛的不同简称或分类,而"hdu acm20"可能指的是该赛事的第20届...

    code_hdu.rar_ACM_The First_hdu_test case example

    For a positive integer n, let’s denote function f(n,m) as the m-th smallest integer x that x&gt;n and gcd(x,n)=1. For example, f(5,1)=6 and f(5,5)=11. You are given the value of m and (f(n,m)?n)⊕n,...

    ACM HDU题目分类

    ACM HDU 题目分类 ACM HDU 题目分类是指对 HDU 在线判题系统中题目的分类,总结了大约十来个分类。这些分类将有助于编程选手更好地理解和解决问题。 DP 问题 DP(Dynamic Programming,动态规划)是一种非常重要...

    hdu1250高精度加法

    ### hdu1250高精度加法 #### 背景介绍 在计算机科学与编程竞赛中,处理大整数运算(特别是加法、减法、乘法等)是常见的需求之一。当数字的位数超过了标准数据类型(如`int`、`long`等)所能表示的最大值时,就需要...

    hdu1001解题报告

    hdu1001解题报告

    HDU1059的代码

    HDU1059的代码

    hdu 1574 passed sorce

    hdu 1574 passed sorce

    HDU DP动态规划

    【标题】"HDU DP动态规划"涉及到的是在算法领域中的动态规划(Dynamic Programming,简称DP)技术,这是解决复杂问题的一种高效方法,尤其适用于有重叠子问题和最优子结构的问题。动态规划通常用于优化多阶段决策...

    HDU图论题目分类

    * 题目1010:Tempter of the Bone,涉及到递归搜索的概念。 * 题目1016:Prime Ring Problem,涉及到递归搜索的概念。 * 题目1026:Ignatius and the Princess I,涉及到完全搜索的概念。 2. 图的遍历:深度优先...

    hdu.rar_HDU 1089.cpp_OJ题求和_hdu_horsekw5_杭电obj

    【标题】"hdu.rar_HDU 1089.cpp_OJ题求和_hdu_horsekw5_杭电obj" 提供的信息是关于一个压缩文件,其中包含了一个名为 "HDU 1089.cpp" 的源代码文件,这个文件是为了解决杭州电子科技大学(Hangzhou Dianzi ...

    hdu2101解决方案

    hdu2101AC代码

    HDU ACM as easy as a+b

    - **条件判断**:使用 `if` 条件语句来控制程序流程,例如 `if(a&gt;a[i+1])`。 - **数据交换**:通过中间变量 `t` 实现两个变量值的交换,如 `t=a; a=a[i+1]; a[i+1]=t;`。 #### 算法知识点 - **排序算法**:代码中...

    ACM HDU

    【ACM HDU】指的是在ACM(国际大学生程序设计竞赛,International Collegiate Programming Contest)中,参赛者在杭州电子科技大学(Hangzhou Dianzi University,简称HDU)的在线评测系统上完成并已解决的题目集合...

    杭电ACMhdu1163

    【标题】:杭电ACMhdu1163 【描述】:这是一道源自杭州电子科技大学(Hangzhou Dianzi University,简称HDU)的ACM编程竞赛题目,编号为1163。这类问题通常需要参赛者利用计算机编程解决数学、逻辑或算法上的挑战,...

    hdu 5007 Post Robot

    hdu 5007 Post Robot 字符串枚举。 暴力一下就可以了。

    hdu_2102_passed

    hdu_2102_passed_sorce

Global site tag (gtag.js) - Google Analytics