`
jackchen0227
  • 浏览: 146478 次
  • 性别: Icon_minigender_1
  • 来自: 帝都
社区版块
存档分类
最新评论

joj 1032 deck 重心的计算

    博客分类:
  • ACM
 
阅读更多

1032: Deck


Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
15s 8192K 1819 601 Standard

Scenario

A single playing card can be placed on a table, carefully, so that the short edges of the card are parallel to the table's edge, and half the length of the card hangs over the edge of the table. If the card hung any further out, with its center of gravity off the table, it would fall off the table and flutter to the floor. The same reasoning applies if the card were placed on another card, rather than on a table. 

Two playing cards can be arranged, carefully, with short edges parallel to table edges, to extend 3/4 of a card length beyond the edge of the table. The top card hangs half a card length past the edge of the bottom card. The bottom card hangs with only 1/4 of its length past the table's edge. The center of gravity of the two cards combined lies just over the edge of the table.

Three playing cards can be arranged, with short edges parallel to table edges, and each card touching at most one other card, to extend 11/12 of a card length beyond the edge of the table. The top two cards extend 3/4 of a card length beyond the edge of the bottom card, and the bottom card extends only 1/6 over the table's edge; the center of gravity of the three cards lines over the edges of the table.

If you keep stacking cards so that the edges are aligned and every card has at most one card above it and one below it, how far out can 4 cards extend over the table's edge? Or 52 cards? Or 1000 cards? Or 99999?

 

Input

 

Input contains several nonnegative integers, one to a line. No integer exceeds 99999.

 

Output

 

The standard output will contain, on successful completion of the program, a heading: 

# Cards Overhang

(that's two spaces between the words) and, following, a line for each input integer giving the length of the longest overhang achievable with the given number of cards, measured in cardlengths, and rounded to the nearest thousandth. The length must be expressed with at least one digit before the decimal point and exactly three digits after it. The number of cards is right-justified in column 5, and the decimal points for the lengths lie in column 12.

Sample Input

1
2
3
4
30

Sample Output

The line of digits is intended to guide you in proper output alignment, and is not part of the output that your solution should produce.

# Cards  Overhang 
    1     0.500
    2     0.750
    3     0.917
    4     1.042
   30     1.997

看了半天没有看懂题意,没办法

/*
	Scenario(题目描述)

如果小心摆放一张卡片,就能让它宽的那侧和桌子的一侧平行,并且,卡片的一半是能伸出桌子外面的。如果再把卡片往外放,卡片的重心脱离桌子,卡片就会从桌子上掉下来。
同理,如果卡片是被放在另一张卡片上,而不是桌子上,情况亦然。

仔细摆放两张卡片,两张卡片宽的那一侧都要与桌沿平行,要将卡片的3/4伸出桌面。上面那张卡片伸出的要比底下那张的边缘长一半。底下那张只把卡片长度的1/4伸出桌沿。
两张卡片的重心恰好位于桌沿。

三张卡片也可以类似于这样摆放,每张卡片只能接触到其中一张。要将一张卡片的11/12伸出桌面,上面两张卡片伸出的要比底下那张的边缘长3/4,底下那张只把卡片长度的1/6伸出桌沿。
三张卡片的重心恰好位于桌沿。

如果你一直堆积卡片,每张卡片的边缘都要平行,而且每张卡片上下都只与一张卡片接触,4张卡片能伸出桌沿多长的距离?52张呢?1000张呢?99999张呢?

Input

输入包含若干个非负整数,每个数占一行,且每个整数不超过99999.

Output

输出将包含:

在成功完成的程序中,有一个标题:# Cards Overhang(两个单词中间有两个空格)

接下来,每一行包含每个输入的整数以及由卡片数算出来的可达到的伸长的最大长度,为使卡片的长度更加精确,务必要四舍五入到小数点后三位.
卡片长度必须由至少一位数字在小数点之前和精确的小数点后三位来表达.卡片数要右对齐到第五列,表示长度的小数点与第十二列对齐.

解题思路:

其实看懂了题目也很简单,感觉跟各大OJ上的HangOver这道题差不多,题目要求我们算出卡片的长度,1张卡片的时候长度是1/2,2张卡片的时候长度为3/4,3张卡片的时候长度为11/12.
其实就是算1/2+1/4+1/6+...+1/n的和,1张卡片是1/2,2张卡片是1/2+1/4,n是以+2递增的,用循环就可以AC了~(还要注意下输出格式!!!)



从上面的卡片往下看,设前n-1个超越的长度是L(n-1),则再加上最下面的一个共n个超越的长度设为L(n), 可将上面的n-1个看成一个整体,最下面的单独看,
则由力矩平衡可得,(n-1)m×(L(n)-L(n-1))=m×[1/2-(L(n)-L(n-1))]  (其中m为各个卡片的质量),化简下即得递推关系式:L(n)-L(n-1)=1/2n
*/

#include <stdio.h>

int main()
{
	int n;
	printf("# Cards  Overhang\n");
	while(scanf("%d",&n) != EOF)
	{
		double sum = 0.0;
		for(int i=1;i<=n;i++)
			sum += 1.0/(2*i);
		printf("%5d     %.3lf\n",n,sum);
	}
}
 
分享到:
评论

相关推荐

    joj 部分题目答案 自己做的 仅供参考

    joj 部分题目答案 自己做的 仅供参考 joj 部分题目答案 自己做的 仅供参考 joj 部分题目答案 自己做的 仅供参考 joj 部分题目答案 自己做的 仅供参考 joj 部分题目答案 自己做的 仅供参考

    joj上做的一些ACM试题

    3. **数学应用**:组合数学、数论、图论、概率论等数学知识在ACM题目中广泛应用,例如计算几何、最优化问题、网络流等。 4. **编程语言基础**:虽然ACM比赛不限制语言,但C++、Java、Python等常用语言是选手们的...

    joj acm 部分习题解答

    【标题】"joj acm 部分习题解答"揭示了这是一份与JOJ(Judge Online Job)和ACM(国际大学生程序设计竞赛)相关的资源,主要是作者对于某些题目的解题思路和代码实现。JOJ是用于在线评测编程竞赛题目的一种平台,而...

    JOJ-jilin-university--acm.rar_joj

    【标题】"JOJ-jilin-university--acm.rar_joj" 提供的是吉林大学JOJ在线判题系统的编程竞赛代码集,主要用于帮助初学者入门。 【描述】中的信息表明,这个压缩包内的代码样例是专门为在JOJ平台上进行编程训练的学生...

    acm.rar_acm jlu 10_acm jlu 1029_joj 1237_joj10

    "joj_1237"和"joj10"可能分别对应JOJ平台上的两个具体题目编号,1237号问题和编号为10的一组题目。这些标签有助于分类和检索这些源代码,便于查找特定题目或比赛的解决方案。 在压缩包内的文件名列表中,只有一个...

    joj.rar_joj

    操作系统中的页面置换算法是内存管理的重要组成部分,尤其是在虚拟内存系统中。先进先出(First In First Out,简称FIFO)页面置换算法是一种简单的页面置换策略,它的基本思想是:当需要淘汰一个页面时,选择最早...

    Joj - Java Version of Java-开源

    Java 开源项目 Joj 是一个致力于为 Java 源代码提供对象化表示的库,它类似于 JDOM 在处理 XML 文档中的角色。Joj 的设计目标是为开发者提供一种更直观、更方便的方式来操作和解析 Java 代码,使得在处理大量 Java ...

    joj 1424 硬币兑换问题

    标题“joj 1424 硬币兑换问题”描述的是一个经典的计算机编程问题,它涉及到使用动态规划(Dynamic Programming, DP)方法来解决硬币找零问题。在这个问题中,我们要找到使用最少数量的硬币来凑成特定金额的方式。...

    JoJ-crx插件

    Etre au courant quand JoJ est en live,策划人semaine et liens vers lesréséauxauxsocioaux Soyez au courant纠结JoJ开始à流光! 现场直播将继续进行。 约翰·奎因·伊斯特·布鲁和克林·德集团的非官方网站 D...

    acm joj 1600

    根据给定的信息,本文将详细解释“acm joj 1600”中的两种大数取模运算方法。此问题主要关注如何高效地计算形如 \(a^b \mod m\) 的表达式,这对于处理大数据或进行密码学运算非常重要。 ### 大数取模运算 #### ...

    吉林大学 joj 1000-2645题代码

    吉林大学 joj 1000-2645题代码,嘿嘿,大家就不用在花JPOINT买代码了,祝ACMer实现自己的心愿

    吉林大学ACM题集.pdf-JOJ

    #### 标题:吉林大学ACM题集.pdf—JOJ 此文档标题明确指出了文档的主要内容——一个由吉林大学组织编写的ACM竞赛题集,并且该题集是以PDF格式提供的。这里提到的“JOJ”即吉林大学在线裁判系统(Jilin University On...

    一个有关调度的问题joj1015

    这个题其实现在想起来也不知道是怎么就给ac的。

    JoJo-s-Bizarre-Survival:一个模组,将JoJo的奇异冒险中的看台添加到Minecraft

    该mod基于荒木飞吕彦的JoJo的奇妙冒险漫画和动漫系列。 这个mod也受到KnightDemon的1.12 mod 极大启发。 这个mod的目的是要从专营权中尽可能多地增加Minecraft,该mod目前仅包含Stand能力,其他能力(Hamon,...

    安全文明施工管理目标【精选文档】.doc

    4. **现场管理目标**:根据JOJ59—59安全检查标准和重庆市建筑工地文明施工标准,对施工现场进行规范化管理,争取成为重庆市的安全文明施工示范工地。 5. **安全管理目标**: - **安全教育目标**:建立安全生产...

    furystudios

    furystudios 普尔维·扎达塔克(Prvi zadatak) ...DroppingOff - radnikhodajućidolazi做pripadajuće科萨雷(izvedeno kroz provjeru tagova kutije)我卡达joj JE dovoljno blizu,fizičkiJE lan

    ControlEstoque_GH:..

    Este Projeto签证是由estoque进行的,它是由mer mercadorias uma determinada empresa sejam averiguadas和atualizadas ... 2021年1月20日,由JoséCláudiodeAraújoJúnior和Annielly Ferreira de Sousa所设计。

    大智慧最新安装

    大智慧最新安装包,老的已经过期不能查询个人自选股,所以推荐最新的大智慧给大家安装

Global site tag (gtag.js) - Google Analytics