`

Greedy Gift Givers

阅读更多
Greedy Gift Givers
A group of NP (2 ≤ NP ≤ 10) uniquely named friends has decided to exchange gifts of money. Each of these friends might or might not give some money to any or all of the other friends. Likewise, each friend might or might not receive money from any or all of the other friends. Your goal in this problem is to deduce how much more money each person gives than they receive.

The rules for gift-giving are potentially different than you might expect. Each person sets aside a certain amount of money to give and divides this money evenly among all those to whom he or she is giving a gift. No fractional money is available, so dividing 3 among 2 friends would be 1 each for the friends with 1 left over -- that 1 left over stays in the giver's "account".

In any group of friends, some people are more giving than others (or at least may have more acquaintances) and some people have more money than others.

Given a group of friends, no one of whom has a name longer than 14 characters, the money each person in the group spends on gifts, and a (sub)list of friends to whom each person gives gifts, determine how much more (or less) each person in the group gives than they receive.

IMPORTANT NOTE
The grader machine is a Linux machine that uses standard Unix conventions: end of line is a single character often known as '\n'. This differs from Windows, which ends lines with two charcters, '\n' and '\r'. Do not let your program get trapped by this!

PROGRAM NAME: gift1
INPUT FORMAT
Line 1:  The single integer, NP 
Lines 2..NP+1:  Each line contains the name of a group member
Lines NP+2..end:  NP groups of lines organized like this: The first line in the group tells the person's name who will be giving gifts. 
The second line in the group contains two numbers: The initial amount of money (in the range 0..2000) to be divided up into gifts by the giver and then the number of people to whom the giver will give gifts, NGi (0 ≤ NGi ≤ NP-1). 
If NGi is nonzero, each of the next NGi lines lists the the name of a recipient of a gift. 



SAMPLE INPUT (file gift1.in)
5
dave
laura
owen
vick
amr
dave
200 3
laura
owen
vick
owen
500 1
dave
amr
150 2
vick
owen
laura
0 2
amr
vick
vick
0 0

OUTPUT FORMAT
The output is NP lines, each with the name of a person followed by a single blank followed by the net gain or loss (final_money_value - initial_money_value) for that person. The names should be printed in the same order they appear on line 2 of the input.

All gifts are integers. Each person gives the same integer amount of money to each friend to whom any money is given, and gives as much as possible that meets this constraint. Any money not given is kept by the giver.

SAMPLE OUTPUT (file gift1.out)
dave 302
laura 66
owen -359
vick 141
amr -150



分析:
The hardest part about this problem is dealing with the strings representing people's names.

We keep an array of Set structures that contain their name and how much money they give/get.

The heart of the program is the getID() function that, given a person's name, returns their Person's ID.

Note that we assume names are reasonably short.


/*
ID:xxfz014
PROG:gift1
LANG:C++
*/
#include <iostream>
#include <string>
#include <fstream>
using namespace std;
const int maxn=20;
struct node
{
    string name;
    int money;
    node(string s="0",int a=0):name(s),money(a){}
}set[maxn];
int n;
int getID(string s)
{
    for(int i=0;i<n;i++)
    if(s==set[i].name)  return i;
}
int main()
{
    ifstream fin("gift1.in");
    ofstream fout("gift1.out");

    string s;
    int a,b;
    fin>>n;
    //cin>>n;
    for(int i=0;i<n;i++)
    {
        fin>>set[i].name;
        //cin>>set[i].name;
        set[i].money=0;
    }
    for(int i=0;i<n;i++)
    {
        fin>>s>>a>>b;
        //cin>>s>>a>>b;
        if(b==0)    continue;
        set[getID(s)].money-=a;
        set[getID(s)].money+=a%b;
        for(int j=0;j<b;j++)
        {
            fin>>s;
            //cin>>s;
            set[getID(s)].money+=a/b;
        }
    }
    for(int i=0;i<n;i++)
    {
        fout<<set[i].name<<" "<<set[i].money<<endl;
        //cout<<set[i].name<<" "<<set[i].money<<endl;
    }
     fin.close();
    fout.close();
    return 0;
}

分享到:
评论

相关推荐

    USACO-Greedy-Gift-Givers.rar_greedy gift givers

    在"Greedy Gift Givers"这个题目中,我们面对的是一个贪心算法的应用问题。贪心算法是一种解决问题的策略,它在每一步选择中都采取在当前状态下最好或最优(即最有利)的选择,从而希望导致结果是全局最好或最优的。...

    USACO官网93题fps格式 OJ题库

    2 [1.1] 贪婪的送礼者Greedy Gift Givers 3 [1.1] 黑色星期五Friday the Thirteenth 4 [1.1] 坏掉的项链 Broken Necklace 5 [1.2] 命名那个数字 Name That Number 6 [1.2] 挤牛奶Milking Cows 7 [1.2] 方块转换 ...

    USACO题解(NOCOW整理版)1

    具体包括了几个不同难度级别的问题,如“Your Ride Is Here”,“Greedy Gift Givers”,“Friday the Thirteenth”和“Broken Necklace”。每个问题的解析都提供了算法思想和解决方案,有的通过简单的数学计算,有...

    1_your ride is here_usaco_TheAnswer_YourRideisHere_

    在提供的压缩包文件名称列表中,我们看到多个源代码文件,如 "1_your ride is here - 副本.py" 和 "2_greedy gift givers.cpp",这些文件很可能是不同参赛者或解题者提交的代码。Python 文件可能对应于 "Your Ride ...

    USACO所有题目题解

    本文主要解析其中三个题目:“Your Ride Is Here (ride)”,“Greedy Gift Givers (gift1)”,以及“Friday the Thirteenth (friday)”。 1. **Your Ride Is Here (ride)**: 这是一个相对简单的问题,属于"ad hoc...

    USACO英汉对照题目

    1.1.1 "Your Ride Is Here" 和 "Greedy Gift Givers" 可能涉及到基本的数据结构和贪心算法。 1.1.3 "Friday the Thirteenth" 可能需要理解日期和时间处理,以及可能的数学计算。 1.1.4 "Broken Necklace" 可能涉及...

    第1章总结1

    1.1节中的题目主要是模拟问题,例如"Your Ride Is Here"和"Greedy Gift Givers",通过模拟操作实现算法。同时,"Friday the Thirteenth"题目引入了模运算,"Broken Necklace"则涉及到数组的使用。 接着,1.2节重点...

    usaco题目的副本1

    在"Greedy Gift Givers"这个题目中,可能需要使用哈希表来统计礼物的分布情况,或者在"Broken Necklace"题目中,利用哈希表记录不同颜色的珠子的数量。 2. **Python内置函数`ord()`和`chr()`**:`ord()`函数用于...

    USACO(Train)解题报告.doc

    ### Chapter 1 Section 1.2 - Greedy Gift Givers (gift1) 该题目的难度与联赛第一题相当,要求计算每个人在分发礼物后的盈余。通过使用数组`incom`和`outcom`分别记录每个人的收入和支出,并利用哈希表优化,可以...

Global site tag (gtag.js) - Google Analytics